1. Joom

    OP Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,420
    Country:
    United States
    So, this is incredibly annoying, and Google has produced absolutely useless results. I have my laptop connected to my TV over HDMI, and use a wireless keyboard with a built in trackpad (it's a cheapo Logitech, but it gets the job done). The problem I'm facing is the obnoxious trackpad gestures. I'm constantly either opening the multitask view or that stupid Cortana helper, even though I have Cortana uninstalled. The catch to this is that Windows only detects this keyboard as a generic HID device, thus treating it like a standard mouse and not offering gesture options. The device just uses the generic Microsoft driver, too, so there's no control panel for it like there typically is for a Synaptics device or whatever. I found a guide somewhere that involves editing the Registry, but I think that only applies to the internal trackpad. Does anyone know of a way to handle this, or maybe a third party tool that can manage input devices like this? Not sure if it's important, but I'm running build 2004 through Boot Camp on a mid-2015 MBP.

    Update: I feel rather dumb, and hate how this is a common scenario for me, but I managed to find something immediately after posting this thread. Seeing as the Group Policy Editor is only available on certain versions of Windows, I guess my original searches were too broad. At any rate, if anyone else has this problem, disable Edge UI using either Regedit or GPE (Pro and Enterprise only).
    https://www.tenforums.com/tutorials/48507-enable-disable-edge-swipe-screen-windows-10-a.html
     
    Last edited by Joom, Aug 7, 2020
    The Real Jdbye likes this.
  2. JuanMena

    JuanMena Obviamente no me importa lo que tú pienses
    Member

    Joined:
    Dec 17, 2019
    Messages:
    1,302
    Country:
    Mexico
    It's probably recognizing your Trackpad as some kind of tablet... probably.

    Try going to Flicks and Gestures on Settings or Control Panel.
    Then, disable everything.
     
  3. Joom

    OP Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,420
    Country:
    United States
    It's not an available option for whatever reason. I've read somewhere that this is a design flaw in Windows 10, and it doesn't properly handle HID devices due to the generic Microsoft driver. Anyway, immediately after posting this thread, I found out I could use the Group Policy Editor to disable Edge UI (one-finger edge gestures), and this seems to have done the trick.
     
  4. JuanMena

    JuanMena Obviamente no me importa lo que tú pienses
    Member

    Joined:
    Dec 17, 2019
    Messages:
    1,302
    Country:
    Mexico
    Do you have a touchscreen device?
     
  5. Joom

    OP Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,420
    Country:
    United States
    No, it's a Logitech K400r. It's just a lower-end wireless keyboard with a built-in trackpad. I like using it when my computer is hooked to the TV because it makes for excellent couch use.
     
  6. JuanMena

    JuanMena Obviamente no me importa lo que tú pienses
    Member

    Joined:
    Dec 17, 2019
    Messages:
    1,302
    Country:
    Mexico
    I was asking about your laptop.
    I'm aware of what kind of keyboard you're using.
    It sounded like a driver thing, but I'm glad to know you've fixed it.
    Try debloating your laptop. I've debloated it and I don't have Cortana anymore.

    Is easy, and all you have to do is to use Windows Powershell and one command.
     
  7. Joom

    OP Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,420
    Country:
    United States
    I have debloated it. Like I said, I have Cortana itself uninstalled, but the right edge swipe gesture still brings up this "helper" window that isn't part of the base Cortana application. And about my laptop, no, it doesn't have a touch screen. It's a mid-2015 MacBook Pro, which is the model just before Apple started implementing touch interfaces.
     
  8. JuanMena

    JuanMena Obviamente no me importa lo que tú pienses
    Member

    Joined:
    Dec 17, 2019
    Messages:
    1,302
    Country:
    Mexico
    WHAT¡?
    Windows + MAC?

    Well, again, if you've solved the problem, I guess there's nothing else I can try to say.
     
  9. Joom

    OP Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,420
    Country:
    United States
    Yeah, Macs come with a utility called Boot Camp that allows you to dual boot Windows. Since PCIe pass through isn't possible on this machine, I have Windows for games, and use macOS for everything else. Since both systems are on the same SSD, switching between the two is nearly seamless.
     
    JuanMena likes this.
  10. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08
    Member

    Joined:
    Mar 17, 2010
    Messages:
    19,728
    Country:
    Norway
    I get that stupid task view constantly on my laptop, and I thought it was something in the Synaptics driver itself but couldn't find out how to disable it. Thanks for the solution.
     
  11. JuanMena

    JuanMena Obviamente no me importa lo que tú pienses
    Member

    Joined:
    Dec 17, 2019
    Messages:
    1,302
    Country:
    Mexico
    Have you both tried to look in Device Manager?
     
  12. Joom

    OP Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,420
    Country:
    United States
    I've come across conflicting reports pertaining to Synaptics pads. Apparently some have been able to disable the gestures through the Synaptics configuration tool, but it seems really dependent upon the version of the driver that's available for the machine.
     
  13. Desraptor

    Desraptor Member
    Newcomer

    Joined:
    Apr 28, 2019
    Messages:
    29
    Country:
    Germany
    U Lucky Man. I have still the same Annoying Problem with EdgeUI on my Trekstor Suftab.
    I bought a Pro Licence but the "Edge UI" Path doesnt exist on it in my group Policies.

    For System-Wide -> Configuration>Administrative Templates>Windows Components>Edge UI
    or User -> Configuration>Administrative Templates>Windows Components>Edge UI

    i Also tried other different solutions i found on the web, but with no functional result.
     
  14. Joom

    OP Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,420
    Country:
    United States
    This seems to be the consensus across the web, unfortunately. It's very hit or miss in everything I've come across. Have you come across this? It was the first thing I tried, which didn't work, but it might for you.
    https://superuser.com/questions/949334/disable-new-gestures-in-windows-10
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Trackpad, Gestures, Keyboard