Homebrew Can someone find a way to create cia installer for 11.0 hbl no downgrades?

Status
Not open for further replies.

bisharpofdeath

Member
OP
Newcomer
Joined
Aug 5, 2016
Messages
7
Trophies
0
Age
34
XP
74
Country
United States
So, I got a couple of eshop download cias, and I need someone to make a cia installer for 11.0 to please the hbl users. So if someone could bypass kernel exploits, and maybe modify nasa to work without kernel exploits, that would be great! We need help from the hbl dev community to make installation possible on 11.0. Please, just somebody needs to find a bypass to install cias and we need your help! The community needs to bring itself together to do this, so are you homebrew devs ready?
 
  • Like
Reactions: ImCarlosGG

KapuDaKoopa

That One Splatoon Dataminer
Member
Joined
Mar 12, 2016
Messages
474
Trophies
0
XP
984
Country
United States
CIA Installers require the signature checks to check if the CIA is signed or not to be patched, allowing for un-signed CIAs to be installed
To patch sigchecks, we need an emuNAND
To use an emuNAND, we need an arm9 exploit
The only currently known arm9 exploits are on 9.2

So basically you need to downgrade to be able to install unsigned CIAs
 

Boured

A Dusk Lycanroc who cares a lot about people.
Member
Joined
Sep 25, 2015
Messages
594
Trophies
0
Age
24
Location
My Laptop
XP
725
Country
United States
So, I got a couple of eshop download cias, and I need someone to make a cia installer for 11.0 to please the hbl users. So if someone could bypass kernel exploits, and maybe modify nasa to work without kernel exploits, that would be great! We need help from the hbl dev community to make installation possible on 11.0. Please, just somebody needs to find a bypass to install cias and we need your help! The community needs to bring itself together to do this, so are you homebrew devs ready?

It is possible to install CIAs to a non-CFW system. They have to have a legit signature or be the pre-installed version.

These are known as Legit-CIA's and Legit CIA can only be created from pre-installed CIA's

An example would be a Pre-Installed Pokemon X on a brand new 3DS. Turn that into a CIA and install it onto a non-CFW system and it will show up as normal since to the 3DS it has a valid signature.

Games that never had a preinstalled version or homebrew CIA need CFW
 
Last edited by Boured,
  • Like
Reactions: KapuDaKoopa

Ricken

Searching for the air to breathe~
Member
Joined
Jan 19, 2016
Messages
2,661
Trophies
1
Age
21
Location
Mid-Michigan
XP
2,958
Country
United States
So, I got a couple of eshop download cias, and I need someone to make a cia installer for 11.0 to please the hbl users. So if someone could bypass kernel exploits, and maybe modify nasa to work without kernel exploits, that would be great! We need help from the hbl dev community to make installation possible on 11.0. Please, just somebody needs to find a bypass to install cias and we need your help! The community needs to bring itself together to do this, so are you homebrew devs ready?
No we are not ready. This is literally

EDIT; Ok, if we were to sign every .cia it would sorta be, yet we would still need a Kexploit
 

KapuDaKoopa

That One Splatoon Dataminer
Member
Joined
Mar 12, 2016
Messages
474
Trophies
0
XP
984
Country
United States
Now that I think about it, how DOES a CIA get signed anyway?

Does it use the 3DS' secret keys to sign the CIA once it's pre-installed?
 

Ricken

Searching for the air to breathe~
Member
Joined
Jan 19, 2016
Messages
2,661
Trophies
1
Age
21
Location
Mid-Michigan
XP
2,958
Country
United States
Now that I think about it, how DOES a CIA get signed anyway?

Does it use the 3DS' secret keys to sign the CIA once it's pre-installed?
Ninty themselves modify a .cia to have legal keys on every system, and throw them onto a system pre-installed
actually we are able to install legit cias on latest fw but there is no point creating a thing like that could take weeks
Then why did we wait 'til Memchunkhax2 to install the legits?
 

KapuDaKoopa

That One Splatoon Dataminer
Member
Joined
Mar 12, 2016
Messages
474
Trophies
0
XP
984
Country
United States
Ninty themselves modify a .cia to have legal keys on every system, and throw them onto a system pre-installed

ah ok thanks

I wonder if we'll ever find a way to sign CIAs, although I highly doubt it'll ever be possible :/
 
  • Like
Reactions: Ricken
D

Deleted User

Guest
Maybe. Who knows? (You'd only be able to install legit cias tho)
 

Drakia

Well-Known Member
Member
Joined
Mar 15, 2008
Messages
1,644
Trophies
2
Age
36
XP
2,596
Country
Canada
It is possible to install CIAs to a non-CFW system. They have to have a legit signature or be the pre-installed version.

These are known as Legit-CIA's and Legit CIA can only be created from pre-installed CIA's

An example would be a Pre-Installed Pokemon X on a brand new 3DS. Turn that into a CIA and install it onto a non-CFW system and it will show up as normal since to the 3DS it has a valid signature.

Games that never had a preinstalled version or homebrew CIA need CFW
No, we can't, not on 11.0. Even "legit" CIA installation requires an arm11 kernel exploit.

Now that I think about it, how DOES a CIA get signed anyway?

Does it use the 3DS' secret keys to sign the CIA once it's pre-installed?
Nintendo has a key, that key is used to sign all "legit" pre-installed games, every console ships with that key being marked as valid.

ah ok thanks

I wonder if we'll ever find a way to sign CIAs, although I highly doubt it'll ever be possible :/
If we brute force it, then maybe a few billion years after the solar system burns out, sure
 

The Catboy

GBAtemp Official Catboy™: Boywife
Member
Joined
Sep 13, 2009
Messages
27,927
Trophies
4
Location
Making a non-binary fuss
XP
39,260
Country
Antarctica
Everything involving CIA, including homebrew and pirated games, will require a CFW to work. There is no way around this and no way to make it work on OFW.
Currently there are only two methods to downgrade with 11: DSi and hard mod
https://github.com/Plailect/Guide/wiki/Firmware-Downgrade
As there is no kernel exploit for 11 nor any other way to downgrade to an exploitable system. If you want to go down the hard mod path, here's a list of people to hit up
http://gbatemp.net/threads/list-of-hardmod-installers-by-region.414224/
 
Last edited by The Catboy,
  • Like
Reactions: Sonic Angel Knight

Sonic Angel Knight

Well-Known Member
Member
Joined
May 27, 2016
Messages
14,397
Trophies
1
Location
New York
XP
12,926
Country
United States
Everything involving CIA, including homebrew and pirated games, will require a CFW to work, there is no way around this and no way to make it work on OFW.
Currently there are only two methods to downgrade with 11: DSi and hard mod
https://github.com/Plailect/Guide/wiki/Firmware-Downgrade
As there is no kernel exploit for 11 nor any other way to downgrade to an exploitable system. If you want to go down the hard mod path, here's a list of people to hit up
http://gbatemp.net/threads/list-of-hardmod-installers-by-region.414224/
You also forgot to add not to ask if someone else can find, or do or create things, simply enough if you can't do it, just suggest it and accept any rejected or acceptable answers. When and if it can or will be done, it will be noted and made possible. Pressuring people to do things cause you either can't or don't know how or want to, doesn't change anything or make anyone wanna do it if not presented in a positive manner.
 
  • Like
Reactions: Temarile

TheCyberQuake

Certified Geek
Member
Joined
Dec 2, 2014
Messages
5,012
Trophies
1
Age
28
Location
Las Vegas, Nevada
XP
4,432
Country
United States
So, I got a couple of eshop download cias, and I need someone to make a cia installer for 11.0 to please the hbl users. So if someone could bypass kernel exploits, and maybe modify nasa to work without kernel exploits, that would be great! We need help from the hbl dev community to make installation possible on 11.0. Please, just somebody needs to find a bypass to install cias and we need your help! The community needs to bring itself together to do this, so are you homebrew devs ready?
Currently anything beyond 9.2 can not install unsigned CIAs because you need an arm9 kernel exploit to do that. Past 9.2* you can install legit CIAs (games that came bundled with a console) but that is a very limited list and requires arm11 kernel.
Edit: anything up to 11.0*

actually its possible to install legit cias on latest fw but there is no point creating a thing like that could take weeks
Actually no you can't install legit CIAs on 11.0 (yet) because you need an arm11 kernel exploit, which we don't have on 11.0.
 
Last edited by TheCyberQuake,

fikatr

Well-Known Member
Member
Joined
Mar 29, 2016
Messages
919
Trophies
0
Location
next to smea
XP
809
Country
Turkey
Currently anything beyond 9.2 can not install unsigned CIAs because you need an arm9 kernel exploit to do that. Past 9.2 you can install legit CIAs (games that came bundled with a console) but that is a very limited list and requires arm11 kernel.


Actually no you can't install legit CIAs on 11.0 (yet) because you need an arm11 kernel exploit, which we don't have on 11.0.
my wrong m8 sorry i read it i think i read it somewhere nvm
 

Swiftloke

Hwaaaa!
Member
Joined
Jan 26, 2015
Messages
1,771
Trophies
1
Location
Nowhere
XP
1,499
Country
United States
Ninty themselves modify a .cia to have legal keys on every system, and throw them onto a system pre-installed

Then why did we wait 'til Memchunkhax2 to install the legits?
Technically, Ninty failed to patch memchunkhax3 again. However, exploiting it would be extremely difficult because of their meddling, not impossible.
my wrong m8 sorry i read it i think i read it somewhere nvm
No, you're right. Technically.
 

Swiftloke

Hwaaaa!
Member
Joined
Jan 26, 2015
Messages
1,771
Trophies
1
Location
Nowhere
XP
1,499
Country
United States
That doesn't change that we need access to an Arm11 Kexploit
Again. We technically have an arm11 kexploit. Though I won't argue with you that we need access to it ;)
Also,
So, I got a couple of eshop download cias, and I need someone to make a cia installer for 11.0 to please the hbl users. So if someone could bypass kernel exploits, and maybe modify nasa to work without kernel exploits, that would be great! We need help from the hbl dev community to make installation possible on 11.0. Please, just somebody needs to find a bypass to install cias and we need your help! The community needs to bring itself together to do this, so are you homebrew devs ready?
I... just... what do I say to this?
It's not that simple. We can't just "bypass kernel exploits". We need access to the kernel to get to the services that handle CIA installation, which only the kernel has. Also, like, WTAF? What... I... just don't even. I hope this isn't too rude, mods, but I feel as though this is the occasion I've been waiting for to use this::gun:
 
Status
Not open for further replies.

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    Xdqwerty @ Xdqwerty: yawn