Update 11.10 and Homebrew

Discussion in '3DS - Homebrew Development and Emulators' started by GalladeGuy, May 28, 2019.

  1. KleinesSinchen

    KleinesSinchen The backup reminder

    Member
    8
    Mar 28, 2018
    Germany
    It depends on your device. I guess it's 11.10.0-43E. All other regions than "E" can use the otherapp payload for 11.9.

    For the "new" devices there is already some unofficial(?) payload:
    https://gbatemp.net/threads/new-2ds-xl-jailbreak-help.539675/#post-8657104
    Don't know anything for the old 2/3DS.

    Your options are:
    • Try the (unofficial?) otherapp payload from reddit. (New 2/3DS only)
    • Wait until otherapp is available.
    • Use Fredminer method – requires having or buying any (cheap) DSiWare. No otherapp needed.
    • ntrboot – requires a compatible flashcart.
     
    Quantumcat and Daedronus like this.
  2. Rockstead

    Rockstead GBAtemp Regular

    Member
    5
    Sep 10, 2013
    Canada
    I haven't update for forever, so I'm a little lost.

    I'm using Luma 3DS, I thought I was using emunand but not so sure anymore.

    When I look at my system settings, it shows Ver. 11.6.0-39U

    When I go to system settings - Update, the update process starts but then it keeps failing and says an error has occurred and update can't be complete.

    Not sure what to do next, any help would be appreciated.
     
  3. Daedronus

    Daedronus Newbie

    Newcomer
    1
    Jun 2, 2019
    New Zealand
    Thank you very much, Kleines! I got it to work with the reddit file.

    Was just looking to play all my US games on my E system.
     
    Quantumcat and KleinesSinchen like this.
  4. Kwyjor

    Kwyjor GBAtemp Fan

    Member
    5
    May 23, 2018
    Canada
    A change in Github broke the Luma updater, so you need to get the latest version by manually downloading it and putting it on your SD card.

    Emunand is extremely old; I think you can check if you have it by using the "Show NAND or user string in System Settings" setting in the Rosalina menu. If you are using AL9H, you will need to to the "AL9H to B9S" portion of http://3ds.guide before upgrading to the latest Luma.
     
  5. IK12345

    IK12345 Newbie

    Newcomer
    1
    Jun 11, 2018
    United Kingdom
    I currently have an EU Old 3DS. Installing the 11.10 update has prevented me from accessing the homebrew menu through Steel Diver, and I can't find any way to fix this. What are my options to get homebrew working again?
     
  6. KleinesSinchen

    KleinesSinchen The backup reminder

    Member
    8
    Mar 28, 2018
    Germany
    Look at my post above. The otherapp payload needs to be updated for the "E" region. I don't know of any new payload for the old models yet.

    Installing full CFW with another method (Fredminer/ntrboot) will – of course – also restore homebrew access.
     
  7. AAAAARRRGH

    AAAAARRRGH Newbie

    Newcomer
    1
    Jun 5, 2019
    United States
    11.10 doesn't patch cfw, only updates spotpass
     
  8. Zach9o9

    Zach9o9 Advanced Member

    Newcomer
    3
    Mar 31, 2016
    United States
    So any solid news on OoTHax, or something? I'm not looking to modify my 3DS or anything, just access the Homebrew Menu to access SVDT for some of my digital saves.
    My system says 11.10.0-43U, and the Zip I got from yellows8's OoTHax github doesn't have anything for the later firmwares, it seems.

    I apologize if I'm being a bother.
     
    Last edited by Zach9o9, Jun 15, 2019
  9. Kwyjor

    Kwyjor GBAtemp Fan

    Member
    5
    May 23, 2018
    Canada
    If you've already been using oot3dhax with 11.7U, 11.8U, or 11.9U, then there is nothing to update as the payload hasn't changed.

    If you've been using 11.6 or older, then see my post on the second page of the thread. If you need a Powersaves, then there might be a thread around here somewhere with a Powersaves for the 11.7U payload. (The 11.7 payload still works on 11.10.)

    Also, while I personally don't think it's unreasonable to stick with homebrew instead of installing CFW, you might want to consider using JKSM instead of SVDT.

    ...To be clear, I haven't tested oot3dhax myself, but as long as you have the right payload, then in light of what has been seen so far, it seems vastly unlikely that 11.10 will have somehow broken it specifically. Please post once you've confirmed it is functional. ;)
     
    Last edited by Kwyjor, Jun 15, 2019
  10. Zach9o9

    Zach9o9 Advanced Member

    Newcomer
    3
    Mar 31, 2016
    United States
    20 TIMES SWITCHING BETWEEN MY SIS' O3DS, POWERSAVES, AND 30+ DIFFERENT FILES, I GOT IT

    A round-about method that worked for me was:
    1. Get the latest otherapp.bin that will work for your system (Smealum's site. If people complain, I'll link it) and rename it to payload.bin.
    2. Using yellow8's pre-made OoTHax Powersave set, find the save that works for your game (The game doesn't give you a "Save Data is Corrupted" Message) and have it on your OoT3D card.
    3. Using a separate 3DS that has a working Homebrew loader, use JKSM to pull the save from the game. Turn off the 3DS and retireve the SD card and insert it into your PC.
    4. On the PC, swap the payload.bin that was ripped from save with the latest one you got from Smealum.
    5. Reinsert the SD card into the Homebrew 3DS, and use JKSM to Import the save to your OoT3D card.

    That should do it.

    I'll swap SVDT with JKSM on my N3DS. I can also pull my OoT3D file via Powersave and upload it later; I just want a decent File hosting site first.
     
  11. Kwyjor

    Kwyjor GBAtemp Fan

    Member
    5
    May 23, 2018
    Canada
    Yikes, that sounds exhausting.

    To be clear: if you have a second 3DS that has a working Homebrew loader, then the Powersaves is completely unnecessary. Just use the offline oot3dhax sploit installer I mentioned in my earlier post.

    Also, I think you can attach files to posts on this board. No file hosting is necessary.
     
    Last edited by Kwyjor, Jun 15, 2019
    Quantumcat likes this.
  12. Zach9o9

    Zach9o9 Advanced Member

    Newcomer
    3
    Mar 31, 2016
    United States
    In fairness, I tried that. Except whenever I went to install it, it kept giving me an "Error: FFFFFFFF" (something about the inability to write to Save0.bin, or something along those lines). I followed the steps carefully, yet it kept pulling that same error.

    Then the only other Powersave I could find with a working link was for a different OoT3D card, thus giving me the "Corrupted Save" error.

    So I just decided to MacGyver it a bit using your previous post. Since it seemed that JKSM would also pull the payload.bin after extracting, I decided to go off that as a launch and went to swap the payload. It was a bit of a round-about method, but since some of the options I was trying wasn't working, gotta improvise somewhere.
     
    Last edited by Zach9o9, Jun 15, 2019
  13. Kwyjor

    Kwyjor GBAtemp Fan

    Member
    5
    May 23, 2018
    Canada
    Well, that's troubling. I haven't tried it myself, but it is two and a half years old and it's possible too many things have changed in that time.

    Did it ask you to select a target when you started it from the Homebrew Launcher? Did you select Ocarina of Time?

    Did the regular sploit-installer not work either?
     
  14. Zach9o9

    Zach9o9 Advanced Member

    Newcomer
    3
    Mar 31, 2016
    United States
    Yes to both of them.

    It did not work either. I don't recall the error, but it wasn't working regardless.
     
  15. Zach9o9

    Zach9o9 Advanced Member

    Newcomer
    3
    Mar 31, 2016
    United States
    This is the Powersave I pulled from my card, should someone need it.

    The Payload is for a New 3DS, as well as a specific Card type, so if it doesn't work for one reason or another, I apologize.

    May it serve the people well for now.
     

    Attached Files:

    Last edited by Zach9o9, Jun 17, 2019
    Kwyjor likes this.
  16. JeeBee42

    JeeBee42 Newbie

    Newcomer
    1
    Jun 17, 2019
    United States
    It seems when I tried using that file to replace another file, it went in as "corrupted". I'm not sure how to fix that, tbh. Using old 3ds 11.10.0.43U, so maybe there's a step I'm missing. I just make a random backup on the Powersaves, replace it and rename it with the provided save file, but it always ends up corrupt.
     
  17. PKMNMANIAC

    PKMNMANIAC Newbie

    Newcomer
    1
    Oct 28, 2015
    Greece
    I was about to install ninjhax through my sky3ds, then i checked my firmware and i felt so dissapointed with the whole thing.
     
  18. Zach9o9

    Zach9o9 Advanced Member

    Newcomer
    3
    Mar 31, 2016
    United States
    A few things, really. First, the payload.bin in the file is built for the New 3DS Model, so there could be issues alone, but the other issue being..
    Each OoT3D game has a "Card ID." If the game is returning a "Corrupted Save" upon startup on your 3DS, then the ID my save is using doesn't match up with your card.

    If it's through the PowerSave program you're getting the issue, I'll look into it on my end.
     
  19. Kwyjor

    Kwyjor GBAtemp Fan

    Member
    5
    May 23, 2018
    Canada
    As suggested, the old 3DS has an entirely different payload than the New 3DS.

    Anyway, as long as you have access to Steel Diver: Sub Wars on the eShop (which is a free download unless you're using some obscure country setting), you should try using steelhax first.

    I have no idea what you mean by that.
     
  20. JeeBee42

    JeeBee42 Newbie

    Newcomer
    1
    Jun 17, 2019
    United States
    Yeah, as Kwyjor and yourself pointed out, definitely the payload messing with it. I'm going to also do as suggested and try steelhax. Had difficulty making it work last time, but I'll give it another go. Payload should be good.

    I just wanted to access Homebrew to get to my TWLSave and import a DS save file to my cartridge lol. Lotta flaming hoops first.
     
    Last edited by JeeBee42, Jun 18, 2019
Loading...