RetroArch - A new multi-system emulator

Discussion in 'Wii - Emulation and Homebrew' started by Toad King, Aug 23, 2012.

Thread Status:
Not open for further replies.
  1. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    24
    GBAtemp Patron
    the_randomizer is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    So, I was playing Snes9x Next for a while then I switched to the FCEUmm core (requiring a reset) and played then for a while. After that, I switched back to the Snes9x Next core and the emulator prompted me to reset, so I did that. Well, when I reset RetroArch a second time, that's when it displayed the invalid format error and the blue LED is lit up.

    To replicate error

    1 - Open up RetroArch and change to Snes9x Next core (if it's not already on it) and reset the emulator as prompted
    2 - Open up a random Snes/Super Famicom ROM and play that for a while
    3 - Once you're done, switch to the FECUmm core, reset the emulator and play that for a while
    4 - Once done with that second core switch back to Snes9x Next and reset
    5 - At this point, the emulator should display the "invalid format" error while the disc slot LED is solid blue

    In total, there you should be prompted three times to reset it when switching from Snes9x Next > FCEUmm > Snes9x Next

    If no one else can replicate this error, then I'll end up looking like an idiot with a false positive. I don't think it's those specific emulator cores per se, but switching back and forth that many times between any two cores may be the issue itself. Sounds like a memory leak when swapping that many times in a short period of time.

    Running the emulator off a Kingston 16GB Class 4 SDHC card.
     
  2. Hielkenator

    Hielkenator GBAtemp Psycho!

    Member
    5
    Feb 7, 2010
    Netherlands
    No the isseu is here too, I think it's only happening switching From Snesgx and to snes gx.
     
  3. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    24
    GBAtemp Patron
    the_randomizer is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    I don't use the Snes9xGx core, only the Next core, that's the thing.
     
  4. Hielkenator

    Hielkenator GBAtemp Psycho!

    Member
    5
    Feb 7, 2010
    Netherlands
    Yes sorry that's what meant.
     
  5. Dogway

    Dogway GBAtemp Regular

    Member
    2
    Aug 16, 2010
  6. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    24
    GBAtemp Patron
    the_randomizer is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    No worries. Hopefully LibretroRetroArch can test it out and see what's going on.
     
  7. Hielkenator

    Hielkenator GBAtemp Psycho!

    Member
    5
    Feb 7, 2010
    Netherlands
    Install them with a wadmanager.
     
  8. Dogway

    Dogway GBAtemp Regular

    Member
    2
    Aug 16, 2010
    Install the wads (not the forwarders) you mean... I installed them, they simply don't work.
     
  9. mastershoes

    mastershoes GameTDB Mod

    Member
    9
    Jun 25, 2011
    United States
    Strange, no else has had a problem that i'm aware of, and there working great for me..

    Forwarding paths:
    usb/apps/retroarch-wii/boot.dol
    sd/apps/retroarch-wii/boot.dol

    and
    usb/apps/sdlmame-wii/boot.dol
    sd/apps/sdlmame-wii/boot.dol
     
    1 person likes this.
  10. chop

    chop GBAtemp Fan

    Member
    2
    Apr 14, 2010
    Pontefract
    ------------------------------------------------------------------------------
    What can you expect in the future?
    ------------------------------------------------------------------------------

    - Port of MAME 0.72 to libretro
    What's the thinking behind 0.72 that's quite an old version I think WiiMame is 0.134
     
  11. Hielkenator

    Hielkenator GBAtemp Psycho!

    Member
    5
    Feb 7, 2010
    Netherlands
    You need de apps in your apps folder on your sd card.
    It's called a forwarder for a reason...it forwards so your apps folder on your sd card.
    These forwarder channels are working fine.
     
  12. Gamecuber

    Gamecuber Advanced Member

    Newcomer
    2
    Aug 29, 2012
    Switzerland
    Horsepower. Wii/Gamecube/Xbox are not fast enough to handle newest MAME port at full speed.
    If you want Mame 0.134, play it on your PC.
     
  13. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    24
    GBAtemp Patron
    the_randomizer is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 29, 2011
    United States
    Dr. Wahwee's castle

    I see an advantage in doing so, newer versions of MAME don't work with older ROM dumps due to accuracy changes, plus like was said, it would be less taxing on the Wii's PowerPC CPU.
     
  14. Dogway

    Dogway GBAtemp Regular

    Member
    2
    Aug 16, 2010
    @[member='mastershoes']: I revised the paths and they are correct, sdlmame was lacking the hyphen, corrected that but everything is the same, I even reinstalled the wads.
    @[member='Hielkenator']: Nice to know they work FOR YOU, that's all, they don't work for me and the same can happen to anybody else.

    I don't know if it's because the versions, I use retroarch 0.9.7.1 and sdlmame v.0.6, HBC 1.0.7, and no IOS58. Installed with waninkoko wadmanager 1.7, using Base IOS249.
     
  15. Hielkenator

    Hielkenator GBAtemp Psycho!

    Member
    5
    Feb 7, 2010
    Netherlands
    Use yet another wad manager
    Use yet another wad manager (yawm). And install with ios 236. ( try it )
    By the way if you do not have ios 236 I recon your soft mods are out of date. ( check this )
    Are you running the latest HBC? (no you are not)

    When you say base IOS249, what IS it based on then? ( ios56,58,38,57 etc ) ( you did not specify )

    There should be no reason this forwarder should not work. ( all wii's are basicly the same concerning homebrew )
     
  16. Dogway

    Dogway GBAtemp Regular

    Member
    2
    Aug 16, 2010
    IOS249 base38
    I don't think I have IOS236, but I will try to install with YAWM and edit if succeeded.
    I don't know why now would I need IOS236 really, I never needed it before.

    I go to test.
    edit: No, it doesn't work either. The screen stays black and the wiimote turns off.
     
  17. Hielkenator

    Hielkenator GBAtemp Psycho!

    Member
    5
    Feb 7, 2010
    Netherlands
    IOS 236 grant acces. It's a patched IOS 36 installed in IOS slot 236.
    Not related to your problem probably but I still wanted to mention your better of upgrading your softmod.
    Your cIOS are outdated and your are potentionally missing out on SaveNand Emulation, and not being able to play IOS reloading games Properly.
    Also the latest HBC is protected in case of an update ( 4.3 )

    I recommend using modmii to get all your files.
    http://www.google.co...RR4F06dv7RHVPBw

    Tell modmii your wii has never been modded, or at least get the lates hackmii installer and update your cIOS.
    http://bootmii.org/download/

    If you HBC is'nt running on IOS58 yet, you can install it seprately and then reinstall the HBC. After that you'll have usb2.0 available on your HBC.
    The latest HBC also fixed a bug involving crashing by programs if a Network connection is'nt available.
     
  18. Dogway

    Dogway GBAtemp Regular

    Member
    2
    Aug 16, 2010
    Thanks for all the suggestions but I do the updates manually, I like to know what I do, and I don't want either IOS58 or HBC higher than 1.0.7. Other than that everything is updated (I don't know why you say they are outdated).
    In any case, what does this have to do with a forwarder not working? :s
    I don't have any objection to install IOS236, but only if strictly necessary.
     
  19. bm123456

    bm123456 GBAtemp Advanced Fan

    Member
    5
    Jun 7, 2011
    United States
    Houston
    All Mastershoes forwarders need ios58 to work.just download the homebrew installer and your forwarder will work.
     
    1 person likes this.
  20. Dogway

    Dogway GBAtemp Regular

    Member
    2
    Aug 16, 2010
    Thanks for the input! I think I'll pass on this then.

    EDIT: I just tried a quick edit and worked. Changed the required start IOS from 58 to 35, grab them here for the oldskoolers like me:
    RetroArch & SDLMame-Wii forwarders (IOS35)
     
Loading...
Thread Status:
Not open for further replies.