Memory Pit - A new DSi exploit for DSi camera!

Discussion in 'NDS - Emulation and Homebrew' started by shutterbug2000, May 27, 2019.

Loading...
  1. carrieshot

    carrieshot Advanced Member

    Newcomer
    2
    Apr 19, 2015
    United States
    I need to figure out which cables are for the camera heh
     
    alexander1970 likes this.
  2. zoogie

    zoogie playing around in the dsiware

    Member
    21
    Nov 30, 2014
    Micronesia, Federated States of
    Your problem is likely nand corruption. Maybe a borked twl photo partition. The error screen you've shown is indicative of filesystem issues, not hardware issues.

    You should really follow the advice in my previous post. It's your best shot.
    Even if there's no flipnote, download all the titles you can and maybe one will be able to take photos and help fix your nand issue.
     
    Last edited by zoogie, Jun 15, 2019
  3. carrieshot

    carrieshot Advanced Member

    Newcomer
    2
    Apr 19, 2015
    United States
    you talking about the flipnote post you made or?
     
  4. zoogie

    zoogie playing around in the dsiware

    Member
    21
    Nov 30, 2014
    Micronesia, Federated States of
  5. carrieshot

    carrieshot Advanced Member

    Newcomer
    2
    Apr 19, 2015
    United States
    I don't have any actual apps in the store, went to check
     
  6. carrieshot

    carrieshot Advanced Member

    Newcomer
    2
    Apr 19, 2015
    United States
  7. KleinesSinchen

    KleinesSinchen The Backup Reminder

    Member
    8
    Mar 28, 2018
    Germany
    I can confirm the "An error has occurred"-screen for hardware issues. Disconnecting the camera lets the DSi boot to "Launcher" normally. Pressing (L) or (R) for taking a photo results in the error screen. However, opening the camera app does not crash.
    So I think it can be hardware or software issue.
    I guess your problem is that the camera app wants to run the pointless tutorial – where you have to take a photo and trying to do so→ ERROR!

    First check if the camera ribbon is connected correctly, not torn and the connector looks okay. It is near the (R)-button. Maybe remove and reinsert carefully.
    Camera_ribbon.

    If cable and connector look good but it does not work… this will suck:
    https://www.ifixit.com/Guide/Nintendo+DSi+Dual+Camera+Assembly+Replacement/4159
    (if you even find a replacement camera module).

    Because it could as well be a software issue – zoogie knows this waaay better than me – it is not an easy target for troubleshooting. So many possible causes of error.

    If you're good at soldering you might as well try the hardmod (removing mainboard – no taking ribbons out of the hinge).

    Sadly "Failzone" was never released.
     
    Last edited by KleinesSinchen, Jun 15, 2019
  8. DSUPERY92

    DSUPERY92 GBAtemp Regular

    Member
    2
    Jul 3, 2018
    Italy
    Tested with dumped and converted dsi camera cia for 3ds,works.
     
    Tarmfot likes this.
  9. SlasherGamer21

    SlasherGamer21 Advanced Member

    Newcomer
    1
    Jun 27, 2019
    Saudi Arabia
    Hell
    I'm surprised the DSi scene is still alive
     
    Tarmfot and alexander1970 like this.
  10. DSUPERY92

    DSUPERY92 GBAtemp Regular

    Member
    2
    Jul 3, 2018
    Italy
    To tell you, it has recently been said that 3ds will not have games for the whole of 2019 but it will always be updated from nintendo and ... the 3ds scene is still alive.
     
  11. reymas101

    reymas101 Professional GBAtemp Noob

    Member
    4
    Nov 4, 2015
    United States
    New York
    Did you happen to figure out what was causing it? I'm having the same issue right now. It's been stuck at the copying TwiLight files for 15+ minutes now
     
  12. reymas101

    reymas101 Professional GBAtemp Noob

    Member
    4
    Nov 4, 2015
    United States
    New York
    Nvm. Just had to wait a bit longer. However now when I open TwiLight the opening plays and then the screen stays white. Any help?
     
  13. Lemon_Chippy

    Lemon_Chippy Newbie

    Newcomer
    1
    Aug 9, 2019
    Philippines
    Can you help me please?? I got a green screen after I carefully followed all the steps necessary to run the exploit. Also my version is 1.4.5U and I'm using a 4gb FAT32 memory card and it doesn't seem to work on me even if I use the latest release of beta memory pit. Please help me, I really want to exploit my dsi :(
     
  14. zoogie

    zoogie playing around in the dsiware

    Member
    21
    Nov 30, 2014
    Micronesia, Federated States of
    Format your sd card and try again.
    https://www.sdcard.org/downloads/formatter/
     
  15. Lemon_Chippy

    Lemon_Chippy Newbie

    Newcomer
    1
    Aug 9, 2019
    Philippines
     
  16. raxadian

    raxadian GBAtemp Advanced Fan

    Member
    5
    Nov 10, 2018
    Argentina
    It helps that the recent exploit works in every DSi and people are appreciating DSi games more now that the only way to get the digital versions is hacking.
     
  17. Paul_IDK

    Paul_IDK Newbie

    Newcomer
    1
    Aug 19, 2019
    France
    I don't know if that's how i'm supposed to do it but i tried launching a rom via TWiLight Menu++ and i get an error 1 : nds-bootstrap not found.
    Can someone tell my how i'm really supposed to launch games or if it's a real error, does anyone know how to fix it ?
    Thanks
     
    Last edited by Paul_IDK, Aug 19, 2019
  18. raxadian

    raxadian GBAtemp Advanced Fan

    Member
    5
    Nov 10, 2018
    Argentina
  19. alexander1970

    alexander1970 GBAtemp allows me to be here

    Member
    11
    Nov 8, 2018
    Austria
    Austria
    Hello.:)

    Maybe a post of your Issue in the TWiLight Thread is certainly more noticed than here.:)
    https://gbatemp.net/threads/ds-i-3d...-ds-i-games-and-ds-i-menu-replacement.472200/

    And please tell also us how do you installed TWiLight Menu please.
    (Because in the package is ALL you need including nds-bootstrap).

    You can also maybe try to install it manually:
    https://github.com/ahezard/nds-bootstrap/releases

    Thank you.:)
     
  20. Paul_IDK

    Paul_IDK Newbie

    Newcomer
    1
    Aug 19, 2019
    France
    Well I installed it automatically with the HiyaCFW installer. Would there be a way of uninstalling only TWiLight Menu++ or do i need to format my SD card and start over again ?
    Is it ok to format my SD card and start over from the beginning or can it cause some problems ?
     
    Last edited by Paul_IDK, Aug 20, 2019
    alexander1970 likes this.
Loading...