Softmodded My 4.0 but want to Upgrade to 4.1

Discussion in 'Wii - Hacking' started by That-Guy, Jul 22, 2009.

Jul 22, 2009
  1. That-Guy
    OP

    Newcomer That-Guy Advanced Member

    Joined:
    Jul 17, 2009
    Messages:
    82
    Country:
    United Kingdom
    OK well now the hacks are available for preloader on 4.1 I think I might as well upgrade.

    I softmod using the bannerbomb method. The files I have for 4.0 are:

    - boot.dol
    - DowngraderIOS35.dol
    - Wadmanager 1.4
    - IOS35.wad
    - CIOSv7.wad
    - IOS36.wad
    - IOS60patched.wad
    - CIOSrev10
    - CIOSCORP

    The questions I have are as follows:

    1) Will the files above work with 4.1 or do I need to get diferent ones?

    2) Above is CIOSrev10 but is the latest CIOSrev13b?

    3) Do I need all them files above? Also are there any others I should install?


    Thanks
     
  2. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    You shouldn't need the downgraderIOS35.dol, IOS35.wad, cIOSv7.wad, or the IOS36.wad, or the cIOSrev10 installer anymore. boot.dol is just about as vague as you can get about an application. Every application (.dol) that you run should be named boot.dol. I'm assuming that's like the hackmii installer or an older HBC installer or something that you most likely don't need anymore if you have the HBC now. If you still have the bannerbomb files on your sd card delete those as well.

    Updating will get rid of any CIOSCORP install. Running that cIOSrev10 installer already overwrote that CIOSv7.wad install and rev13b is the latest, but rev13a would be better to update to. Rev14 may possibly be out in a couple days.

    You may need to patch IOS60 again after the update if you still want to play vc wad's from the sd card menu, but I'm not positive on whether or not that works the same on 4.1 though it should.

    If you don't even use the sd card menu then 4.1 will pretty much do absolutely nothing for you.
     
  3. nknave

    Member nknave GBAtemp Regular

    Joined:
    Jun 23, 2009
    Messages:
    154
    Country:
    Mexico
    All you have to do is download using NUSD is SystemMenu4XX.WAD of your System. (Example: NTSC is 449).


    download with this code: 0000000100000002 v4xx (xx.......well you know)

    Download the latest hacks.ini file for Preloader that is compatible with System Menu 4.1 and do the following:

    - Run HBC, Run WAD Manager (I recomend 1.4 and selecting IOS to use as an installer)
    - in WAD Manager, install SystemMenu4xx.wad, exit WAD Manager
    - run Preloader and it will Reinstall it self.


    Done, you don't have to do more, and you will not loose any hacks that you already have.


    Good Luck and as always, this is at your own risk. I did it at mine and I have it working perfectly fine.


    Cheers!!!
     
  4. That-Guy
    OP

    Newcomer That-Guy Advanced Member

    Joined:
    Jul 17, 2009
    Messages:
    82
    Country:
    United Kingdom
    Yes the boot.dol is the Hackmii Installer [​IMG]

    So if I was doing a Virgin Wii that had 4.1 I would use the following files with no problems:

    boot.dol (hackmii installer)
    DowngraderIOS35.dol
    Wadmanager 1.4
    IOS35.wad
    CIOSv7.wad
    IOS36.wad
    IOS60patched.wad
    CIOSrev10
    CIOSrev13b
    CIOSCORP
    Preloader 0.29

    Is this correct?

    Also does this work with Wii's with any serial number?
     
  5. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    I don't recommend directly installing system menu wad's to anyone not completely certain of what they are doing.

    Just run Waninkoko's 4.1 updater and if you still REALLY need CIOSCORP, then install that again and patch IOS60 if necessary as well.

    Edit:
    No this does not work on any Wii. You cannot downgrade IOS35 on new Wii's and CIOSCORP, while dangerous to install on any Wii blindly, cannot install on new Wii's at all unless you use a certain recent version of it from softmii 3.0 I believe. (not suggesting it either way)

    The way to hack a virgin new Wii is to run bannerbomb with the hackmii installer, install the HBC with it, run the Trucha Bug Restorer from WiiPower to downgrade IOS15, use IOS15 to install an IOS36 with the trucha bug, restore IOS15 (as shown here http://www.youtube.com/watch?v=ltrd3oq8hPc...re=channel_page ), then run the cIOS rev13a installer using IOS36 and do a network installation if you have wifi. This will be enough to run any backups through a loader such as NeoGamma R6 for discs or USB Loader GX or any other usb loader for loading games from a usb device.

    THIS method will work on ANY wii of any firmware of any serial number.
     
  6. That-Guy
    OP

    Newcomer That-Guy Advanced Member

    Joined:
    Jul 17, 2009
    Messages:
    82
    Country:
    United Kingdom
    Thank You for your help you have been great.

    Last question I promise:

    You said:
    By "new Wii's" do you mean any virgin wii with 4.1 or ones with a certain serial number?
     
  7. nknave

    Member nknave GBAtemp Regular

    Joined:
    Jun 23, 2009
    Messages:
    154
    Country:
    Mexico
    Serial Number is LU64+, now known as Boot2v4, and the simple way to know is by trying to install BootMii with HackMii installer, if you can't install to Boot2, than you have one of these Wii's and you shouldn't downgrade nor install cIOSCorp untill new cIOSCorp is released (IF ever released).


    Cheers!!!
     
  8. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    Yea Firmware doesn't really have anything to do with how new a Wii is. It's the boot2v4 Wii's that can't downgrade IOS's outside of what WiiPowers TBR does.

    It's better to be safe and just use the TBR for any Wii since there are no types of Wii's that it doesn't work on and it's just as easy if not easier than any other method.

    And a bit of background to what CIOSCORP is. It basically takes an old dip module from an older cIOS revision and patches EVERY IOS on your system with it and installs them over the official IOS's on your system to achieve the end result of seeing a little animated video of whatever game is in the drive in the disc channel before you play it instead of just clicking on a backup loader channel to load the game without any animations. For older IOS's it just completely replaces them with that same cIOS.
     
  9. That-Guy
    OP

    Newcomer That-Guy Advanced Member

    Joined:
    Jul 17, 2009
    Messages:
    82
    Country:
    United Kingdom
    Thanks for you help guys have learnt a lot.

    I love this site [​IMG]
     
  10. morph80

    Newcomer morph80 Newbie

    Joined:
    Sep 17, 2006
    Messages:
    7
    Country:
    I'm still on 3.2U and am now wondering if its worth while me going to 4.1U for the sake of compatibility and future proofing. Would I lose any features? any advice would be much appreciated.

    If I did decide to go 4.1U, would the following be correct?

    Install Boot Mii and make nand backup.
    Install Bannerbomb
    Install cIOS 38 r13
    Use Firmware-Updater_4.1 or just use System Update via Wii?
    Install preloader
    Install USB loader GX and NeoGamma

    Am I missing any other IOS or App?
     
  11. YayMii

    Member YayMii hi

    Joined:
    Jun 24, 2009
    Messages:
    4,881
    Location:
    that place
    Country:
    Canada
    No. You use Bannerbomb FIRST. Bannerbomb is what you use to install Bootmii (don't forget the Homebrew Channel). Then you install the latest cIOS to 249, update, install Preloader, then use loader of choice (make sure if you use USB loader that you format the USB drive as WBFS, and have a manager on your computer to put games).
     

Share This Page