Internal modchip - SAMD21 (Trinket M0, Gemma M0, ItsyBitsy M0 Express) Guide, Files & Support

Discussion in 'Switch - Tutorials' started by mattytrog, Jun 20, 2018.

  1. pmc

    pmc Newbie

    Newcomer
    1
    Sep 24, 2018
    United Kingdom
    hi @mattrytrog do you offer a service for installing trinket m0? dont want to risk it myself! cheers
     
  2. edwardsalazar97

    edwardsalazar97 Member

    Newcomer
    1
    Jul 11, 2019
    Colombia
    hello my switch has all the straps connected, and it starts well without the charger, it injects the payload, but when it has the charger it starts the ofw, the chip is an m0 trinket with the Part_1_TRINKET_PERMA_CFW_Latest installed, it should not remain in rcm and start only when disconnected the charger to not burn efuse
    @mattytrog
     
  3. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    13
    Apr 27, 2018
    United Kingdom
    Still not getting notifications!

    Yep can fit a chip @pmc inbox me.

    @edwardsalazar97 you are correct. You have a loose strap or an incorrect connection somewhere sir.
     
    pmc likes this.
  4. edwardsalazar97

    edwardsalazar97 Member

    Newcomer
    1
    Jul 11, 2019
    Colombia
    I already checked 10 times and as I say without the connected charger starts the cfw, but with the charger directly starts the ofw @mattytrog

    — Posts automatically merged - Please don't double post! —

    I have the connected USB strap, the joycon, and the volume @mattytrog
     
  5. mattytrog
    OP

    mattytrog You don`t want to listen to anything I say.

    Member
    13
    Apr 27, 2018
    United Kingdom
    And you are using perma part1 file?

    Strange.

    Try dropping the part 2 UF2 on there again but keep USB connected for 5 seconds after dropping it on there.
     
  6. edwardsalazar97

    edwardsalazar97 Member

    Newcomer
    1
    Jul 11, 2019
    Colombia
    if I use Part_1_TRINKET_PERMA_CFW_Latest, I have already done it several times and the straps seem to work whenever I do not have the charger connected, when I have the charger connected it starts directly cfw, I understand that it should remain in rcm, until I disconnect it and so if it would start, right ? @mattytrog
     
    Last edited by edwardsalazar97, Sep 17, 2019
  7. edwardsalazar97

    edwardsalazar97 Member

    Newcomer
    1
    Jul 11, 2019
    Colombia
    I have changed the chip and I get the same result
     
  8. pmc

    pmc Newbie

    Newcomer
    1
    Sep 24, 2018
    United Kingdom
    will do cheers
     
    Last edited by pmc, Sep 17, 2019
  9. edwardsalazar97

    edwardsalazar97 Member

    Newcomer
    1
    Jul 11, 2019
    Colombia
    Oh god, have I lost the resistance? or the component that goes with the volume + strap, now the volume does not rise, I managed to put a similar component that I found on an old plate, functional the volume for a while after it goes up only forever @mattytrog
     
    Last edited by edwardsalazar97, Sep 18, 2019
  10. DfknG

    DfknG Newbie

    Newcomer
    1
    Jan 4, 2019
    Australia
    Thanks @mattytrog
    I had a look I actually do have some wick but I cant get it to take. I've moved the capacitor and i'm worried that i'll lift a pad.
    If you can inbox me as I cant inbox you and if there's a way I can get this device to you i'd greatly appreciate it.
    From you're responses you'll not want to accept but expect some donations heading your way for work done.


    Many thanks.
     
  11. salitoshater

    salitoshater Newbie

    Newcomer
    1
    Apr 13, 2019
    Germany
    @edwardsalazar97 no need to replace the cap.

    i completely removed mine and bridged the contacts. i wasn't able to solder at this point. I made 20-30 attempts, with Fluxer, without, with leaded solder and without. No success.
    If this SMD component is missing, there are no disadvantages (as long as the contacts are connected). It is also mentioned here in the thread over and over again.
     
  12. edwardsalazar97

    edwardsalazar97 Member

    Newcomer
    1
    Jul 11, 2019
    Colombia
    if the problem is that I joined them but the volume button is always stuck @salitoshater
     
  13. edwardsalazar97

    edwardsalazar97 Member

    Newcomer
    1
    Jul 11, 2019
    Colombia
  14. edwardsalazar97

    edwardsalazar97 Member

    Newcomer
    1
    Jul 11, 2019
    Colombia
    Last edited by edwardsalazar97, Sep 18, 2019
  15. recgame77

    recgame77 GBAtemp Regular

    Member
    2
    Dec 25, 2015
    Cameroon
    Hi where did you connected pin 2 3 and 4 ; not related but i dont fully get it still based on the thread pics.
     
  16. edwardsalazar97

    edwardsalazar97 Member

    Newcomer
    1
    Jul 11, 2019
    Colombia
    I have already solved it, volume + and - buttons working perfectly with 100 ohms resistors, the power button strangely did not work with any resistance of 100 or 150, it started working normal with 50 ohms quite strange but it already works
     
  17. ShadyGame

    ShadyGame GBAtemp Regular

    Member
    5
    Sep 12, 2009
    Portugal
    i think i ripped 1 of the 2 pins of the joycon mod, when trying to remove the solder, now my switch wont detect my right joycon, only bluetooth, what can i do?

    that means no rcm mode also :/
     
    Last edited by ShadyGame, Oct 1, 2019
  18. edwardsalazar97

    edwardsalazar97 Member

    Newcomer
    1
    Jul 11, 2019
    Colombia
    @ShadyGame change the tape for a new one, and for rcm you can do it with a jig or a clip

    — Posts automatically merged - Please don't double post! —

    @recgame77 I advise you to check the images well, if you do not understand it, it is best that you do not damage the console
     
  19. ShadyGame

    ShadyGame GBAtemp Regular

    Member
    5
    Sep 12, 2009
    Portugal
    it doesnt detect the joycon so it doesnt detect the jig either

    im talking about this, the right pin, it came out along with the solder i guess

    [​IMG]
     
  20. edwardsalazar97

    edwardsalazar97 Member

    Newcomer
    1
    Jul 11, 2019
    Colombia
    ok, I thought the damage was in the joycon not in the switch strap, when mentioning mod joycon I assumed that was

    — Posts automatically merged - Please don't double post! —

    if you did not tear all the way or the track you can with a cutter remove some of the coating so that the copper is seen and join the two tracks 3XWWddb.
     
    Last edited by edwardsalazar97, Oct 2, 2019
Quick Reply
Draft saved Draft deleted
Loading...