Hacking Chrono Cross PSX Freeze on 6.20 TN-E

KnobTwiddler

Member
OP
Newcomer
Joined
Jun 12, 2012
Messages
16
Trophies
0
XP
28
Hi everyone. For the last two days, i've been trying to get the multi-disc PSX game, Chrono Cross, to work on my 6.20 TN-E PSP 3000. The game freezes each time I beat Mama Komodo, and I can't seem to get around it, even when I turn off all of my plugins.

I have read many threads on users having the same problem, but they are old threads with different custom firmwares and popsloaders (6.20 TN-E has a built in popsloader)

I also tried looking for an Eboot of the game online, but i either get a black screen after the Playstation logo, or it would freeze on Mama Komodo.

Can anyone help?
 

KnobTwiddler

Member
OP
Newcomer
Joined
Jun 12, 2012
Messages
16
Trophies
0
XP
28
It's definitely starting to sound like a good idea by now. But the thing is, since this problem have been lingering for years I would assume that by now there would be some fix
 

BORTZ

DO NOT SCREENSHOT
Supervisor
Joined
Dec 2, 2007
Messages
13,223
Trophies
3
Age
33
Location
Pittsburgh
XP
15,483
Country
United States
since this is here i have a question. Im on the same firmware but i get a "authorization failed" error code when i try to download this title. Other titles work fine like DLC for God Eater Burst and the PSX version of Front Mission 3.
 

xist

ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ
Member
Joined
Jul 14, 2008
Messages
5,859
Trophies
0
XP
973
Country
If you make the eboot properly it won't freeze on Mama Komodo....i know this for a fact as having ripped and converted my own discs and using 3.72 pops and a custom game id there are no problems at all on disc 1.

Also TN's HEN's are very out of date.

"authorization failed" sounds like a payment issue.
 

KnobTwiddler

Member
OP
Newcomer
Joined
Jun 12, 2012
Messages
16
Trophies
0
XP
28
If you make the eboot properly it won't freeze on Mama Komodo....i know this for a fact as having ripped and converted my own discs and using 3.72 pops and a custom game id there are no problems at all on disc 1.

Also TN's HEN's are very out of date.

Well, the reason why I never updated is because I never really had a reason to (I guess until now), but anyway I used PSX2PSP to make the EBOOT, with having both EBOOT's having the highest compression possible.
 

xist

ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ
Member
Joined
Jul 14, 2008
Messages
5,859
Trophies
0
XP
973
Country
Well, the reason why I never updated is because I never really had a reason to (I guess until now), but anyway I used PSX2PSP to make the EBOOT, with having both EBOOT's having the highest compression possible.

PSX2PSP will break Chrono Cross as it's a very irksome game to get working. Ideally you need to use GameID: SCUS94640 and 3.72 pops (via popsloader) as well as making a clean image (Alcohol is good, as is CloneCD) The clincher is what tool you use to create the eboot, and for Chrono Cross it appears that best compatibility is obtained via CDDA popstation.exe v1.24
 

realveemon

Well-Known Member
Member
Joined
Oct 2, 2008
Messages
144
Trophies
0
XP
111
Country
United States
Not that it always makes a difference but compression has seen its fair deals of make/break situations..

IF it makes a difference then your welcome

Xist is right with the IDs and POPS Ver btw
 

KnobTwiddler

Member
OP
Newcomer
Joined
Jun 12, 2012
Messages
16
Trophies
0
XP
28
Alright, today I bought the game on PSN, because i got tired of trying to figure this out...but NOW i have a new problem. Every time I try to download the game, I get the error "the install failed, (80109D80)", so I tested out other games i downloaded, and all the others download just fine. I tried using PRO C and TN-E and both give me that error.

If there is a god, he/she does not want me to play this game.
 

KnobTwiddler

Member
OP
Newcomer
Joined
Jun 12, 2012
Messages
16
Trophies
0
XP
28
I did, and i'm still getting the error. I read up on a few forum posts that this error means (i assume from what i read) banned psps from psn, or that it detects that it's not the official firmware.

And to correct myself, other games won't download. the only exception is a wallace and gromit comic
 

♣zx♣

Active Member
Newcomer
Joined
Nov 14, 2010
Messages
43
Trophies
0
XP
127
Country
Alright, today I bought the game on PSN, because i got tired of trying to figure this out...but NOW i have a new problem. Every time I try to download the game, I get the error "the install failed, (80109D80)", so I tested out other games i downloaded, and all the others download just fine. I tried using PRO C and TN-E and both give me that error.

If there is a god, he/she does not want me to play this game.
i'm currently looking at some thread and found this? I've been playing chrono cross (PSN version) for almost 2 weeks and got no problems at all... you need to just use a popsloader and choose 6.60 then go on. you can play it with no hassle... hope you know how to use popsloader..
but if not...try following this...

-first install the latest popsloader (google it)
-then on your psp , remove the chrono chross save data on your psp,
-then choose your game then press R...(it will load the popsloader menu)
-then choose 6.60...

that's all you need...

...
(back to searching)
 

KnobTwiddler

Member
OP
Newcomer
Joined
Jun 12, 2012
Messages
16
Trophies
0
XP
28
Alright, today I bought the game on PSN, because i got tired of trying to figure this out...but NOW i have a new problem. Every time I try to download the game, I get the error "the install failed, (80109D80)", so I tested out other games i downloaded, and all the others download just fine. I tried using PRO C and TN-E and both give me that error.

If there is a god, he/she does not want me to play this game.
i'm currently looking at some thread and found this? I've been playing chrono cross (PSN version) for almost 2 weeks and got no problems at all... you need to just use a popsloader and choose 6.60 then go on. you can play it with no hassle... hope it helps..


...
(back to searching)


As much as i really really REALLY don't want to, i guess i have no choice but to update to 6.60... :( At least there is 6.60 PROC, but i'm hoping it gives me the same functionality as 6.20 PROC
 

♣zx♣

Active Member
Newcomer
Joined
Nov 14, 2010
Messages
43
Trophies
0
XP
127
Country
Alright, today I bought the game on PSN, because i got tired of trying to figure this out...but NOW i have a new problem. Every time I try to download the game, I get the error "the install failed, (80109D80)", so I tested out other games i downloaded, and all the others download just fine. I tried using PRO C and TN-E and both give me that error.

If there is a god, he/she does not want me to play this game.
i'm currently looking at some thread and found this? I've been playing chrono cross (PSN version) for almost 2 weeks and got no problems at all... you need to just use a popsloader and choose 6.60 then go on. you can play it with no hassle... hope it helps..


...
(back to searching)


As much as i really really REALLY don't want to, i guess i have no choice but to update to 6.60... :( At least there is 6.60 PROC, but i'm hoping it gives me the same functionality as 6.20 PROC
no ... you dont need to... I'm using 6.20 pro B10 playing this. also tried plying it on 5.50..prometheus-4.. just use the plugin...
 

KnobTwiddler

Member
OP
Newcomer
Joined
Jun 12, 2012
Messages
16
Trophies
0
XP
28
Then I flat out have no idea how to fix this problem :/


EDIT: I'll try out what you said

And google is not nice to me about installing popsloader. some forums i went to tell me to go google it. ISN'T THAT HOW I GOT TO YOUR FORUM!?


But besides, i'm not really worried about popsloader right now...I just want chrono cross that i paid for to download...
 

♣zx♣

Active Member
Newcomer
Joined
Nov 14, 2010
Messages
43
Trophies
0
XP
127
Country
Then I flat out have no idea how to fix this problem :/


EDIT: I'll try out what you said

And google is not nice to me about installing popsloader. some forums i went to tell me to go google it. ISN'T THAT HOW I GOT TO YOUR FORUM!?


But besides, i'm not really worried about popsloader right now...I just want chrono cross that i paid for to download...
here try this...
http://pspslimhacks.com/popsloader-v3-popsloader-for-pro-lcfw/


it can be used to any Custom firmware...
you can never play chrono cross on any Firmware below 6.60...
so i suggest you use that if you dont want to change your current firmware...
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    Doctor-Masu @ Doctor-Masu: ahjjj