Can't load up Homebrew Channel anymore after stupid mistake

Discussion in 'Wii U - Hacking & Backup Loaders' started by MartinDocNewland, Jul 14, 2014.

  1. MartinDocNewland
    OP

    MartinDocNewland Searching for the truth

    Member
    529
    144
    Jul 7, 2012
    Hello

    Is the title says I have done something silly and installed a cios that has stopped me from loading up the homebrew channel (Get a black screen) Can't load any homebrew (Was using Wiiflow Mod version 4.4.2 i think and get a black screen) and can't reinstall bootmii (Gets stuck at the scam screen before you have to press 1) Did a factory reset on the WiiU side but nothing has helped.

    Was trying to get tatsunoko vs capcom to work in Wiiflow Mod

    Is there anything I can do to get homebrew back? (Was thinking of reflashing my dump to the nand but don't even know if you can)

    Really need help as only had the machine 6 days lol
     


  2. TeamScriptKiddies

    TeamScriptKiddies Licensed Nintendo (indie) Game Developer

    Member
    1,902
    1,321
    Apr 3, 2014
    United States
    Planet Earth :P
    Use the smashstack (or w/e exploited you originally used to install HBC) to launch the CIOS installer you originally used to install the CIOS in question. Once the installer comes up navigate to the problematic CIOS and uninstall it using the on screen instructions. Post back with your results or if you have any questions :)
     
  3. Bug_Checker_

    Bug_Checker_ GBAtemp Advanced Fan

    Member
    950
    444
    Jun 10, 2006
    United States
  4. MartinDocNewland
    OP

    MartinDocNewland Searching for the truth

    Member
    529
    144
    Jul 7, 2012
    Thanks for getting back to me, it is very much appreciated!

    I used the Indiana Jones hack to get bootmii loaded so will use that again. Feel stupid for asking this but how do I get the CIOS installer (I used Multi Mod Mii) to boot up? As you know its a dol file and not an elf file (Finding modding the vWii a lot harder then modding a Wii lol)
    So can I have some help on that please?

    (Sorry I keep asking question but as I said i'm finding hacking the vWii a lot harder then a real Wii)

    (EDIT)

    Tried renaming the MMM boot.dol file to boot.elf and put it in the root of my SD card but it will not boot into MMM and says hanging
     
  5. TeamScriptKiddies

    TeamScriptKiddies Licensed Nintendo (indie) Game Developer

    Member
    1,902
    1,321
    Apr 3, 2014
    United States
    Planet Earth :P
    Try what Bug_Checker_ suggested first. I may have jumped the gun on this one...
     
  6. MartinDocNewland
    OP

    MartinDocNewland Searching for the truth

    Member
    529
    144
    Jul 7, 2012

    How do I run SysCheck if I can't get into the HB Channel and reinstalling Bootmii just hangs before you are told to press 1?
     
  7. TeamScriptKiddies

    TeamScriptKiddies Licensed Nintendo (indie) Game Developer

    Member
    1,902
    1,321
    Apr 3, 2014
    United States
    Planet Earth :P
    Forget about bootmii and HBC altogether. Take the elf or dol file for the Syscheck app itself and launch it directly using the Indiana PWNS exploit. This will require that you take the existing boot.dol/elf file that comes with the Indiana Pwns exploit (should be the hackmii installer) and replace it with the syscheck boot.dol/elf. Make sure you rename the Syscheck file to be exactly the same as the hackmii installer file name was. Then launch the exploit and it should automatically boot into the Syscheck application.
     
  8. MartinDocNewland
    OP

    MartinDocNewland Searching for the truth

    Member
    529
    144
    Jul 7, 2012
    Right will try this, thanks for your time by the way. Will report back soon
     
  9. MartinDocNewland
    OP

    MartinDocNewland Searching for the truth

    Member
    529
    144
    Jul 7, 2012
    Right tried what you said (Been trying what you said for hours now and no go my end)

    My card is set up this way: https://dl.dropboxusercontent.com/u/91659847/20140716_145529.jpg

    When I rename the SysCheck dol file (its already named boot.dol) to boot.elf and put in the root I get this: https://dl.dropboxusercontent.com/u/91659847/20140716_144110.jpg

    When I get rid of the bootmii elf file and just replace it with the SysCheck dol file in the root I get this: https://dl.dropboxusercontent.com/u/91659847/20140716_145202.jpg

    Been at this for 9 hours now and I have not gotten anywhere lol

    EDIT

    Found a elf file of USBLoaderGX (A version that runs on ios250 AND IT BOOTED!
    So this have given me a big smile and I know not all is lost!

    EDIT 2

    Been loading dol files through USBLoaderGX and NOTHING is working :(

    SysCheckHDE just hangs with a black screen
    InspectMii just hangs with a black screen
    MMM just hangs with a black screen
    d2x-cios-installer loads up till i get this: https://dl.dropboxusercontent.com/u/91659847/20140716_171928.jpg

    So not having much luck and running out of ideas

    EDIT 3

    Managed to get Wad Manager 1.7 to run so I thought I would try and get IOS236 Installer MOD v7 Special vWii Edition to run and it did. Thought it would be a good plan to install IOS236 but when I try to install the IOS it looks for IOS36 revision 3864 then hangs so I guess that IOS has been messed up (Yes I know you should NEVER mess with any IOS below 200)

    So i'm guessing I need to install that IOS but where do i find it?

    EDIT 4

    Found the IOS I needed from an idea that CYAN made me think about so thanks to him for that. But i'm a bit worried about how to install it so if anyone is reading this I need some help with installing IOS36 please
     
  10. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,269
    8,743
    Oct 27, 2002
    France
    Engine room, learning
    To install an IOS, you need hardware access.

    launching homebrew using the game exploit doesn't provide hardware access (only the homebrew channel or an already installed forwarder does).
    So, you can launch homebrew which doesn't require hardware access, such as USBLoaderGX, but it will then not be able to provide that access to other homebrew as it doesn't have it.
    Unless USBLoaderGX booted using cIOS d2x, then it should have ahb access and could pass it to launched homebrew.


    Do you have a forwarder installed?
     
  11. MartinDocNewland
    OP

    MartinDocNewland Searching for the truth

    Member
    529
    144
    Jul 7, 2012

    I did have the green Homebrew Channel Forwarder and the Wiiflow forwarder but I was just getting a black screen so I factory resetted my Wii U to see if that help but it didn't sadly (I did not know at the time if I was a good plan to do so)

    I just need to know how to install IOS36 safely now
     
  12. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,269
    8,743
    Oct 27, 2002
    France
    Engine room, learning
    So, you still have these channels installed? Great :)
    (factory reseting also reset vWii?)

    instead of launching boot.elf from a game exploit (which will not work), put your boot.dol on your SD card to the place where the forwarder expect wiiflow (I guess apps/wiiflow/boot.dol)
    it will launch your homebrew with ahb_access.
    So, if you can launch MMM, it will work.

    Before reinstalling wads, maybe try to run syscheck to see if you have the correct versions. you can post the syscheck here. (not sure if users know which version to expect on vWii).

    I guess the one you really want to install from your NAND dump is IOS58. it will make the HBC working again.


    If you don't have the Wiiflow forwarder, try launching USBLoaderGX again from the game exploit. Then go to Credit screen and check if you see "+AHB" in the top right.
    if it's there, you should be able to launch MMM from USBGX. Not sure why it only black screen.
     
  13. MartinDocNewland
    OP

    MartinDocNewland Searching for the truth

    Member
    529
    144
    Jul 7, 2012

    Not being rude but have you read everything I have posted on here? I said I did have them but don't anymore. When I had them after my mistake EVERY forwarder did not work (When Clicked the screen went black and hanged) So I thought I would try another way to fix my problems. I have managed to run two wad installers via the Indiana Pwns exploit but now I need to reinstall IOS36 but don't know the safest way to do so (As in what wad manager I should use to install IOS36)
     
  14. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,269
    8,743
    Oct 27, 2002
    France
    Engine room, learning
    I did read, but I thought you reseted only the wiiU side, not vWii.

    There were two or three other thread with the semi-brick issue.
    I can try to find them if it can help you.
     
  15. MartinDocNewland
    OP

    MartinDocNewland Searching for the truth

    Member
    529
    144
    Jul 7, 2012

    When you factory reset the Wii U it also factory resets the vWii side but it does not reset the IOS's you install
     
  16. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,269
    8,743
    Oct 27, 2002
    France
    Engine room, learning
    Here is the guide to fix IOS58 :
    http://gbatemp.net/threads/vwii-semi-bricked.353595/#post-4755115 (try1)
    http://gbatemp.net/threads/vwii-semi-bricked.353595/#post-4756051 (try2)
    http://gbatemp.net/threads/vwii-semi-bricked.353595/page-2#post-4756201 (success)

    You need a cIOS installed (I guess you have 249/250)

    If you have upside down HBC too, reinstall it with a wad manager which is not silently-patching IOSes.
    The guide says he used WiiMod's incorporated Wad Manager. at least he could launch HBC. So from HBC relaunch MMM and reinstall your IOS58 again. MMM shouldn't patch the signature without telling you.

    and sorry for previous messages if I felt aggressive. You didn't clearly stated what you did wrong in your first post, just "installed a cios and hbc stopped working". no info on which cIOS, etc. I often don't understand why users still mess with their IOS when all guides says to not do it so I get little upset.
     
    MartinDocNewland likes this.
  17. MartinDocNewland
    OP

    MartinDocNewland Searching for the truth

    Member
    529
    144
    Jul 7, 2012

    Its ok dude, no harm done and yes its my fault for not explaining myself. Right I have managed to install an unpatched IOS36 with the boot.elf of YAWMM with base 236, now to follow the guide you posed to fix IOS58 then hopefully I can post the output file that Syscheck gives me
     
  18. MartinDocNewland
    OP

    MartinDocNewland Searching for the truth

    Member
    529
    144
    Jul 7, 2012
    Right i'm trying to install IOS58-v6432 ripped from my Nand backup but getting a Install Ticket Error (ret = -1017)

    Tried to look up this error but can not find any info on it

    EDIT

    Forgot to say I'm installing it from an SD card

    EDIT 2

    Managed to install IOS58 using 236 as base but it still freezes before the press 1 screen when trying to reinstall HBC so again I have hit a brick wall lol

    Going to need to think about this again!
     
  19. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,269
    8,743
    Oct 27, 2002
    France
    Engine room, learning
    I think it's an error when you have a bad or corrupted ticket.
    Try to re-extract the wad from your dump with ShowMiiWad mod (I think you need the latest mod for vWii. I don't remember very well why the mod is required, sorry).

    If it still happen, I hope someone else can help you.
     
  20. MartinDocNewland
    OP

    MartinDocNewland Searching for the truth

    Member
    529
    144
    Jul 7, 2012
    Its ok, I managed to install it with 236 base instead of 249/250 but i'm still getting the screen freeze on me

    EDIT

    Right managed to get Syscheck to run via the elf version of USBLoaderGX so here is the SysCheck file!

    Warning: Spoilers inside!

    Can someone look through this for me and tell me what is wrong? (I don't like the look of IOS223, BC v6 or MIOS v10 but it might just be me)