Should I update my DSi firmware?

Discussion in 'Acekard' started by zackfiles, Sep 18, 2011.

Sep 18, 2011
  1. zackfiles
    OP

    Newcomer zackfiles Advanced Member

    Joined:
    Oct 1, 2008
    Messages:
    97
    Location:
    Vancouver
    Country:
    Canada
    Hi guys!

    I have a DSi that I haven't ever updated. It came out of the box with 1.4U firmware.
    I bought an Acekard 2i and realized that it wouldn't work without this "ak2ifw_update_14_DSL.nds" patch. So I did it, and the Acekard worked!

    But now, I really want to get in to the DSi store, and in order to do that, I believe I have to update the firmware, but I have a feeling that my "ak2ifw_update_14_DSL.nds" patch will get in the way, and my DSi will get corrupted.

    What should I do? Please help! I don't want my DSi to get corrupted, and I still want my Acekard 2i to work...
     
  2. Nathanaël

    Member Nathanaël GBAtemp Regular

    Joined:
    Jul 5, 2011
    Messages:
    274
    Country:
    Nauru
    You should do a bit reading at the internet adress that's printed on your card.
     
  3. FIX94

    Global Moderator FIX94 Global Moderator

    Joined:
    Dec 3, 2009
    Messages:
    6,547
    Location:
    ???
    Country:
    Germany
    You can simply update the firmware with the update from here, if the ak2i update was successfully completed you can update your dsi without any problem.
     
  4. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    wut

    I've got an AK2i and I've never heard of that.
     
  5. zackfiles
    OP

    Newcomer zackfiles Advanced Member

    Joined:
    Oct 1, 2008
    Messages:
    97
    Location:
    Vancouver
    Country:
    Canada
    Ah! Sorry guys! It wasn't called happyday.exe

    Here is what I used:
    http://dsir4im3idsoneiacekard2i.articlesba...14-1143017.html

    I had to put the Acekard into my DS lite, then I patched it with this file:
    ak2ifw_update_14_DSL.nds

    After that, it worked properly on my 1.4U DSi.

    Will my current patch conflict with the current 1.4.3U patch? I'm really worried...
     
  6. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
  7. zackfiles
    OP

    Newcomer zackfiles Advanced Member

    Joined:
    Oct 1, 2008
    Messages:
    97
    Location:
    Vancouver
    Country:
    Canada
  8. comk4ver

    Newcomer comk4ver Newbie

    Joined:
    Mar 28, 2011
    Messages:
    5
    Country:
    United States
    Okay let me get this straight: after updating my acekard to the newest firmware I can then update the firmware on my dsi? But what about later on in the future when I need to flash a new firmware update or a new acekard?
     
  9. FIX94

    Global Moderator FIX94 Global Moderator

    Joined:
    Dec 3, 2009
    Messages:
    6,547
    Location:
    ???
    Country:
    Germany
    If a new dsi firmware comes out you will simply need to wait for a new acekard firmware update, no need to get a new acekard.
     
  10. comk4ver

    Newcomer comk4ver Newbie

    Joined:
    Mar 28, 2011
    Messages:
    5
    Country:
    United States
    question 1: what i meant was for example; if i wanted to flash an newer update on my acekard (assuming a new firware update happens 1.5) would I still be able to on the new firmware update for my dsi? I was under the impression that if you were on anything above nintendo firmware 1.2 you wouldn't be able to flash any flash carts. Is that now not accurate?
    It's the only reason why I have never upgraded my dsi.

    Question 2: I have upgraded my acekard to firmware 1.4.3 for the dsi but my dsi is still on 1.2, should i upgrade my dsi or will i still be able to run any item i wish just like that?

    A million thanks to the all knowledegable one!
     
  11. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    1 - If you can run the acekard, you can flash the acekard.
    You just can't flash ANOTHER acekard. An acekard can flash itself on the DSi, but one cart cannot flash another.

    2 - You can run any DS/i game on any DSi firmware. It's dsiware ones and such that want you to update to get to them (the store).
     

Share This Page