Gaming Race Driver GRID Problem..

67birdman

Well-Known Member
OP
Member
Joined
May 25, 2008
Messages
441
Trophies
0
Age
27
Location
Vancouver, BC
XP
195
Country
Canada
Hi
So I recently bought a new graphics card, and I decided to get GRID.
I saw that my specs were fine so I got it.
But now when I run it I can't see the main menu all I see is yellow squares..
What do I do? Please help, I really wanna play..
Thanks
 

Rayder

Mostly lurking lately....
Former Staff
Joined
Jan 14, 2007
Messages
6,606
Trophies
0
Location
USA
XP
589
Country
United States
Hmm....I have an X1600 on this machine and the game runs ok here, so I know it SHOULD work.

Maybe try updating DirectX. Just go to www.microsoft.com and search for "DirectX". You specifically want the "End-User Runtime".

Do you have "MicroSoft .NET Framework" installed on the computer? ATI graphics cards use .NET Framework for their control panel and may radically affect compatibility if .NET framework is not there. Be sure to at least get version 2 of .NET Framework for use with ATI cards. .....but, if it never complained about .NET when you installed the Catalyst drivers, then you likely already have .Net Framework in the system.....hmmmm....

Is it an official "legal" version of the game, or a pirated copy? There were many pirated versions of the game floating around on the net that didn't actually work properly, so if that's what you have, trust me, try a different download, from a different release group.

If it's an official version, check here for patches and possible solutions:
http://community.codemasters.com/forum/grid-946

Last suggestion.....try a PC hardware site for technical help.....one of my favorites is down for maintenance, but:
http://www.hardwareheaven.com/
http://www.rage3d.com/

Both of those sties are VERY helpful for anyone with computer hardware issues.

Hope at least one of those suggestions helps you. GRID is too good of a game to miss.



EDIT: These should be the video drivers you need:
http://support.amd.com/us/gpudownload/wind...?=English
Be sure to get the "full software suite".

Apparently, the issue MAY be that an X1600 is a DX9 card and Vista is up to DX11.......read the release notes in the link.....hmm....
 

67birdman

Well-Known Member
OP
Member
Joined
May 25, 2008
Messages
441
Trophies
0
Age
27
Location
Vancouver, BC
XP
195
Country
Canada
Yeap, thats already installed too.
I think that was my last hope
frown.gif
 
General chit-chat
Help Users
    AkiraKurusu @ AkiraKurusu: I've got a 2017 MacBook Pro, the one with the Touch Bar thing above the keyboard; well, today I...