R4i 3DS not working on DSI XL

Discussion in 'R4 DS' started by Infinite Zero, Jun 16, 2012.

  1. Infinite Zero
    OP

    Infinite Zero Almost!

    Member
    2,922
    5
    Apr 25, 2010
    United States
    California
    Can anyone help me with this R4?
    http://ndsill.net/
    It doesnt work on my brother's 1.4.4 U Dsi xl and it hangs on my DS Lite.
    I've never worked on a DSi r4 before so please help where I can download the firmware

    oh dang! can a mod please move this to the flashcarts section? i had too many tabs open..
     
  2. Technicmaster0

    Technicmaster0 GBAtemp Psycho!

    Member
    3,283
    680
    Oct 22, 2011
    Gambia, The
  3. raystriker

    raystriker Alpha PC Builder

    Member
    1,283
    434
    Dec 28, 2011
    India
    Bloomington
    Is the card green in colour? Then Dont upgrade to the newest version!You might destroy your cart or have many other problems!(mine was destroyed i.e it got corrupted)
     
  4. ferofax

    ferofax End of the World

    Member
    2,566
    437
    Jan 26, 2009
    Philippines
    If you're on a Prince Caspian firmware, don't flash your firmware. The official firmware on the site is GUARANTEED to brick the cart. Devs were stupid enough to put a bricker up for download, the gall of them. Check the firmware, if it's dated 4/23/2012, it's a bricker. The one you want is the last good firmware they upped, which uses the Prince Caspian icon (that's why I call it that) dated 12/10/2011.

    If however you're not on a Prince Caspian firmware (say you're on Finding Nemo or that japanese blue wolf icon), upgrade to the Prince Caspian firmware. Granted, it won't work on DSi 1.44 nor latest 3DS firmwares, but at least it's not bricked. Also, if you managed to brick your cart, unbrick it using that same firmware.

    @raystriker: here's a little help for you too.
    Get it here. I personally uploaded it, because it is currently unavailable for download anywhere. You'll need a working flashcart to unbrick a bricked flashcart. Just run the firmware updater from the working flashcart (get a device it works on-- DSphat, DSlite, even DSi/XL as long as it works on it and isn't blocked). When the updater runs and prompts to press A, DON'T. swap the carts (remove the flashcart and insert the bricked one) before pressing A. see to it the process finishes (sometimes it doesn't). if it reaches 100%, congratulations, you just unbricked the cart. now you can play it as usual on your DSlite, but it won't work on DSi 1.44 (yet).