pokemon emerald will not boot on VBA WiiI recently downloaded the vV

Discussion in 'Wii - Hacking' started by zeldarocks, Jul 19, 2008.

  1. zeldarocks
    OP

    Newcomer zeldarocks Advanced Member

    Joined:
    Jul 17, 2008
    Messages:
    78
    Country:
    I recently downloaded the VBA port for wii hoping I would be able to lay pokemon, I can run pokemon crystal just fine but when it comes to emerald, no-go, the rom loads but it just sits at a white screen forever... please help...
     
  2. dinofan01

    Member dinofan01 Misses the old days...

    Joined:
    Jul 4, 2008
    Messages:
    2,842
    Country:
    United States
    No real time clock. I believe it needs to be patched.
     
  3. jan777

    Member jan777 motion control..? srsly? so 2008. 3DS is teh bombz

    Joined:
    Jan 4, 2008
    Messages:
    2,829
    Country:
    Philippines
    i read somewhere that you had to make a save from another emu first then use that
     
  4. Majin Vegeta

    Member Majin Vegeta GBAtemp Regular

    Joined:
    Jul 12, 2008
    Messages:
    159
    Country:
    Germany
    You need to patch SRAM if you don't want a white screen.
    Download GBATA
    Just load your ROM, patch SRAM, patch RTC and also shrink it.
     
  5. xcalibur

    Member xcalibur Gbatemp's Chocolate Bear

    Joined:
    Jun 2, 2007
    Messages:
    3,166
    Location:
    Sacred Heart
    Country:
    United Kingdom
    This game wouldn't run in VBA on the computer at first too. Either patch it with GBATA like Majin Vegeta suggested or use a save from the computer. I don't know if the emulator on the wii will allow you change the save type but try and change it to 128kb EEPROM if you can.
     
  6. zeldarocks
    OP

    Newcomer zeldarocks Advanced Member

    Joined:
    Jul 17, 2008
    Messages:
    78
    Country:
    I went to patch the real time clock and it said it was Unneeded I've also SRAM patched it, ad I've trimmed it, still white screen...
     
  7. Dark-Aries

    Newcomer Dark-Aries Advanced Member

    Joined:
    Jul 19, 2008
    Messages:
    54
    Country:
    United States
    I found out how to play the pokemon games on vbawii...


    Load up the game on the computer, adjust the vba settings like realtimeclock and 128 eeprom saves(I think that's correct), then the game should work perfectly on the computer...If the clock still doesn't work just patch it if available. After everything is done start a new game, set everything up to how you want it in the game, then save ASAP. Now you should have a .SAV file. Copy over the SAV file to the saves folder on your SD card...Voila! it works!
     
  8. FireEmblemGuy

    Member FireEmblemGuy Finally hit 1000 posts

    Joined:
    Jul 6, 2007
    Messages:
    2,274
    Location:
    Michigan, USA
    Country:
    United States
    I don't get it... I seem to be the only person who's been able to get Pokemon games to work without patching, aside from FireRed's save type and booting ShinyGold at all. But I never touched Emerald and it worked fine, RTC and all... and I don't even think VBA Wii has RTC support, which kinda creeps me out...

    Are you guys using the latest revision(30052008)? When I first downloaded it for HBC use both packs I tried used an older version.
     
  9. zeldarocks
    OP

    Newcomer zeldarocks Advanced Member

    Joined:
    Jul 17, 2008
    Messages:
    78
    Country:
    I got it to work, it seems that I may have been using a corrupt rom or something. i have yet to verify...

    how'd you get RTC to work it still give me the message about the real time clock at startup...

    EDIT: I deleted the save file off my save folder in VBA Wii to confirm if it would generate the save no its own, and everything works fine, I don't even get the RTC message at startup... cool... [​IMG]

    Edit:it seems VBA Wii cannot keep track of the save file, I saved but it says new game when I restart. How can i get it to save properly?
     
  10. harrybuttox

    Member harrybuttox GBAtemp Regular

    Joined:
    Apr 29, 2008
    Messages:
    277
    Country:
    United States
    you do have the correct BIOS also right?

    Posts merged

    Save normally then press the home button and press the + button. That should work.
     
  11. zeldarocks
    OP

    Newcomer zeldarocks Advanced Member

    Joined:
    Jul 17, 2008
    Messages:
    78
    Country:
    I tried that and still no-go, the save file vanishes after I restart, regardless of how I restart...
     
  12. zeldarocks
    OP

    Newcomer zeldarocks Advanced Member

    Joined:
    Jul 17, 2008
    Messages:
    78
    Country:
    please help me....
     
  13. harrybuttox

    Member harrybuttox GBAtemp Regular

    Joined:
    Apr 29, 2008
    Messages:
    277
    Country:
    United States
    Did you save like you would normally first, and then did home and the + button? Also, do you have the save folder in root/vba/saves?
     
  14. zeldarocks
    OP

    Newcomer zeldarocks Advanced Member

    Joined:
    Jul 17, 2008
    Messages:
    78
    Country:
    I got it to work, I just didn't understand what you meant at first, NVM, great emulator, thanks for helping Harrybuttox [​IMG] I'm playing Super Metroid Redesign as we speak...
     
  15. Majin Vegeta

    Member Majin Vegeta GBAtemp Regular

    Joined:
    Jul 12, 2008
    Messages:
    159
    Country:
    Germany
    Deleting your old save should help if you patched the ROM like I said and it still doesn't work.
     
  16. zeldarocks
    OP

    Newcomer zeldarocks Advanced Member

    Joined:
    Jul 17, 2008
    Messages:
    78
    Country:
    like I said, I already got it to work, Super Metroid FTW
     

Share This Page