Hyper-R4I run on DSi 1.4U System

Discussion in 'NDS - Flashcarts and Accessories' started by ffsky, Aug 13, 2009.

  1. ffsky
    OP

    ffsky Newbie

    Newcomer
    1
    Oct 2, 2008
    Switzerland
  2. Kittymat

    Kittymat GBAtemp Advanced Fan

    Member
    2
    Oct 16, 2008
    UK
    So!

    Big question, can they update the current card or are they going to try and get everyone to buy again?
     
  3. indask8

    indask8 New Member Forever

    Member
    3
    Apr 19, 2007
    France
    Look at the Flag...
    Hyper4i is an EZVi clone, so of course it can run on 1.4...

    Only hyper4i.cn show this news, the .com version isn't modified yet...

    And I bet the R4i from r4i.cn will update soon too.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice