GBA SP Shell replaced but now screen not working.

ClassyDragon

Well-Known Member
OP
Member
Joined
Jan 30, 2017
Messages
108
Trophies
0
Age
23
Location
ケンタッキー
XP
702
Country
United States
I recently broke part of the shell to my GBA SP AGS-101 model and ordered a replacement shell.
Before replacing the shell, I can confirm the console itself was running fine and the screen was working.
Now that I've got everything connected, the screen won't turn on yet the sound of the system starting can be heard.
I'm posting some pictures of the ribbon cable and I'd be grateful if anyone could determine whether the ribbon cable might be broken or if I've reconnected it incorrectly.
Thank you!
20180131_213036.jpg
20180131_213310.jpg
 

ClassyDragon

Well-Known Member
OP
Member
Joined
Jan 30, 2017
Messages
108
Trophies
0
Age
23
Location
ケンタッキー
XP
702
Country
United States
Looking again, there does appear to be a small tear on the cable, and I assume that's what is causing the issue. I guess my question now is whether I can replace the ribbon cable without replacing the entire screen.
 

koffieleut

Well-Known Member
Member
Joined
Jan 22, 2009
Messages
641
Trophies
0
Age
37
Location
probably at home
XP
1,531
Country
Netherlands
I think you're screwed, the easiest method is to buy a new screen.
The hard method is to hand solder new wires to the screen, I won't recommend it though because it is extremely difficult.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: https://youtube.com/shorts/PjOYapR1T8s?feature=share