GBA Micro not loading cartridges?

Discussion in 'GBA - Hardware, Devices and Utilities' started by Alex4U, Jul 25, 2016.

  1. Alex4U
    OP

    Alex4U edgy

    Member
    1,068
    905
    Jan 6, 2016
    Mexico
    with Snivy, Mystery Zone (Adress 0x00)
    Well, some years i got a GBA Micro, with that fail, the GBA Micro doesn't read GBA Cartridges, i tested a lot of gba games, and any doesn't work, only rare times, shows a very corrupted "Nintendo" Logo, i opened, but the slot doesn't show a pin broken, i cleaned 4 times the slot, and nothing... is okay to solder a GBA SP Slot? (AGS-101) is the same slot??? Doens't damage the motherboard?
    Thanks :/
     
  2. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,199
    8,957
    Nov 21, 2005
    I am not sure if it is the same slot -- the GBM does not do GB/GBC games like the original GBA and SP. While that might not matter in the long run (if you can stop yourself and others putting in GB/GBC games then who cares sort of thing) I am more concerned with any changes in pin placement.
    It could be the same as the GBM was a small run device at the end of the GBA lifetime (give or take that three pillars nonsense) while the SP was presumably still in production and basic manufacturing logic says use the same but I would not buy one blind and expect it to work. Alas I don't have a GBM here to pull apart to have a look.

    Garbled logo means something has been detected. What did you clean it with? Also maybe take a soldering iron and reflow each of the pins on the motherboard, it could just be one of those did not flow properly or since creeped or something similar. Depending upon the thickness of the cart you might just have got one back in line temporarily and that was the result.
     
    Alex4U likes this.
  3. Alex4U
    OP

    Alex4U edgy

    Member
    1,068
    905
    Jan 6, 2016
    Mexico
    with Snivy, Mystery Zone (Adress 0x00)
    Ugh... i cleaned the slot with Alcohol, ummm, maybe NDS/Lite slot-2 should be the same slot? :/
    EDIT: I buyed new GBA games, like Mario Kart Advance JP, I tested in my GBA, GBA SP, GBA Player, works perfect, GBA Micro gave me "Ninte" logo, but "ndo" are corrupted. And the game doesn't start, tested with The Incredibles Game, game gave me NINTENDO Logo, game starts, and i got White Screen, i tested again with ALL my gba games, some gives me a corrupted logo, some games doesn't show Nintendo Logo ( corrupt logo too) all games works perfectly with my GBA, GBA SP, and gba player, i think maybe the slot have a "broken pin (?) " i don't know... i try to re-solder the slot. Thank you for you post ^^/
     
    Last edited by Alex4U, Jul 26, 2016 - Reason: MORE INFORMATION