Firmware status

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Nah3DS, Jan 24, 2018.

  1. Frankbel

    Frankbel Advanced Member

    Newcomer
    3
    Feb 10, 2004
    Italy
    Messina
    Forgive me if this question has been posted thousand times.
    I am on 5.0.1, should I update to OFW 6.0.x?
     
  2. Nah3DS
    OP

    Nah3DS Madre de Dios! Es El POLLO DIABLO!!!

    Member
    11
    Feb 9, 2010
    Argentina
    I've found this on Reswitched's discord
    Warning: Spoilers inside!
    @Draxzelex do you know anything about this?
     
    Last edited by Nah3DS, Nov 20, 2018
  3. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    16
    Aug 6, 2017
    United States
    New York City
    Well yeah, Deja Vu has been made to work on firmware 4.1 and hexkyz has managed to make it work on firmwares as high as 6.0.1. However it may have been finally patched out in 6.1 since there was a browser exploit that was removed in that firmware update.
     
  4. ZachyCatGames

    ZachyCatGames GBAtemp Fan

    Member
    3
    Jun 19, 2018
    United States
    I remember that :P
    Yea, Deja Vu was never fully patched, only parts of it were, they’re still trying to keep deja vu for when Mariko comes out though :P
     
    Last edited by ZachyCatGames, Nov 9, 2018
  5. Vinceology

    Vinceology Member

    Newcomer
    1
    Aug 22, 2015
    United States
    Question, so can we install games onto the Switch yet just like how I can install cia files onto my 3DS?
     
  6. ichibaka

    ichibaka Advanced Member

    Newcomer
    2
    Jul 4, 2018
    United States
    This has been possible for many months now
     
  7. AvatarMew

    AvatarMew GBAtemp Fan

    Member
    3
    Sep 5, 2015
    Would I be banned if I played any downloaded games online? I don't have a Switch yet but I want to get one.
    Also, which FW should I be looking for?
     
    Last edited by AvatarMew, Nov 30, 2018
  8. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    16
    Aug 6, 2017
    United States
    New York City
    You'll be banned if you hack the Switch period. And as always, the lower the firmware, the better.
     
  9. k7ra

    k7ra GBAtemp Fan

    Member
    3
    Dec 11, 2016
    I don't get it. Why the lower fw still better?
    If anyway all update it...
     
  10. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    16
    Aug 6, 2017
    United States
    New York City
    Because as recently shown with firmware 6.2, newer firmware always present issues for hackers. Regardless of the fact that we have an unpatchable exploit that works on all firmwares, the same cannot be said for CFW and homebrew that are usually designed to run better on certain firmwares, typically the lower firmwares. DevMenu, for example, does not run on firmwares above 5.1 and it has a couple of nifty features. The only reason one would need to be on the latest firmwares is if they plan to play online. Lastly, lower firmwares have access to potentially exclusive exploits that higher firmwares may not be able to utilize such as the coveted untethered coldboot.
     
  11. Irocadiext

    Irocadiext Member

    Newcomer
    2
    Jul 19, 2018
    United States
    what are my options to play some of the newer gms that require fw past 5.1.0? any way to play them with the ease of sxos or do I have to switch to a different cfw? I believe i ve read reinx lets use a fw bypass with tinfoil i think. No way to do this with sxos i guess.
     
  12. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    16
    Aug 6, 2017
    United States
    New York City
    No CFW has a way to bypass the higher firmware requirements of certain games. If you do have to update your firmware, I recommend updating with ChoiDujourNX.
     
  13. Spadezilla

    Spadezilla Member

    Newcomer
    1
    Dec 19, 2013
    United States
    is this still the latest info?
     
  14. Irocadiext

    Irocadiext Member

    Newcomer
    2
    Jul 19, 2018
    United States
    ok thanks for your reply. I thought i read somewhere that you can use sometype of newer fw need bypass or spoof with tinfoil. anyway i guess i ll have to update. thnx.
     
  15. Spadezilla

    Spadezilla Member

    Newcomer
    1
    Dec 19, 2013
    United States
    where are we at regarding patched Switches before system menu version 5.0 or whatever
     
  16. Spadezilla
    This message by Spadezilla has been removed from public view by Joe88, Dec 10, 2018 at 12:45 AM.
    Dec 10, 2018 at 12:22 AM
  17. Vinceology

    Vinceology Member

    Newcomer
    1
    Aug 22, 2015
    United States
    Can you please send me the link on how to do it from start to bottom? Like I just dont know what exactly to google.

    Ive installed cfw many times now for my 3DSs.
     
Loading...