Firmware status

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Nah3DS, Jan 24, 2018.

  1. 2manyGames2play

    2manyGames2play GBAtemp Regular

    Member
    2
    Nov 24, 2015
    Netherlands
    With ChoiDujourNX: Is it also possible to downgrade below/past a firmware fuse count (since the program ignores them), or only to the firmware the Switch came with?
     
    Last edited by 2manyGames2play, Sep 11, 2018
  2. kublai

    kublai GBAtemp Fan

    Member
    5
    May 29, 2008
    United States
    Awesome post. I'm going to make this my desktop wallpaper so I can remember it.
     
  3. Resaec

    Resaec GBAtemp Fan

    Member
    4
    Dec 19, 2017
    Germany
    You can downgrade to 1.0.0, but once you downgrade below your current fuse count (eg 3.0.1 -> 3.0.0) you need to boot with hekate.
     
  4. 2manyGames2play

    2manyGames2play GBAtemp Regular

    Member
    2
    Nov 24, 2015
    Netherlands
    But of course.. :)
     
  5. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Fan

    Member
    5
    Jun 19, 2018
    United States
    Hell
    Also sleep mode wouldn’t work :P
     
  6. 2manyGames2play

    2manyGames2play GBAtemp Regular

    Member
    2
    Nov 24, 2015
    Netherlands
    Don't forget exFAT.
     
  7. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Fan

    Member
    5
    Jun 19, 2018
    United States
    Hell
    That would depend on what firmware you downgraded to (1.0.0 is the only one that doesn’t have an exfat version) and/or whether you chose the exfat version
     
  8. Isaac_ssbm

    Isaac_ssbm Member

    Newcomer
    2
    May 21, 2018
    United States
    Does someone know what Firmware Dragon Ball fighter z will require?
     
  9. Mysuke

    Mysuke Advanced Member

    Newcomer
    3
    Mar 9, 2017
    Brazil
    5.1.0 according to nswdb.com
     
    Isaac_ssbm likes this.
  10. Isaac_ssbm

    Isaac_ssbm Member

    Newcomer
    2
    May 21, 2018
    United States
    I can confirm that FighterZ does work on 5.1.0
     
  11. DocBo

    DocBo GBAtemp Regular

    Member
    3
    Apr 11, 2018
    Germany
    My english is not the best, so i have a question.
    I read here i can downgrade to a lower fw even when my fuses are burnt (7 burned FW 6.0)?!
    And the only issue is the sleep mode then?!
    Or will the switch brick if i do that?!
     
    Last edited by DocBo, Oct 4, 2018
  12. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Fan

    Member
    5
    Jun 19, 2018
    United States
    Hell
    If you downgrade you would have to use a custom bootloader like Hekate or ReiNX and sleep mode wouldn't work
     
    DocBo likes this.
  13. DocBo

    DocBo GBAtemp Regular

    Member
    3
    Apr 11, 2018
    Germany
    Ok, and what happends if i do not boot up with hekate or reiNX after downgrade?!
    Will it brick or simply not boot up?!
     
  14. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Fan

    Member
    5
    Jun 19, 2018
    United States
    Hell
    It just won’t boot up
     
    DocBo likes this.
  15. maraxion

    maraxion Member

    Newcomer
    1
    Mar 13, 2016
    Norway
    Hm.
    How do you identify if you have the old or new model?
    Gonna buy a used switch and unsure how I get the information I need before i Buy it. Any tips what I should look for to be modable?
     
  16. Canna

    Canna Bad Ass Poisonous Mushroom

    Member
    6
    GBAtemp Patron
    Canna is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jul 14, 2018
    United Kingdom
  17. Daniel_Jackson

    Daniel_Jackson Newbie

    Newcomer
    1
    Oct 9, 2018
    Netherlands
    I have a newly purchased 4.0.1 Switch. Should be vulnerable to fusee gelee according to the serial number, I should be able to actually verify that soon.
    I will buy retail cartridge games, I'm not interested in backup loading. My main goal of hacking my switch is to have a permanent installation of homebrew channel (for retroarch) that I can boot without additional (hardware) steps every time. I know that, for now, that's not possible on my system.
    In the future, which hack will help me better? :
    When Deja Vu gets released, will it allow for such a permanent installation? In that case, I should not update I think and keep my FW low.
    Or can Fusee Gelee help me later? Since that's hardware based, I should be safe to update?
     
  18. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Fan

    Member
    5
    Jun 19, 2018
    United States
    Hell
    Deja Vu will likely allow you to start cfw using the browser, and you’ll have to redo it evertime you restart your system
    Fuse Gelee also has to be done every time you restart your system

    If you wanted to you could update with ChoiDujourNX which would allow you to update without burning fuses which means you could downgrade back to 4.0.1 in the future, the only downside is that you must use autorcm

    ChoiDujourNX: https://gbatemp.net/threads/choiduj...ller-homebrew-for-the-nintendo-switch.513416/
     
    Draxzelex and Daniel_Jackson like this.
  19. Daniel_Jackson

    Daniel_Jackson Newbie

    Newcomer
    1
    Oct 9, 2018
    Netherlands
    I'll need to catch up a lot more before even trying such stuff, but it does sound interesting - thanks
     
  20. Titanica

    Titanica As mature as a Seventh Grader!

    Member
    5
    Dec 18, 2016
    United States
    Earth
    I believe the thread should be updated now, because Atmosphere has officially been released.
     
Loading...