Does anyone knows what firmware Majoras Mask 3D needs?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Xeonhawk, Feb 8, 2015.

  1. Xeonhawk
    OP

    Xeonhawk GBAtemp Regular

    Member
    2
    Nov 23, 2014
    United States
    Because I really hope it isn't above 9.2.0 :/
     
  2. Xeonhawk
    OP

    Xeonhawk GBAtemp Regular

    Member
    2
    Nov 23, 2014
    United States
    bump
     
  3. VinsCool

    VinsCool Neges Singula

    Member
    24
    GBAtemp Patron
    VinsCool is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jan 7, 2014
    Canada
    Another World
    It requires 7.1.0
    You are fine in 9.2 :)
     
  4. zoogie

    zoogie playing around in the dsiware

    Member
    19
    Nov 30, 2014
    Micronesia, Federated States of
    VinsCool likes this.
  5. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die

    Member
    8
    Jun 28, 2014
    United States
    Arizona Bay
    Rom tool says 7.1 with 6.x encryption
     
  6. Bonny

    Bonny GBAtemp Advanced Fan

    Member
    4
    Dec 8, 2008
    Germany
    Bavaria
    The Euro rom runs without any problems on emunand 9.2 for me.
     
  7. codychaosx

    codychaosx GBAtemp Advanced Fan

    Member
    5
    Mar 15, 2009
    United States
    Wisconsin
    MAXLEMPIRA likes this.
  8. YoungStarDC

    YoungStarDC Member

    Newcomer
    1
    Nov 24, 2014
    Netherlands
    The Hague, Netherlands
    My LE MM 3DS runs 9.0.0-20E so you should be good to go.
     
  9. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    20
    Oct 27, 2002
    France
    Engine room, learning
    That's Wrong.
    This website gives the Firmware version provided in the update partition of the dumped cartridge, not the required firmware to launch the game.
     
  10. Jayro

    Jayro MediCat USB and Mini Windows 10 Developer

    Member
    13
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jul 23, 2012
    United States
    Octo Canyon
    It's one in the same, the firmware on the cartridge is the minimum that the game requires to run, hence why it's included on the cart.
     
    MAXLEMPIRA likes this.
  11. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    20
    Oct 27, 2002
    France
    Engine room, learning
    Not at all. They both are different.

    For example :
    You can run Bravely default on an GW3DS EmuNAND version 4.5 without problem, even if that cartridge comes with an update partition containing a 6.2.0x version.

    Games bundled with an update partition at their manufacturing time doesn't reflect the SDK version the developers used to create the game.
    Nintendo adds always the last update partition version in manufacturing games, whatever the game really requires.


    Some games have 8.1 partition bundled with them, but the developers never used 7.x encryption key, so you can play them on a 4.x or 6.x NAND.

    Fantasy life is bundled with 8.1 but doesn't use 7.x encryption key so you can use 6.x NAND.
    Persona Q is bundled with 7.1 and 8.1 but doesn't use 7.x encryption key so you can use 6.x NAND.
    Monster Hunter 4 Ultimate/G have both 8.1 bundled, but require 7.1 because it's using the 7.x encryption key.

    some game info to show differences between update version and SDK version
     
    logg, Takeshi, cvskid and 1 other person like this.
  12. Ra1d

    Ra1d GBAtemp Maniac

    Member
    6
    Jul 31, 2010
    Canada

    So...basically if someone tries to run a Bravery Default on a 4.5 console he will still have to update to 6.2.0 ?
     
  13. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    20
    Oct 27, 2002
    France
    Engine room, learning
    if he is playing the cartridge version without update firmware version spoofing, then yes it will ask to update.
    If he is playing the dumped ROM version (which has firmware spoofing by default when using Gateway/MT) it will work fine without asking to update.

    I don't know if Sky3DS has a update firmware version spoofing.
    I don't know about .cia version


    You can find a list of games using 7.x encryption here:
    http://wiki.gbatemp.net/wiki/3DS_Titles_with_7.x_Encryption
    these games require 7.x NAND to work. other games can be launched on a lower NAND version.

    Attention : do not edit the list based on 3ds.essh.co !
    try the game on EmuNAND/RedNAND first (without flashcart) to see if it works on 4.x-6.x
     
    cvskid and Ra1d like this.
  14. blasian

    blasian Newbie

    Newcomer
    1
    Feb 14, 2015
    United States
    I am a little confused sry. The wiki under the emunand section says "You don't need to update EmuNAND to play ROMs requiring a newer System version." I'm assuming this is outdated? I have emunand v6.3.0 so I will need to update it to play Majora's Mask?
    edit: I'm referring to emunand normal, not classic, and playing offline.
     
  15. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    17
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    Most likely yes, it's probably using 7.x encryption.
     
  16. tony_2018

    tony_2018 GBAtemp Psycho!

    Member
    7
    Jan 3, 2014
    United States
    I'm running it on emunand 9.4. No issues.
     
  17. lPolarisl

    lPolarisl GBAtemp Fan

    Member
    2
    Jan 24, 2015
    Hungary
    Running fine on sysnand 9.2 (retail version).
     
  18. codychaosx

    codychaosx GBAtemp Advanced Fan

    Member
    5
    Mar 15, 2009
    United States
    Wisconsin
    Well hey knowing is half the battle
     
  19. tony_2018
    This message by tony_2018 has been removed from public view by Cyan, Feb 14, 2015, Reason: flaming and insulting.
    Feb 14, 2015
  20. codychaosx
    This message by codychaosx has been removed from public view by Cyan, Feb 14, 2015, Reason: flaming and insulting.
    Feb 14, 2015
  21. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    20
    Oct 27, 2002
    France
    Engine room, learning
    It's only half outdated.

    it depends which game you want to play.
    Like I explained above, some games are working fine with old version.
    Some games are requiring new 7.x key to decrypt the game's data, which requires 7+ NAND.


    The FAQ is outdated because it was written before 7.x release, but a lot of games are still working if you don't update.
     
  22. Anton299

    Anton299 GBAtemp Regular

    Member
    2
    Jan 18, 2012
    Ukraine
    Kiev
    What about decrypted MM3D?
    I've tried to build cia from fully decrypted PAL rom (exefs & romfs folders, exheader.bin), used exinjector with -sd and -fwspoof keys, installed cia to CFW 4.5 - but it hangs on 3DS logo.

    With this .bat it shows lust 3ds logo, forever (-desc app:7):
    Code:
    makerom -f ncch -rsf mm.rsf -target t -desc app:7 -icon exefs\icon.bin -banner exefs\banner.bin -exefslogo -code exefs\code.bin -exheader exheader.bin -romfs romfs.bin -o LoZ-MM.cxi
    exinjector -rom LoZ-MM.cxi -exheader exheader.bin -sd -fwspoof
    makerom -f cia -rsf mm.rsf -target t -content LoZ-MM.cxi:0:0 -content manual.cfa:1:1 -o loz-mm.cia
    pause
    
    And with same .bat file, but with -desc app:5 (and 4 as well) it also shows 3ds logo and just after it I see: "an error has occurred, please turn off the console..."

    RSF:
    Code:
    BasicInfo:
      Title                  : "LoZ-MM-EU"
      CompanyCode            : "01"
      ProductCode            : "CTR-P-AJRP"
      ContentType            : Application # Application / SystemUpdate / Manual / Child / Trial
      Logo                    : Nintendo # Nintendo / Licensed / Distributed / iQue / iQueForSystem
     
    TitleInfo:
      UniqueId                : 0x1256
      Category                : Application
     
    Option:
      UseOnSD                : true # true if App is to be #installed to SD
      EnableCompress          : true # Compresses exefs code
      FreeProductCode        : true # Removes limitations on ProductCode
      EnableCrypt            : false # Enables encryption for NCCH and CIA
      MediaFootPadding        : true # If true CCI files are created with padding
     
    AccessControlInfo:
      ExtSaveDataId: 0x1256 # same as UniqueId
      SystemSaveDataId1: 0x00000000 # plaintext exheader
      SystemSaveDataId2: 0x00000000 # plaintext exheader
      OtherUserSaveDataId1: 0x00000 # plaintext exheader
      OtherUserSaveDataId2: 0x00000 # plaintext exheader
      OtherUserSaveDataId3: 0x00000 # plaintext exheader
      UseOtherVariationSaveData : false
     
    SystemControlInfo:
      SaveDataSize: 512KB # plaintext exheader
      RemasterVersion: 0 # plaintext exheader
      StackSize: 0x00040000 # plaintext exheader
      JumpId: 0x0004000000125600L
    I wonder, is there any chances to build firmware spoofed MM cia from decrypted files for 4.5 CFW?..
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice