Hacking Adrenaline Frame Skipping with Smooth Graphics Off

Burnt Lasagna

Well-Known Member
OP
Member
Joined
Feb 29, 2012
Messages
132
Trophies
0
XP
288
Country
United States
Some might know this (old news) but Adrenaline added support for disabling the internal GPU "Smooth Graphics" filtering in the Adrenaline settings. This is great for the PlayStation TV because it doesn't officially allow the user to toggle Bilinear filtering (it's forced on in PSP games).
However, I'm noticing that in certain instances, particularly during FMV, there is heavy frame skipping with Smooth Graphics set to "No". This performance impact baffles me since this setting should be zero image processing.

I created an issue topic on Adrenaline's GitHub page a while back but it was closed rather quickly with no explanation given. This tells me the issue either can't be fixed (hardware problem) or I'm being stupid and not doing something correctly.
Do other people have this problem? Does anyone know a fix or at least know why disabling the filter effects performance?

EDIT: For a quick demonstration of what I'm talking about, load up The Dracula X Chronicles and watch the opening FMV. If Filtering is set to "Bilinear" with Smooth Graphics set to "No", there will be heavy frame skipping in this video.
 
Last edited by Burnt Lasagna,

rsn8887

Well-Known Member
Member
Joined
Oct 8, 2015
Messages
947
Trophies
1
Age
45
Website
www.patreon.com
XP
3,375
Country
United States
- If you change the Graphics Filtering option (the first option) to anything else than "original" you will get slow-down.

- If you change the Screen Mode (PS1) option to anything else than "original," you will get slow-down in PS1 games.

- If you set Graphics Filtering to "original" and Screen Mode (PS1) to "original," and then change Smooth Graphics to ON or OFF, you shouldn't get any slow-down either way.
 
  • Like
Reactions: Count Duckula

deathblade200

Well-Known Member
Member
Joined
May 10, 2016
Messages
1,361
Trophies
0
XP
1,214
Country
United States
- If you change the Graphics Filtering option (the first option) to anything else than "original" you will get slow-down.

- If you change the Screen Mode (PS1) option to anything else than "original," you will get slow-down in PS1 games.

- If you set Graphics Filtering to "original" and Screen Mode (PS1) to "original," and then change Smooth Graphics to ON or OFF, you shouldn't get any slow-down either way.

1. wrong sharp bilinear doesn't cause any lag in games they others cause a bit though
2. wrong all this is doing is changing the screen size the same way the original psone classics do
3. I use sharp bilinear full screen (or if a game has black bars i use original size and then custom mode in the official option to remove bars) and I use smooth graphics all with 0 lag

and btw there is a way to completely turn off bilinear first set graphics filter to original and then in the adrenaline menu select "open official settings" and turn off the bilinear settings in that menu
 

rsn8887

Well-Known Member
Member
Joined
Oct 8, 2015
Messages
947
Trophies
1
Age
45
Website
www.patreon.com
XP
3,375
Country
United States
1. wrong sharp bilinear doesn't cause any lag in games they others cause a bit though
2. wrong all this is doing is changing the screen size the same way the original psone classics do
3. I use sharp bilinear full screen (or if a game has black bars i use original size and then custom mode in the official option to remove bars) and I use smooth graphics all with 0 lag

and btw there is a way to completely turn off bilinear first set graphics filter to original and then in the adrenaline menu select "open official settings" and turn off the bilinear settings in that menu

You are talking about Vita not VitaTV. VitaTV doesn’t have that option. Sharp-bilinear causes skipped frames during scrolling for me in the game Lomax, for example. Bilinear causes screen tearing.
 
Last edited by rsn8887,
  • Like
Reactions: Count Duckula

Burnt Lasagna

Well-Known Member
OP
Member
Joined
Feb 29, 2012
Messages
132
Trophies
0
XP
288
Country
United States
- If you set Graphics Filtering to "original" and Screen Mode (PS1) to "original," and then change Smooth Graphics to ON or OFF, you shouldn't get any slow-down either way.
Toggling Smooth Graphics off doesn't work when Graphics Filtering is set to "original" on the PSTV. Essentially, I have to have a filter enabled to shut off filtering...
 
Last edited by Burnt Lasagna,

rsn8887

Well-Known Member
Member
Joined
Oct 8, 2015
Messages
947
Trophies
1
Age
45
Website
www.patreon.com
XP
3,375
Country
United States
Toggling Smooth Graphics off doesn't work when Graphics Filtering is set to "original" on the PSTV. Essentially, I have to have a filter enabled to shut off filtering...

Yeah I forgot about that. I am having the same issue as you on my VitaTV. The only way I can use Adrenaline without any slowdown is by selecting “original” gfx modes. Also the VitaTV has almost no graphics settings in the official menu.

I think there’s an option to turn off smoothing in the official menu when a PS1 game is playing, but I might remember it wrong.

There’s a related problem when playing PS1 games on VitaTV with “original” settings: the aspect ratio of PS1 games is not exactly 4:3 for some reason. It is slightly stretched vertically. It is not a deal breaker. I mean it still looks pretty good and the games run perfect. But it would be nice to have perfect 4:3 aspect ratio for PS1 games, without slowdown. I am not sure if it is possible.
 

You may also like...

General chit-chat
Help Users
  • The Real Jdbye @ The Real Jdbye:
    why would you need your candles warmed?
  • The Real Jdbye @ The Real Jdbye:
    is this like a fetish thing
  • K3N1 @ K3N1:
    Because they obviously need to be warmed
  • K3N1 @ K3N1:
    The person who made the image was probably just thinking of wax melts and said candles shit happens
  • K3N1 @ K3N1:
    Although the wax of a candle could probably be melted down and repurposed with a fresh wick sometimes the wick burns out and the jar is still full
  • M4x1mumReZ @ M4x1mumReZ:
    I dont think a candle is ever going to work on there.
  • The Real Jdbye @ The Real Jdbye:
    no they're actually called candle warmers
    +1
  • M4x1mumReZ @ M4x1mumReZ:
    Thought that was a mug warmer.
  • The Real Jdbye @ The Real Jdbye:
    what i don't get is, if you want the smell, but not the ambience of burning a scented candle, why dont you just get an aromatherapy oil diffuser, scented candles are shit anyway they barely smell
    +1
  • The Real Jdbye @ The Real Jdbye:
    @M4x1mumReZ they're used for that, but they're called candle warmers
    +1
  • M4x1mumReZ @ M4x1mumReZ:
    I don't get why they would name it that.
  • M4x1mumReZ @ M4x1mumReZ:
    You wouldn't melt a candle with this, as if it was too big for example then the wax would flood the holder.
  • M4x1mumReZ @ M4x1mumReZ:
    That's my theory btw
  • The Real Jdbye @ The Real Jdbye:
    apparently people use them to melt scented candles instead of burning them which sounds like a very roundabout way to accomplish something
    +1
  • M4x1mumReZ @ M4x1mumReZ:
    It would be more recommended though for wax melts.
  • The Real Jdbye @ The Real Jdbye:
    yeah you use candles that come in jars, apparently
    +1
  • M4x1mumReZ @ M4x1mumReZ:
    You can get those small yankee candles.
  • M4x1mumReZ @ M4x1mumReZ:
    They come in tiny little jars.
  • M4x1mumReZ @ M4x1mumReZ:
    These are what I am on about.
  • The Real Jdbye @ The Real Jdbye:
    i've seen them
    +1
  • M4x1mumReZ @ M4x1mumReZ:
    Me too
  • M4x1mumReZ @ M4x1mumReZ:
    Really nice to have.
  • RetroNerdGamer @ RetroNerdGamer:
    lmao my dad just got one of those today
    RetroNerdGamer @ RetroNerdGamer: lmao my dad just got one of those today