WiiFlow - an open source GUI USB-Loader

Discussion in 'Wii - Backup Loaders' started by zorglub07, Jan 17, 2010.

  1. Tetsuo Shima

    Tetsuo Shima GBAtemp Advanced Fan

    Member
    8
    Oct 29, 2008
    Italy
    Not at all. Thanks for the clear explanation. Now it all makes sense to me.
     
  2. Tetsuo Shima

    Tetsuo Shima GBAtemp Advanced Fan

    Member
    8
    Oct 29, 2008
    Italy
    D'oh! :slamshisface:
    I missed this piece.

    Well, thanks to you both!:bow:
    What would I do without kind Gbatemp users?
    I will try d2x-v10-alt ASAP
     
  3. Tetsuo Shima

    Tetsuo Shima GBAtemp Advanced Fan

    Member
    8
    Oct 29, 2008
    Italy
    Ok I installed d2x-v10-beta53-alt on cios 249 base 56 and 250 base 57 as suggested on the wiki.
    Deleted wiiflow save from NAND.
    Now I can see all my partitions but it can't find no games, not even forcing Hermes Cios, which remained untouched and could see them in 4.1.
    I'm wondering why... I have them on a WBFS partition, can it be the reason?
     
  4. MassiveRican

    MassiveRican GBATemp's Unofficial Vigilante

    Member
    7
    Aug 2, 2011
    Creeping in the Shadows
    Possibly, I don't speak ill of WBFS, it has it's pros and cons, but I can definitely tell you FAT32 or even NTFS might be better for you. Try this app out, it works like a charm, you won't need to re-format your HDD. It converts a WBFS partition into a Fat32 partition - on the fly/in place, I can vouch for it's integrity I've converted a few drives myself and it's super quick :wink:
     
    ToddofWar420 likes this.
  5. Tetsuo Shima

    Tetsuo Shima GBAtemp Advanced Fan

    Member
    8
    Oct 29, 2008
    Italy
    Thanks but I solved my problem.
    I don't know what happened, I just pressed B to go to the emulators, then I switched back to USB and suddenly all of my games magically appeared.
    Tested some of them and they are finally working!
    No need to convert the partition to FAT, but thanks for that app nonetheless, I didn't know of its existence. I may need in a future.
    Now I'm very happy! Thanks everybody!
     
    MassiveRican likes this.
  6. MassiveRican

    MassiveRican GBATemp's Unofficial Vigilante

    Member
    7
    Aug 2, 2011
    Creeping in the Shadows
    Can anyone else confirm if the banner does not show for WWE '13? The game works just fine, but thinking it might be my dump unless anyone else has the issue.
     
  7. matto21

    matto21 GBAtemp Regular

    Member
    6
    Dec 29, 2011
    Italy
    here works well
    know how to remove the LED light when you start wiiflow
     
  8. MassiveRican

    MassiveRican GBATemp's Unofficial Vigilante

    Member
    7
    Aug 2, 2011
    Creeping in the Shadows
    Only know about the setting for LED w/DML games. However, not sure about LED @startup or in general.
     
  9. fledge68

    fledge68 GBAtemp Advanced Maniac

    Member
    10
    Jan 30, 2012
    United States
    Ok, Fix - I did some checking on that install game error. It just says "an error has occurred". I ran an sd log and noticed this

    Creating Gamelist
    Games found: 109
    Folder path to create: usb1::/wbfs
    Folder path to create: usb1::/wbfs/Carnival Games Mini Golf [RG9E54]
    SPLIT 0: no file

    notice in the path there are two ::
    This looks like a mistake to me. I think the path is getting an extra : thrown in there whenever fsop_makefolder() is called

    Also while checking the code I noticed that my wbfs_ext.c was still the old one with snprint and bzero instead of strncpy and memset. So I deleted it and recreated it thru svn update and it's still the old one. But I haven't been using my compiled versions just using the ones from caseyomaha so the sd log is unrelated to this weird problem. Must be some weird google svn problem.

    edit: weird I decided to make a new svn folder and do an svn checkout and now everything is fine with the code. Maybe svn update isn't working right but checkout does work right.
     
  10. FIX94

    FIX94 Global Moderator

    Global Moderator
    21
    Dec 3, 2009
    Germany
    ???
    Dump, bostonBC and MassiveRican like this.
  11. sdoc96

    sdoc96 Creaky Old Stiff Member

    Member
    4
    Jan 10, 2007
    Australia
    Melbourne
    Anyone else have no text in Wiiflow for r882-883? All I can see is empty buttons.
    Last version I compiled was r840 and that works fine.
    Everything else seems to work, except there is no text at all.

    Has there been a change to libraries or am I doing something really stupid? Clean install each time.
     
  12. Damian666

    Damian666 Coder from Hell

    Member
    6
    Mar 24, 2010
    Netherlands
    In your code...
    nah, i have it too when i try any new revs, or it doesnt start at all, just dsi errors on me, but the no text happened to me too, was able to get past it with a custom theme, think its default theme related O.o
     
  13. MassiveRican

    MassiveRican GBATemp's Unofficial Vigilante

    Member
    7
    Aug 2, 2011
    Creeping in the Shadows
    sorry to ask have you attempted letting wiiflow re-create a new wiiflow.ini? I'm curious to know if it creates one properly so you might want to try that. Also, try an older wiiflow.ini if you have any backed up that worked for you.
     
  14. sdoc96

    sdoc96 Creaky Old Stiff Member

    Member
    4
    Jan 10, 2007
    Australia
    Melbourne
    Yep let it re-create a wiiflow.ini on both 882 & 883, no good. Have not tried an old wiiflow.ini yet though - will give that a crack.
     
  15. bostonBC

    bostonBC GBAtemp Maniac

    Member
    6
    Aug 17, 2011
    United States
  16. AbdallahTerro

    AbdallahTerro da KiNG

    Member
    11
    Jan 14, 2012
    Ideas factory :)
    Same here.
    All my games are on usb2 ntfs
    when I try to install to usb1 fat32 I get game already exists message even though it doesn't!
    when I try to install to usb2 ntfs, I get no "game already message"! and then installation starts and "an error has occured" message
    So it seems not only installation is broken but also detection of already installed games.
    Also it would be cool if we can have simultaneous use of both USB ports like in GX.
    Thanks Fix for latest fix, flows are smooth now.
    Abz :)
     
  17. drakorex

    drakorex GBAtemp Advanced Maniac

    Member
    6
    Jan 19, 2011
    United States
    I've tried several times getting help on this without success and then gave up for a while, now I'm trying again. I used the d2x v10 alt installer on vwii, installing 249-56, 250-57, and 251-58. I then boot up wiiflow and no wii games want to start up no matter what ios is used, vwii just reboots. but if I use 249-58, most games start up and run, however monster hunter tri freezes when you try to begin a new game. Other people insist that 249-56 is the way to go and it works for them. Can somebody please help me figure out what I'm doing wrong?
     
  18. MassiveRican

    MassiveRican GBATemp's Unofficial Vigilante

    Member
    7
    Aug 2, 2011
    Creeping in the Shadows
    ^^ Does anyone else have Monster Hunter Tri that can test on vWii? That way we can at least confirm if there is a problem or not :!:

    @Fix94 thanks for the cover cache fix. As soon as TOW420 get's back to me with some news I'm going to start caching damn near 1000 Genesis covers so now I know it'll go nice and easy, probably with a few manual restarts since I know it could run out of mem with that many covers lol.
     
  19. matto21

    matto21 GBAtemp Regular

    Member
    6
    Dec 29, 2011
    Italy
    r883 vWii
    Monster Hunter Tri and all games OK
    does not return to wiiflow
     
  20. drakorex

    drakorex GBAtemp Advanced Maniac

    Member
    6
    Jan 19, 2011
    United States
    @matto21, How exactly did you go about installing d2x? Maybe I did it wrong, though I can't see how...
     
Quick Reply
Draft saved Draft deleted
Loading...