Question Which NSP installer supports USBHDD:/ except SX Installer?

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by wurstpistole, Mar 8, 2019.

  1. wurstpistole
    OP

    wurstpistole I got 8 warning points

    Member
    12
    Nov 19, 2015
    Gambia, The
    So I tried to switch to Atmos now and what I like to do is install my nsps from USB.
    SX Installer can do that with protocol USBHDD:/

    Now I tried Lithium, no usbhdd:/ there
    Tried Goldleaf, no function to install from USB
    Tried Tinfoil (this one) and despite specifically saying in the readme that SX USB Mass Storage Device installation is supported, also no success. Protocol usbhdd:/ is not available.

    SX Installer works fine (on SX OS), but that won't work on Atmos.
    So what can I use to install nsp from USB in Atmos?
     
  2. tomi1578

    tomi1578 GBAtemp Regular

    Member
    3
    Sep 12, 2018
    Israel
    Nothing
     
  3. wurstpistole
    OP

    wurstpistole I got 8 warning points

    Member
    12
    Nov 19, 2015
    Gambia, The
    You mean to tell me there is no Installer except SX Installer that supports installing from USB Devices?
     
    TotalJustice and peteruk like this.
  4. tinkle

    tinkle taciturn shill girl

    Member
    7
    Jun 9, 2015
    United States
    Exactly.None that have EmuNAND either, and none that allow for XCI Loading. You probably shouldn't have fallen for the anti-TX narrative brainwashing prominent around here, and invested in the premium product.
     
    tbb043, 210modz, Ita54_2 and 3 others like this.
  5. wurstpistole
    OP

    wurstpistole I got 8 warning points

    Member
    12
    Nov 19, 2015
    Gambia, The
    I have the premium product. That's why I am able to compare between SX Installer and the others in the first place.
    I just want to be ready for the exact moment where SX falls behind for weeks *ahem*
     
  6. a7mag3ddon

    a7mag3ddon GBAtemp Regular

    Member
    4
    Mar 17, 2013
    It hasnt fallen behind for weeks, unless you mean being able run on firmware 7.1 thats not even required for anything ?

    Run 7.0 ofw and 6.2 cfw emunand.
     
    comput3rus3r and thaikhoa like this.
  7. hashcheck1

    hashcheck1 GBAtemp Fan

    Member
    5
    Aug 5, 2013
    xecuter released src for this, goldleaf etc could incorporate
     
  8. baxzxd
    This message by baxzxd has been removed from public view by Minox, Mar 9, 2019, Reason: Flamebait.
    Mar 9, 2019
  9. Rahkeesh

    Rahkeesh GBAtemp Maniac

    Member
    7
    Apr 3, 2018
    United States
    I thought they released something closer to an API. So programs could hook into SX OS drivers, if you happen to be running SX OS.
     
  10. hashcheck1

    hashcheck1 GBAtemp Fan

    Member
    5
    Aug 5, 2013
    https://sx.xecuter.com/download/libusbfs.zip

    i don't even use sxos but have license
     
  11. DeuX

    DeuX GBAtemp Regular

    Member
    4
    Jun 14, 2018
    Switzerland
    TETRIS 99 [UPD] [65536]
    Fishing Universe Simulator [UPD] [65536]
    World Tree Marché [UPD] [65536]

    At least 3 new updates require to be on 7.0, so I wouldn't say anything
     
    wicksand420 and Essasetic like this.
  12. Thetoto

    Thetoto GBAtemp Advanced Fan

    Member
    5
    May 10, 2018
    France
    Rahkeesh likes this.
  13. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    11
    Nov 6, 2002
    United States
    Azores/Portugal
    Funny is that you bought SX OS and you asked here ? Why not asking SX OS developer about it ? Thats what they are doing. Ask them for an accurate answer.
     
    TotalJustice likes this.
  14. wurstpistole
    OP

    wurstpistole I got 8 warning points

    Member
    12
    Nov 19, 2015
    Gambia, The
    Thanks for your completely irrelevant answer.
     
    retrofan_k, Heichart and crazy_p like this.
  15. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    First, the switch from SX OS to Atmosphere is highly recommended, if not only because TX now appears unable to support 7.0.0 and higher. Many would not be surprised if they we're abandoning SX OS in a similar way Gateway was abandoned, and even if it's not happening now, the abandonment of SX OS is likely to happen eventually for various reasons.

    Second, you cannot install NSP files from a USB HDD right now. You can, however, install directly from your computer over a USB connection. There's no reason to use the USB HDD as a middleman.
     
    wicksand420, Heichart and ghjfdtg like this.
  16. AnalogMan

    AnalogMan ultraSuMoFramework Dev

    Member
    12
    Apr 20, 2007
    United States
    The USBHDD:/ protocol is part of SXOS. Tinfoil does have the ability to use it but since it only exists under SXOS, you only see that option if you run Tinfoil on SXOS. Since Atmosphere does not have the USBHDD:/ protocol no apps that incorporate it will be able to use when run under Atmosphere.
     
    wicksand420 and Rahkeesh like this.
  17. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    11
    Nov 6, 2002
    United States
    Azores/Portugal
    LOL! That is silly comment. You are welcome but your question is actually irrelevant question, really. Buying SX OS should ask the question to the developer who sold it to you. Sometimes we give you the wrong answer so that is inaccurate in here. The developer is your accurate answer. Just saying.
     
  18. Rahkeesh

    Rahkeesh GBAtemp Maniac

    Member
    7
    Apr 3, 2018
    United States
    Eh there's some added convenience to not needing to mess with two clients instead of one. Although I assumed OP would know about this option but worth bringing up just to be sure.
     
  19. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    The added convenience is minimal, if not irrelevant, when contrasted with the added convenience of not having to use a USB HDD middleman.
     
  20. youcantseeme421

    youcantseeme421 Banned

    Banned
    2
    Jun 2, 2018
    United States

    Nobody recommends that besides the 4 or 5 silly nut huggers that bash TX every chance they get. I swear, it's the silliest thing I see on here. The thing is, majority of SX users (probably Atmo users too) don't care for 7.0.0. They just simply do not care, and you will not change their mind. They want to play backups. There are installers which can bypass the firmware requirements, so it's not an issue.

    Just let people enjoy things and do what they want.
    Either help the man, or don't comment. You type of people are the absolute worst. Ruining a good forum
     
    Last edited by youcantseeme421, Mar 9, 2019
    tbb043, retrofan_k, opmas and 3 others like this.
  21. Lacius

    Lacius GBAtemp Legend

    Member
    18
    May 11, 2008
    United States
    To say there are only four or five people on GBATemp who recommend switching from SX OS to Atmosphere isn't even close to true. Disingenuous claims won't help make your point.

    When games require 7.0.0 or higher, which is an inevitability, they will care.

    That won't work with games that use newer keys or newer software development kits. Unless SX OS comes out with support for 7.0.0 or higher, there will be a time when new games are unplayable using SX OS.
     
    ZachyCatGames and ghjfdtg like this.
Quick Reply
Draft saved Draft deleted
Loading...