Hacking Unable to fix TWL Firm

Danni95dg

Member
OP
Newcomer
Joined
Aug 4, 2016
Messages
13
Trophies
0
Age
26
XP
43
Country
Hey there!

So, since it seems that nobody finds a solution in the official topic for Luma 3DS, I'm opening a new thread.

I have my o3DS with Luma3DS 6.1 with firmware 11.0E. I am completely unable to boot flashcards (I get error message), DSi games (black screen with 3ds theme sound) or DS Wi-Fi Settings (Black screen)

  • I have installed the original TWL FIRM from AuroraWright's guide.
  • I have erased my TWL FIRM, and installed the clean one.
  • I have A9LH, and no bootmanager
  • These games are neither working if I open Gateway mode instead of Luma
  • First time I opened Luma I could use Flashcards, but not DSi games
And that's all the information I can provide, I think. Then... Someone thinks about a possible solution?
 

Wojton

Well-Known Member
Member
Joined
Mar 7, 2014
Messages
180
Trophies
0
Age
30
XP
219
Country
Poland
Do you know when it started happening? If you do, and you have a NAND backup with functioning DS-mode, try doing the following:

-Backup your NAND
-Restore old NAND backup (from when the DS mode used to work properly)
-Dump TWLN/TWLP partition using Decrypt9
-Restore your current NAND backup
-Restore the TWLN/TWLP dumps using Decrypt9
 
Last edited by Wojton,

GothicIII

Well-Known Member
Member
Joined
Jan 4, 2015
Messages
809
Trophies
0
Age
34
XP
1,796
Country
Gambia, The
I have the similar problem but I don't own ds games only flashcards. I'm using a9lh boot manager.
Gateway emunand/sysnand won't boot ds mode. It's broken since a9lh atleast for me.
Luma doesn't work because of bootmanager. The patches luma tries to apply break ds mode because the a9lh bootmanager messes with the RAM.

I managed to solve it with cakes fw. If you provide a twl firm dump and put it into the cakes folder it will force load it and overwrite the memory region no matter what. So ds mode works with it.
 
Last edited by GothicIII,

Danni95dg

Member
OP
Newcomer
Joined
Aug 4, 2016
Messages
13
Trophies
0
Age
26
XP
43
Country
I have the similar problem but I don't own ds games only flashcards. I'm using a9lh boot manager.
Gateway emunand/sysnand won't boot ds mode. It's broken since a9lh atleast for me.
Luma doesn't work because of bootmanager. The patches luma tries to apply break ds mode because the a9lh bootmanager messes with the RAM.

I managed to solve it with cakes fw. If you provide a twl firm dump and put it into the cakes folder it will force load it and overwrite the memory region no matter what. So ds mode works with it.
Woah! Didn't know about that! ^^ Then I have to try.
I have no problem with the RAM, I can run SMB ang GBA games.
By the way, are there regions for TWL FIRM? Maybe I was using one from another region (?)

Do you know when it started happening? If you do, and you have a NAND backup with functioning DS-mode, try doing the following:

-Backup your NAND
-Restore old NAND backup (from when the DS mode used to work properly)
-Dump TWLN/TWLP partition using Decrypt9
-Restore your current NAND backup
-Restore the TWLN/TWLP dumps using Decrypt9
Woops, I did not see this message the first time n_n" Sorry.

That's a REALLY good idea, I'll try too :D
 
Last edited by Danni95dg,

Danni95dg

Member
OP
Newcomer
Joined
Aug 4, 2016
Messages
13
Trophies
0
Age
26
XP
43
Country
Hi everyone! Sorry for dobleposting, but it's to let moderators know that they can close the thread. While trying to do the solutions @Wojton and @GothicIII gave me, I found this from Plailect. And finally everything is working back.

Thank you both! I was about to give up :D
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    K3N1 @ K3N1: https://youtu.be/JEFuHlAkoJs