Triiforce MRC and Art Style games

Discussion in 'Wii - Hacking' started by Sicklyboy, Aug 24, 2010.

Aug 24, 2010
  1. Sicklyboy
    OP

    Global Moderator Sicklyboy Resident Mechanical Keyboard Addict

    Joined:
    Jul 15, 2009
    Messages:
    5,620
    Location:
    [̲̅$̲̅(̲̅ ͡° ͜ʖ ͡°̲̅)̲̅$̲̅]
    Country:
    United States
    I cant figure out how to get any of the Art Style games (Rotozoa, Rotohex, etc) to work. I have installed saves for it, they are good wads, and I have changed the boot method to Load Apploader but they just black screen. Any idea what is going on? =(
     
  2. AdamBrunt

    Member AdamBrunt GBAtemp Advanced Fan

    Joined:
    Jun 24, 2003
    Messages:
    688
    Country:
    Can't help but having exactly the same problem.
     
  3. Sicklyboy
    OP

    Global Moderator Sicklyboy Resident Mechanical Keyboard Addict

    Joined:
    Jul 15, 2009
    Messages:
    5,620
    Location:
    [̲̅$̲̅(̲̅ ͡° ͜ʖ ͡°̲̅)̲̅$̲̅]
    Country:
    United States
    Odd thing is that I DID have rotozoa and light trax working at one point, and none of the settings have changed since. Theyre both in-region wads, so I don't need to force the language or video mode. I can change it to "normal boot method" and try it again... but I think that will be taking a step backwards.

    Question is related - I when the games DO work, I can't load them through an ISO forwarder in CFG Loader. It errors with a grey "System files are corrupted. Please delete *game* through the Data Management screen, then redownload it. If the problem persists, call NIntendo at *whatever their number is*". Why does it do this? T_T
     
  4. AdamBrunt

    Member AdamBrunt GBAtemp Advanced Fan

    Joined:
    Jun 24, 2003
    Messages:
    688
    Country:
    You've completely lost me now .... you can play Wiiware via CFG Loader ?

    EDIT: Nvm ... I have just found this - http://gbatemp.net/index.php?showtopic=207530
     
  5. marc_max

    Member marc_max GBAtemp Advanced Fan

    Joined:
    Jun 19, 2008
    Messages:
    812
    Country:
    Spain
    Install a System Menu 3.2 to your emulated NAND using ShowMiiWads.
    I'm doing some tests.
    My Cubello stopped working from USB NAND last month (it can be related to the new Wii I bought).
    I installed a System Menu 3.2 on my USB NAND and now it works again! Can anyone try this on their NAND? Because some users were having problems running these games even having a System Menu installed on their NAND and using Apploader method and it seems this is the final solution.

    You must install a System Menu 3.2 and use Apploader method.
     
  6. twig123

    Member twig123 GBAtemp Regular

    Joined:
    Apr 4, 2009
    Messages:
    258
    Country:
    United States
    @plasma dragon007
    Really?
    Did you read my reply to you having issues with the bit.trip games at all?
    http://gbatemp.net/t249621-bit-trip-games-...t&p=3065594

    1) You need a FULL dump of your NAND (this would contain the SM as suggested by marc_max above)
    2) You need to install the save file
    3) The game needs to be set to 'Apploader'


    @marc_max
    Could we add the info that a Full dump is needed in the Triiforce_MRC thread, so that we can potentially avoid issues with nand dumps?
    or maybe at least mention that some games will not function without one?
     
  7. marc_max

    Member marc_max GBAtemp Advanced Fan

    Joined:
    Jun 19, 2008
    Messages:
    812
    Country:
    Spain
    I don't have a full dump.
    I had a Compatibility Dump from SimpleFSDumper, and it worked correctly. But when I had to buy a new Wii, I remember that I made a new dump with SimpleFSDumper, deleted ticket and title folders from the new dump and copied these folders from the old nand dump. Then Cubello stopped working (even with Apploader method), but the other Art Style games worked perfectly.

    Theorically, SimpleFSDumper's Compatibility Dump also dumps System Menu (it's needed for the Apploader method). But for some reason, it doesn't appear on ShowMiiWads. I tried installing a 4.2, but Cubello still didn't work. I tried a 3.2 and it worked.

    Also, I don't know if they need a save file because when I made my Wii's dump I already had a savefile for Cubello and Orbient.

    @twig123 I'll post it now on Triiforce mrc thread. I hope someone can confirm this!
     
  8. Slimmmmmm

    Member Slimmmmmm GBAtemp MoNkEeE

    Joined:
    Nov 1, 2007
    Messages:
    1,687
    Location:
    the land of lol
    Country:
    United Kingdom
    I'm sure it's either a wrong version of the IOS the game uses (quick to test) or one of the shared content files is different from those people that have it working, or a third thing (unlikely) could be the install method.

    It can't be the difference between a full nand dump and a partial dump, well unless you want to be really vague about it.

    At present I've got a new Wii too and the art style games weren't working with my current setup. I had another Wii before this and they never worked no matter what sys menu Ver the emu nand had, app loader or not, save file on before etc. One day they started working though.

    What I learned at the time, was no sys menu version change, full dump/part or save file "tricks" worked. PAL on PAL btw. I gave up because I didn't have time to continue going through every situation and I never got a comparitive from someone with it working.

    Then, I went back to doing other things with the Wii and forgot about the games. That Wii was formated, virginised and set up over and over with testing some other things at that time and I cant be sure of everything that changed but I know IOS versions changed, the shared content was newer or older but NOT the same and the WiiWare were all installed to the NAND, played, saves made and THEN a nand dump made for Triiforce.

    So that would be option 3, the install method..unlikely but maybe installing these games to the actual nand writes something different to the uid.sys, or it prefers one version of a shared content over another that ShowMiiWads doesn't.

    The answer is there somewhere.
     
  9. marc_max

    Member marc_max GBAtemp Advanced Fan

    Joined:
    Jun 19, 2008
    Messages:
    812
    Country:
    Spain
    I don't think it's the IOS, games are always working on a cIOS. It's possible that they still search for the contents from their IOS, but I doubt it.
    And yes, the difference between a full nand dump and a partial dump is important. The apploader requires a System Menu installed, and some dumps made with old SimpleFSDumper versions didn't dump the System Menu, for example.
     
  10. AdamBrunt

    Member AdamBrunt GBAtemp Advanced Fan

    Joined:
    Jun 24, 2003
    Messages:
    688
    Country:
    My NAND is a full dump (well, ShowMiiWads lists a whole load of IOS and SM data when ithe first dump I had didn't have any of this) - taken from my Wii which is 4.2E. Haven't tried replacing it with a full 3.2 dump though.

    I also haven't tried using twig123's save files - that's probably my next step.

    I also can't remember if I ever got them to work (or even tried) by installing onto real NAND either.
     
  11. marc_max

    Member marc_max GBAtemp Advanced Fan

    Joined:
    Jun 19, 2008
    Messages:
    812
    Country:
    Spain
    You don't have to replace it with a full 3.2 dump, you only need to install a 3.2 System Menu. You can revert back at any time to 4.2 by doing the same.
     
  12. AdamBrunt

    Member AdamBrunt GBAtemp Advanced Fan

    Joined:
    Jun 24, 2003
    Messages:
    688
    Country:
    Ah, ok.

    I'll give that a go after trying twig123's save files if they don't work.
     
  13. Sicklyboy
    OP

    Global Moderator Sicklyboy Resident Mechanical Keyboard Addict

    Joined:
    Jul 15, 2009
    Messages:
    5,620
    Location:
    [̲̅$̲̅(̲̅ ͡° ͜ʖ ͡°̲̅)̲̅$̲̅]
    Country:
    United States
    Taking in everything I have read from this...

    twig - I apologize, once I had figured out my issues (or so it seemed) from my previous thread I stopped following it, thus I failed to see your last post in it.

    In ShowMiiNand, what am I looking for to see whether I have a 4.2U SM in there or not? There are a few Hidden Chanels and a System Channel in there. I made a dump with SimpleFS Dumper (idr what version, will check in a minute or two).

    Oddly, some games DID require "Apploader" method to work, and setting them to Apploader made them work. But the art Style games are an exception it seems o.o

    Anyway, I will use NUSAD to grab a SM 3.2U wad and install that to the emu NAND.

    Turns out no menu was installed. Installed 3.2U, gonna test in a sec
     
  14. twig123

    Member twig123 GBAtemp Regular

    Joined:
    Apr 4, 2009
    Messages:
    258
    Country:
    United States
    I have my ArtStyle and Bit.Trip games working on a 4.2U nand with no problem...
    They were all installed through ShowMiiNand. I did install them on the real nand, grabbed the save files for each and then uninstalled, but the nand dump was done before I did that. I have a FULL dump from SFSD 0.42 and is also working with SNEEK.

    But from the testing that I did and my post in the Triiforce_MRC thread, these games DO indeed need a save file present for them to start on emulated nand.
    Also, as Slimmmmmm suggested, you might have and outdated IOS that could be preventing it from running as well.

    Here's what I did:
    Ran PimpMyWii (To install all updates except for cIOS 249, as it installs rev19 and doesn't support nand emulation)
    Made sure Wii was hacked to my liking
    Did a FULL dump with SFSD 0.42 (Wii is SM 4.2U)
    Tested games in Triiforce_MRC (Pretty much all I had worked, except the ones that need save files)
    Installed WW that required saves to actual nand & gathered files.
    Uninstalled WW
    Copied Save files to emulated nand
    Set Triiforce_MRC to Apploader for games that previously didn't work
    ...poof, works for me

    Don't know if that helps or not, but that is what worked for me.
     
  15. Sicklyboy
    OP

    Global Moderator Sicklyboy Resident Mechanical Keyboard Addict

    Joined:
    Jul 15, 2009
    Messages:
    5,620
    Location:
    [̲̅$̲̅(̲̅ ͡° ͜ʖ ͡°̲̅)̲̅$̲̅]
    Country:
    United States
    Huh. Rotozoa and Light Trax work fine now (I installed 3.2U and they didnt work, but 4.2U did). Orbient, Rotohex, and Cubello still don't work though (all set to apploader).

    Gonna use twig's saves but idk what that would do... I already have saves there o.o

    Still lost. I reinstalled 3.2U and used Twig's saves, Rotozoa and Light Trax still work but Cubello, Rotohex, and Orbient STILL refuse to work whether they are set to Apploader or Normal! Wiimote loses sync and the system blackscreens, that is it.
     
  16. marc_max

    Member marc_max GBAtemp Advanced Fan

    Joined:
    Jun 19, 2008
    Messages:
    812
    Country:
    Spain
    Are you using ShowMiiWads to install games? Or they are already installed before making the NAND dump?

    DON'T use wad2nand.
    Check if you have sys/uid.sys. Hex-search for the game ID that does not work inside that file. Is it on the file?

    EDIT: Also, re-install it with ShowMiiWads even if you have it installed.

    EDIT2: I saw that I commented a very important block of code (and I can't remember why). On main.c lines 804-808 are commented, uncomment them and recompile and try it again. I hope this is not the problem because it was my own fault!
     
  17. Sicklyboy
    OP

    Global Moderator Sicklyboy Resident Mechanical Keyboard Addict

    Joined:
    Jul 15, 2009
    Messages:
    5,620
    Location:
    [̲̅$̲̅(̲̅ ͡° ͜ʖ ͡°̲̅)̲̅$̲̅]
    Country:
    United States
    Yessir, I am using ShowMiiWads to install the games. I would use YAWMM but I get a -1024 when trying to install to emu nand on the wii and can't browse the fat32 drive (cios249 rev17 base whatever is the one that is that works the best... too tired to remember right now. 38?)

    I do have sys\uid.sys

    I take it hex search that file is what you mean? I have never used a hex editor, but can try my best. Reccomend any specific one?

    And main.c for the source of triiforce mrc? I will have to find it and recompile it tomorrow, I assume it is hosted on google code? Also, I feel so dumb for asking this because I am majoring in computer science (being up at 2 AM isnt helping) but I havent dealt with C, just C++ and Java. Are the libs included with most C editors, or are they included with windows?

    IIRC Borland C++ comes with the C++ libs... (Sorry... I am asking you so many things I could easily figure out for myself once I have more than 3 minutes to sit down and look at it... but if you do have any input on anything I asked, I would greatly appreciate it =)

    Off topic - Cubello is annoyingly complicated IMO, and I can hardly play Rotohex bcause I am colorblind (really, why would you not include a colorblind mode in a game like that!?). Orbient is AMAZING though
     

Share This Page