Trails/Kiseki modding

Discussion in 'PSP - Hacking & Homebrew' started by julialy, Jul 7, 2017.

  1. supermist

    supermist GBAtemp Regular

    Member
    3
    Jan 26, 2009
    United States
    I think I'm having the same text display issue for the Chinese version of Ao. Characters are all over the place. The translated textures from the HD Texture pack are working however.

    Tried changing the font which seems to better contain some of the characters but its still kind of everywhere. Looking at earlier posts I'm not sure what step I'm missing to get it working.

    Seeing how Guren's Ao translation is almost done, I wanted to use UMDGen to extract the scena and text files and place them into the PC version and use the 60FPS hook. I know that might not even work but I at least wanted to give this a try so I'm using the current translation as a means of practice.
     
    ton likes this.
  2. julialy
    OP

    julialy Homebrewer

    Member
    6
    Nov 26, 2012
    United States
    United States
    Be sure you have your non-unicode language setting set to Chinese(Traditional)
     
  3. supermist

    supermist GBAtemp Regular

    Member
    3
    Jan 26, 2009
    United States
    Hmm there are 3 different Chinese Traditional options. Does it matter which I pick?
     
  4. julialy
    OP

    julialy Homebrewer

    Member
    6
    Nov 26, 2012
    United States
    United States
    No.
    If one option displays garbled text try another option.
    If you want to play with the Japanese patch, you need to select Japanese instead. (The Ao patch will use the Japanese version as a base).

    Also, in the future, the patch will auto-change the language so you don't have to do it.
     
  5. supermist

    supermist GBAtemp Regular

    Member
    3
    Jan 26, 2009
    United States
    Hmm, the Chinese characters displayed but when I put the English scena and text it's all squares. I changed the user ft too.
     
  6. julialy
    OP

    julialy Homebrewer

    Member
    6
    Nov 26, 2012
    United States
    United States
    Are you attempting to play Zero or Ao?
    If you are attempting to play Zero, you need to use the Japanese version of the game, since the Chinese version of the game does not display ASCII text correctly.
    If you are attempting to play Ao, something else is going on and I never encountered your problem.
     
  7. supermist

    supermist GBAtemp Regular

    Member
    3
    Jan 26, 2009
    United States
    With Zero I was able to get the Japanese version working with the english translated text and scena. There's some annoying flickering so I may try the chinese version.

    Ao is where I can't get the english text and scena to display properly but I should play around with some options.
     
  8. supermist

    supermist GBAtemp Regular

    Member
    3
    Jan 26, 2009
    United States
    I think I narrowed down the issue. I reinstalled the game and the Chinese text displays fine.

    I extract the english scena and text files with UMD gen. Its still in Chinese.

    I then change the user.ft file and this is where I'm getting the squares and etc.
     
  9. julialy
    OP

    julialy Homebrewer

    Member
    6
    Nov 26, 2012
    United States
    United States
    Try removing the "Ouroboros" and "patch" directories.
     
    supermist likes this.
  10. supermist

    supermist GBAtemp Regular

    Member
    3
    Jan 26, 2009
    United States
    I don't see those so maybe its my version.
     
  11. julialy
    OP

    julialy Homebrewer

    Member
    6
    Nov 26, 2012
    United States
    United States
    Oh, also, make sure you are overwriting all of the files in data/scena, or you will get wrong story text.
    There's currently no solution to UI text.
     
  12. supermist

    supermist GBAtemp Regular

    Member
    3
    Jan 26, 2009
    United States
    I did overwrite them, but I think the Chinese version had more scena files.
     
  13. julialy
    OP

    julialy Homebrewer

    Member
    6
    Nov 26, 2012
    United States
    United States
    Are you sure you are extracting files from english patched version and not the original Japanese version?

    Why don't you try your ISO in PPSSPP?
     
  14. supermist

    supermist GBAtemp Regular

    Member
    3
    Jan 26, 2009
    United States
    Yeah I did double check that. Seems that no matter which PC version of Ao I'm using it doesn't translate.

    Unlike all the versions of Zero which did when following the same steps :P
     
  15. julialy
    OP

    julialy Homebrewer

    Member
    6
    Nov 26, 2012
    United States
    United States
    Is your filesystem case sensitive? Just delete all the scena files then copy the new scena files over.
     
  16. supermist

    supermist GBAtemp Regular

    Member
    3
    Jan 26, 2009
    United States
    Ah man... I tried that too and still no go.

    I think I'll just hold off on Ao PC for now and try again in a couple of weeks. As always, thanks for your help and everything you've done for this community.
     
  17. flame1234

    flame1234 GBAtemp Advanced Fan

    Member
    6
    May 17, 2009
    United States
    I want to get rid of the black borders when the movies play.

    All of the movies are full frame 480x272 but the "event scene indicator" (black bars on the top and bottom) obscures part of them. Any idea how hard this is to do? I think it wouldn't be so hard to remove all the black bars throughout the game (you just nop that microcode or at least part of it), but I would like to keep those, except for the movies.

    EDIT:
    I figured out that microcode 0x19 EventBegin has a single-byte parameter. If it is zero, then it gives the normal black bars during the event and if it is one, it plays the event without them.

    So the thing to try would be:
    Adding event end microcode + event begin microcode with 01 parameter before each of the movies.
    Adding event end microcode + event begin microcode with 00 parameter after each of the movies.
    EDIT: Tried this and it didn't work. I give up on this. It played the movie without the black border but the part after was messed up.

    EDIT: Okay, I tried it a different way and it worked.
    Microcode B8 (for the movies) gets called before and after each movie and the first byte parameter is different on those calls.
    So I found the place in the code that gets hit on movie start/end.
    And there I put modifications of the parameters for the black bars which are li instructions in the code. But PPSSPP doesn't like that very much (you have to disable dynarec to make it work like this).
    So then I modified the parameters to be lw instructions instead of li which worked.
     
    Last edited by flame1234, Feb 3, 2018
  18. zeropain

    zeropain Newbie

    It seems like that Gurens translation patch could be released in this month according to one of his replies to a post made at his blog. Cant wait for it.
     
  19. trailsfan

    trailsfan Member

    Newcomer
    1
    Jun 5, 2017
    United States
    Guys, why dont we contact to ZhenjianYang (who made tools for Trails games) to help us make a tool or python script for Trails in the Sky the 3rd?
     
  20. DeadlyAnGeL91792

    DeadlyAnGeL91792 GBAtemp Regular

    Member
    3
    Sep 9, 2010
    United States
    The Usa
    @julialy Did the controller problem on the AO hook exe file for AO pc ever get fixed?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice