Question Switch won't load Sysnand after Nand Restore using Hekate Tools

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Rocho, Aug 1, 2019.

  1. Rocho
    OP

    Rocho Newbie

    Newcomer
    1
    Aug 1, 2019
    Guatemala
    Hi,

    since yesterday I've been trying to recover my switch sysnand since I can no longer access it after a nand restore I did with Hekate tools,

    I was trying to return to my first and only backup I generated yesterday too as it was the first time I hacked my Switch using this guide: nh-server.github everything went fine till I tried to install a nsp game on emunand and realized it was also showing on my Sysnand.

    For security reasons I tried to unlink the sysnand and emunand by initializing (factory reseting) the emunand but it also initialized my sysnand. In an attempt to restore to my virgin sysnand I ran a restore using Hekate tools but after that I wasn't able to access neither Sysnand nor Emunand.

    When loading any of this 2 I get the Nintendo Switch Logo followed by an error 2002-4153 stating: An error has ocurred. Please press the POWER Button to restart the console normally or a VOL Button to reboot to payload. If you are unable to restart the console, hold the POWER Button for 12 seconds to turn the console off.

    I mannaged to enter emunand by downloading the files from sdsetup(dot)com and found out my emunand was has restored to my original files, including my games and photos. But sysnand is still unloadable even without the SD inserted.


    Is there any way to restore the original OS for the sysnand? I tried to use :

    ChoiDujourNXv102
    Gptrestore
    going into recovery mode and trying the 3 options : update, initialize without losing data and initialize.


    I do really need help at this point as I searched a lot of topics but most of them don't lead to concrete solutions.
     

    Attached Files:

    NoNAND likes this.
  2. Rocho
    OP

    Rocho Newbie

    Newcomer
    1
    Aug 1, 2019
    Guatemala
    Hi!

    I just wanted to let everyone know I successfully recovered my sysnand!!

    I formated my sd card several times to.FAT32 and passed a slower option with the partitioner program on the guide I was following (add zeroes).

    Then I reinserted all the files from the tutorial as if I was going to generate a new emuMMC BUT i added my backup files already to the SD card.

    After I had acces to Hekate i tried restoring again BOOT0 and BOOT1 followed by a nand restore. As there was no EmuMMC created just yet on my clean SD the restore had no option but restore my Sysnand!

    Checked and it wirks without the SD card too.

    Now I've finished the process and finally have emuMMC again.

    This emuMMC had my Nintendo acccount linked to it so to unlink it from my Sysnand I opened (important) EmuaMMC and initialized the console (factory reseted) and bow I have a separated Sysnand and EmuMMC!!!


    Just wanted to put this down so if anyone has the same problem could try this steps.
     
    jajamundo likes this.
Quick Reply
Draft saved Draft deleted
Loading...