Star link requiring me to update to firmware 6

Discussion in 'Switch - Backup Loaders & Modchips' started by NathanBrown, Oct 14, 2018.

  1. NathanBrown
    OP

    NathanBrown Advanced Member

    Newcomer
    3
    Jun 19, 2018
    India
    Should I go ahead and do it? Did it ask for anyone else? I got the XCI and the update file, but I haven’t played the game yet cause it’s forcing me to system update
     
  2. dsrules

    dsrules GBAtemp Guru

    Member
    9
    Sep 20, 2005
    if you updated the game then it requires 6.0
     
  3. nyder

    nyder GBAtemp Fan

    Member
    5
    Mar 6, 2014
    United States
    Here is my take on it. Since it requires 6.0, i wouldn't be surprised that the games coming out in Nov + is going to require 6.0. So I bit the bullet and upgraded my Switch to the 6.01 or whatever the latest version is. Haven't been having a problem.
     
  4. IceTeaX

    IceTeaX Member

    Newcomer
    2
    Apr 26, 2018
    Germany
    Use tinfoil to install the nsp and it will remove the firmware requirement.
     
    Green Hypnotic likes this.
  5. frostii

    frostii GBAtemp Regular

    Member
    4
    Jun 24, 2009
    United States
    Brisbane, Australia
    I bit the bullet and went from 5.1 to 6.0.1.
    Starlink + update nsp plays fine. In fact I've got no issues with any games (using SX OS 2.0.1).
    Realistically, all big games from now on will require a minimum of 6.0, so you might as well update!
     
  6. Garou

    Garou GBAtemp Maniac

    Member
    6
    Jan 13, 2015
    star link can still run on firmware 5.x.x if you install it using tinfoil's ignore firmware requirement

    until just a while ago, games requiring firmware 5.0.0 and above can still running on 4.0.0-4.1.0. even updates that need 6.0.0 can still be used on 4.0.0
    I'd say we have another month or 2 until games actually require firmware 6.0.0
     
    fr33x74 and Draxzelex like this.
  7. NathanBrown
    OP

    NathanBrown Advanced Member

    Newcomer
    3
    Jun 19, 2018
    India
    I need to start looking into tinfoil tbh, I’ve been relying on just SX OS, I feel like I’m missing out a lot
     
    IceTeaX likes this.
  8. IceTeaX

    IceTeaX Member

    Newcomer
    2
    Apr 26, 2018
    Germany
    It's super simple. Give it a try;)
     
  9. Skiiermike

    Skiiermike Member

    Newcomer
    3
    Feb 26, 2018
    Canada
    All you need to do is create a folder on your sd called switch.

    Place the tinfoil nro in it and run it once from the homebrew tab in sx os.

    From then on put your nsps in the newly created tinfoil/nsp folder.

    Run tinfoil from the homebrew tab and install your nsps.

    Sent from my SM-N950W using Tapatalk
     
    GunzOfNavarone likes this.
  10. Shoruk3n

    Shoruk3n Advanced Member

    Newcomer
    2
    Jul 20, 2018
    United States
    Sacramento, CA
    Was this game leaked or something? Release is supposed to be the 16th
     
  11. lil-devil

    lil-devil GBAtemp Regular

    Member
    5
    Oct 16, 2007
    Canada
    yup.... nothing new....
     
    GunzOfNavarone likes this.
  12. Frexxos

    Frexxos GBAtemp Fan

    Member
    6
    Apr 27, 2015
    Germany
    if you install it with tinfoil you can skip those firmware required thing?!
     
  13. lil-devil

    lil-devil GBAtemp Regular

    Member
    5
    Oct 16, 2007
    Canada
    so far, all the games can be had on a lower version if you skipped the firmware requirement on tinfoil. least, its true for 5.0.1 switch firmware.
     
  14. Garou

    Garou GBAtemp Maniac

    Member
    6
    Jan 13, 2015
    again, check the masterkey used by the game
    you still can't play games if it requires newer masterkey. fortunately games released until today still using masterkey that available since 5.0.0
     
  15. alienware777

    alienware777 Member

    Newcomer
    3
    Dec 15, 2009
    United States
    Of all the features TX has yet to steal, why is tinfoil firmware check not already done
     
  16. jajamundo

    jajamundo GBAtemp Regular

    Member
    5
    Aug 28, 2009
    United States
    We actuallly dont care about this. The reason is simple. We have a OFW on a lower version and CFW in the highest. We just use emuNand. Simple as that
     
  17. alienware777

    alienware777 Member

    Newcomer
    3
    Dec 15, 2009
    United States
    Who exactly is 'we' you speak of? I was one of the first preorders for sx pro, and I want the firmware check feature. Next time don't speak for the world eh?
     
  18. loler55

    loler55 GBAtemp Advanced Fan

    Member
    5
    Jan 4, 2012
    Gambia, The
    you dont need it since you can use emunand
     
  19. carlskie

    carlskie Member

    Newcomer
    1
    Dec 21, 2017
    Philippines
    im having a problem with tinfoil on sx os 2.1 running 5.1 i got an error 2168-0002 when i click on album, but i can play the games i install on tinfoil
     
  20. alienware777

    alienware777 Member

    Newcomer
    3
    Dec 15, 2009
    United States
    I didn't realize I was part of a hivemind. I didn't realize loler55 is able to tell me what I need and don't need.
     
Loading...