Hacking soft reset problem

DeathEvil

Member
OP
Newcomer
Joined
Apr 19, 2012
Messages
20
Trophies
0
XP
14
Country
United States
Soft reset works for bout 98% of games which is right from what I have been reading, but everytime it resets, the shortcut is gone and clicking on microsd shows empty folder. turning ds of and on of course fixes it. memory was just formatted using sd formatter, latest akaio with latest loaders. Using custom skin (probably dont matter), but I'm suspecting it could be due to 32gb microsdhc sandisk? it works great without the soft reset and I'm loving akaio as well as acekard:)

it would be sweet if there was an option to reset ds from the akaio menu.
 

Another World

Emulate the Planet!
Former Staff
Joined
Jan 3, 2008
Messages
10,578
Trophies
0
Age
46
Location
From Where???
Website
wiki.gbatemp.net
XP
5,371
Country
Colombia
there has been a issue with soft-reset for awhile. i've had it but norm has not been able to reproduce it. it was more wide spread a few builds ago and he made some adjustments in an attempt to fix it.

i experience the exact situation you are describing. i also experience soft-reset taking me back to root, forcing me to dive back into my directories. i've formatted, scanned the card, looked for issues, etc, but have never been able to solve the problem. the real interesting issue is that the same build of akaio (clean and freshly downloaded) works correctly on a different msd card. it seems the problem is msd card related in some way, which would confirm many of the older soft-reset issue reports.

what you should do is really debug the problem. try everything you can think of. test with every patch turned on/off, cheats on/off, different roms, different homebrew, different file structures, etc. if it always behaves the same then perhaps its a deeper issue. akaio.net would be the place to report such a problem, but make sure you have fully debugged. the staff there doesn't like it if you post something without taking the time to debug.

-another world
 

DeathEvil

Member
OP
Newcomer
Joined
Apr 19, 2012
Messages
20
Trophies
0
XP
14
Country
United States
In a way I'm glad to hear I'm not the only one:) yes soft reset always takes me back to the root as well, only sometimes it works, and sometimes sd card is empty. I tried couple of things like turning of the rumble (since it rumbles every time soft reset engages). I will try to get to the bottom of it by debugging, but chances are someone already encountered the issue and pinpointed where the problem lies - if so please speak up:)
 

maskmanyeah

New Member
Newbie
Joined
May 16, 2012
Messages
1
Trophies
0
XP
1
Country
Indonesia
i encountered this problem yesterday.. and SD formatter 3.1 do the trick !
simply format your microSD without messing up with the option or stuff..
but before you do that,don't forget to backup your Games. :yaysp:
 

LeoSan

Well-Known Member
Newcomer
Joined
Oct 5, 2010
Messages
49
Trophies
0
Website
Visit site
XP
79
Country
Uruguay
same issue here, when I soft reset I'm always sent back to root.
It used to work properly last year, but for some reason it stopped working at some point in time
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    K3N1 @ K3N1: https://youtu.be/pCtNJWsld9k