SavSender / NetCat Problems

Discussion in 'NDS - Flashcarts and Accessories' started by Matsuzo, Jan 13, 2008.

Jan 13, 2008

SavSender / NetCat Problems by Matsuzo at 12:10 AM (2,563 Views / 0 Likes) 3 replies

  1. Matsuzo
    OP

    Newcomer Matsuzo Newbie

    Joined:
    Jun 29, 2007
    Messages:
    2
    Country:
    United States
    Hello everyone. I'm new around here (found this place through Google), but I was wondering if any of you could help me with an issue I'm having.

    My data on Jump Ultimate Stars got corrupted (bad Action Replay code), so I decided to obtain a .sav file from the internet and use SavSender and NetCat to write it to the cart, following this guide, as well as general pointers from portforward.com. However, when I run NetCat and try to run SavSender on my DS, I get an error message. To see if it was just a problem with restoring saves, I started a new game in JUS and tried to dump the new save onto my computer. On the DS's end, SavSender hangs at the line, "Sending EEPROM contents.". On the computer's end, the .sav file itself gets created, but no data ever reaches it.

    Basically, I'm at a loss. I double- and triple-checked my syntax in the command line, I know my computer has a static IP, and I forwarded the port correctly to the best of my knowledge. Also, the .sav file I intend to use has been tested with a rom and verified to be good. I've also re-downloaded both programs to no avail. Can anybody suggest to me something I haven't tried yet to get this working? I'd really appreciate it.

    Information:

    OS: Windows XP Home Edition SP2
    Router: Belkin F5D7230-4
    Flashcart: R4, firmware version 1.15
    SavSender v. 1.1b
    NetCat v. 1.10

    Pics (linked so as not to stretch the page):

    Ports forwarded on router (the one for NetCat is labeled as such):
    http://i113.photobucket.com/albums/n230/Ma...blems/ports.png

    Error message from save restore attempt:
    http://i113.photobucket.com/albums/n230/Ma...ems/restore.jpg

    Attempted save dump:
    http://i113.photobucket.com/albums/n230/Ma...oblems/dump.jpg

    I know the last two are kind of blurry, but my camera doesn't do screencaps so well. [​IMG]
    Anyways, if any of you can help me out, I'd really appreciate it!
     
  2. kazumi213

    Member kazumi213 GBAtemp Regular

    Joined:
    Oct 16, 2006
    Messages:
    293
    Country:
    Spain
    First you must be sure that your DS can connect to your router. Are you able to play Wi-Fi with a commercial DS game?

    Second, all Wi-Fi problems I've ever had with homebrew were resolved by "unhiding" the router Wi-Fi access point. There should be some kind of checkbox to hide/unhide your router's access point for it to not/yes broadcast its presence. Also, if possible (just to be sure) try to set the "Type" setting on your port forwarding config for netcat to "TCP and UDP".

    Finally, even when the R4 can auto dldi-patch homebrew, it is known to fail for some homebrews. Not sure on SavSender, but you can always try to externaly patch it by yourself prior to copying it to your R4.
     
  3. DanTheManMS

    Member DanTheManMS aka Ricochet Otter

    Joined:
    Jun 2, 2007
    Messages:
    4,325
    Location:
    Georgia
    Country:
    United States
    Hm, as the creator of that guide you'd think I'd have some insight, but I'm clueless here. I had the same issue when he first released the program, but as you can see at http://forum.gbadev.org/viewtopic.php?t=13099 his update fixed the issue for me. You've got the version that does both reading and writing, so you're not using the first release or anything. I don't really know what's wrong. Maybe it's a firewall issue or something?

    You could try SavReceiver to see if that program can dump the save (there's a guide based on my own at the TeamCyclops forums), or use Eepinator to restore it to an official cart (restoring works on an R4 even though dumping doesn't). You could also try Rudolph's NDS Backup Tool wifi version with the instructions at http://www.monroeworld.com/ds/hacking/backup/

    Sorry I can't help more.
     
  4. Matsuzo
    OP

    Newcomer Matsuzo Newbie

    Joined:
    Jun 29, 2007
    Messages:
    2
    Country:
    United States
    I tried Eepinator, and it's saying that the .sav file is the wrong size (too small). Is there any way I can pad the save to make it fit, or can I just not use it?

    EDIT: Never mind, I got it to work. I just needed to use a raw .sav file (which means, actually, that the file I had was way too big). I feel like such an idiot... [​IMG] Thanks for the help, guys!
     

Share This Page