Official Retroarch WiiU (wip.)

Discussion in 'Wii U - Homebrew' started by aliaspider, Nov 6, 2016.

  1. cucholix

    cucholix Banners guy

    Member
    7
    Jan 17, 2017
    Chile
    @ploggy @rioray are you guys getting "CPU Jam" error with Vice sdl2?
    I got it when loading The Last Ninja (d64)
     
  2. rioray

    rioray GBAtemp Regular

    Member
    3
    Jul 24, 2017
    France
    No , all is fine here.

    [​IMG]
     
    lordelan likes this.
  3. cucholix

    cucholix Banners guy

    Member
    7
    Jan 17, 2017
    Chile
    Mine is TOSEC set, d64, 2 tapes
    vice sdl2

    My vicerc:
    Code:
    [C64]
    SoundDeviceName="retro"
    SoundBufferSize=100
    SDLBitdepth=32
    SDLWindowWidth=384
    SDLWindowHeight=272
    VirtualDevices=1
    VICIIVideoCache=1
    VICIIFilter=0
    SidEngine=0
    SidModel=1
    JoyDevice1=4
    JoyDevice2=4
    DriveTrueEmulation=0
    
    My roms folder:
    upload_2018-2-10_12-6-8.

    Launched it from playlist "Last Ninja, The (USA) (Side A).d64" and got that CPU JAM error :unsure:
     
    Last edited by cucholix, Feb 10, 2018
  4. cucholix

    cucholix Banners guy

    Member
    7
    Jan 17, 2017
    Chile
    @rioray it seems the game doesn't like when you disable True Drive Emulation :lol: anyway, it appears System 3 logo now then the title screen, however if I press the Y button the game freezes in the title screen, what button/key do you need to press to start the game? :unsure:

    Ok, seems like the game had some kind of piracy protection, tried another dump, it's working now
     
    Last edited by cucholix, Feb 10, 2018
    ShadowOne333 likes this.
  5. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    18
    Jan 17, 2013
    Mexico
    Someone has a suggestion or idea as to why certain boxarts show up and some don't? :P
     
  6. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    18
    Jan 17, 2013
    Mexico
    Figured out what the issue with some thumbnails not appearing was.

    So, turns out that the thumbnails must have the name you specify for the game from the Playlist file, and not the name given to the ROM file.

    For example:
    Code:
    sd:/ROMs/Quake/hipnotic/PAK0.PAK
    Quake: Scourge of Armagon
    sd:/retroarch/cores/tyrquake_libretro.rpx
    Quake
    DETECT
    Quake1.lpl
    
    With this example, the thumbnail at hand should be named whatever one sets as the game name in there under the second line (Quake: Scourge of Armagon), and NOT the ROM name (first line or PAK0.PAK).
    So, inside the Boxart folder under Quake, you should put the PNG image with the following name there:

    Quake_ Scourge of Armagon.png

    With that, the correct boxart and thumbnail will load up properly.

    Also, for those that don't know, thumbnail images do not support special characters, any special character should be replaced with a lower dash "_".
    The special characters that are not supported are:

    &*/:`<>?\|"


    So if you use any of those in the game name inside the Playlist, replace those with _ in the PNG name.

    That's it, hope it helps :lol:
     
    Last edited by ShadowOne333, Feb 11, 2018
    Gunstorm, Reid_Dead, lordelan and 6 others like this.
  7. Osakasan

    Osakasan GBAtemp Advanced Fan

    Member
    6
    Sep 19, 2015
    Just noticed something

    I dumped my gbc rom of VC Pokemon Crystal and its savegame and tried to load it with the Ganbatte core

    The rom loads correctly, but if i try to use the save file it hardlocks

    mGBA core gives me a ISI: Bad execute of unmaped memory 00000000 error

    Am i doing something wrong?
     
  8. FoxForceFive
    This message by FoxForceFive has been removed from public view by porkiewpyne, Feb 12, 2018, Reason: Wrong thread.
    Feb 11, 2018
  9. AmandaRose
    This message by AmandaRose has been removed from public view by porkiewpyne, Feb 12, 2018, Reason: Reply to trashed post.
    Feb 11, 2018
  10. MegaSuperab2

    MegaSuperab2 Homebrewer, Memer, Acts Like Bedroom Is Basement

    Member
    2
    May 8, 2016
    United States
    The Earth
    Why does it kick me out of the app when I launch it?
     
  11. cucholix

    cucholix Banners guy

    Member
    7
    Jan 17, 2017
    Chile
    @rioray I'm getting this error when loading Commodore Plus-4 games through vice_xplus3_libretro
    Do I need some bios? couldn't find github for it, sorry to bother you :P

    Edit: fixed it, with .tap games
     

    Attached Files:

    Last edited by cucholix, Feb 12, 2018
  12. FoxForceFive

    FoxForceFive Member

    Newcomer
    3
    Apr 5, 2009
    Apologies, had multiple tabs open & posted in the wrong thread!
     
  13. upsteady

    upsteady Member

    Newcomer
    1
    Feb 12, 2018
    Turkey
    Hello guys. I use wii u retroarch without a problem but now my fba core is not working. When I load a rom, it gave me an error screen. Some games are working but screen is reversed in working games. What can I do about that please help. Sorry for my bad English.
     
  14. cucholix

    cucholix Banners guy

    Member
    7
    Jan 17, 2017
    Chile
    Interesting, I always though that the name itself couldn't contain special characters, but it's only the thumbnail in which you replace by "_" :)
     
    Last edited by cucholix, Feb 12, 2018
    ShadowOne333 likes this.
  15. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    18
    Jan 17, 2013
    Mexico
    Yep that's correct :)
    I only use &, ! and + mostly for my ROMs, and from those only "&" gets replaced by "_" in the thumbnails.
    I managed to get ALL of my ROMs and hacks with custom boxarts ;)
    No ROM was unaccounted for :P
     
    cucholix likes this.
  16. AriaHiro

    AriaHiro Advanced Member

    Newcomer
    1
    May 12, 2016
    United States
    its been a while. how far has this project progressed so far if you dont mind me asking
     
    DarthDub likes this.
  17. Osakasan

    Osakasan GBAtemp Advanced Fan

    Member
    6
    Sep 19, 2015
    Well, that depends on when you left it.

    So far no PSX emulation yet. Overlays are working and Shaders presumably will be at the 1.7.1 stable build. There seems to be a Commodore 64 core now?

    Basically small improvements overall.
     
  18. AriaHiro

    AriaHiro Advanced Member

    Newcomer
    1
    May 12, 2016
    United States
    ill be sure to try it out after my shift
     
    DarthDub likes this.
  19. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    18
    Jan 17, 2013
    Mexico
    Several cores have been added too.
    Mostly old computer stuff when it comes to cores, like Commodore64 and others.
    PSX and N64 are still a no-go.
    XMB menu now has the animation for the background working instead of a static image, as well as being able to change the colour and all.
    Shaders and overlays are working, and network and Playlists with thumbnails works too.
     
  20. AmandaRose

    AmandaRose The Fallen Angel

    Member
    12
    Aug 19, 2015
    United Kingdom
    Glasgow
    Plus the clock and date now works for games that require it like some of the Pokemon titles ect.
     
  21. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    18
    Jan 17, 2013
    Mexico
    Oh yeah I forgot about that too.
    The RTC in RetroArch works properly now :P
     
    DarthDub, cucholix and AmandaRose like this.
  22. AriaHiro

    AriaHiro Advanced Member

    Newcomer
    1
    May 12, 2016
    United States
    does it support multiplayer yet?
     
Loading...