Official Retroarch WiiU (wip.)

Discussion in 'Wii U - Homebrew' started by aliaspider, Nov 6, 2016.

  1. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,773
    5,336
    Jan 17, 2013
    Mexico
    Oh yeah I forgot about that too.
    The RTC in RetroArch works properly now :P
     
    DarthDub, cucholix and Marko76 like this.
  2. AriaHiro

    AriaHiro Advanced Member

    Newcomer
    59
    28
    May 12, 2016
    United States
    does it support multiplayer yet?
     
  3. Marko76

    Marko76 GBAtemp Psycho!

    Member
    3,847
    2,156
    Aug 19, 2015
    United Kingdom
    Clydebank
    It's supported multiplayer for about the last year lol.
     
  4. Metro City

    Metro City Member

    Newcomer
    28
    2
    Oct 20, 2015
    Italy
    I followed the guide and I installed it from wup installer, but when I run retroarch it gives me this screen:
    [​IMG]
     
  5. coolguy8

    coolguy8 Member

    Newcomer
    10
    1
    Tuesday
    United States
    Is retroarch on the Wii U "up to par" so to speak if I were to plan on making it my primary means of emulating classic consoles? I tried a raspberry pi 3 once and it wasn't quite there, let's say up to and including N64/PS1. I'm okay using my PS3 for PS1 if necessary, but preferably everything else would be on the Wii U.
     
  6. Vorde

    Vorde GBAtemp Regular

    Member
    105
    45
    Jul 8, 2015
    Canada
    Both Wii and Wii U had N64 virtual console that can handle most titles :)
     
  7. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    23,862
    11,598
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    N64 on Wii U emulates more accurate than the Wii did, especially the RSP (graphics processor), better framebuffer and alpha dithering effects.
     
    cucholix and Vorde like this.
  8. Billy Acuña

    Billy Acuña GBAtemp Addict

    Member
    2,436
    1,548
    Oct 10, 2015
    Mexico
    Not to mention that wii side emulators like Wii64 (mupen64gc-fix, glide and rice) and WiiSXR are pretty good with WiiU clockspeeds :)
     
    wakabayashy likes this.
  9. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    23,862
    11,598
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    They are, unfortunately the graphics plugins on them are broken, culling issues, jumping vertices, etc. I really hope they can improve those plugins. Audio is another issue where the Wii U fails, it uses linear audio, N64 used Gaussian:lol:.
     
    wakabayashy likes this.
  10. Polygon-Man

    Polygon-Man Newbie

    Newcomer
    8
    3
    May 10, 2015
    Try an older build, for example 2018-02-11_RetroArch_rpx.7z.

    I tried to latest, 2018-02-15_RetroArch_rpx.7z, and I got the same error
     
    lordelan likes this.
  11. Milenko

    Milenko Advanced Member

    Newcomer
    69
    16
    Oct 16, 2017
    Australia
    I had to reinstall after messing around with cores and the latest gives me that too

    — Posts automatically merged - Please don't double post! —

    Re installed the Retroarch channel and replaced the folder in sd/ with the build from the 12th and still get an error
     
    Last edited by Milenko, Feb 16, 2018 at 1:49 AM
  12. masterflops

    masterflops Newbie

    Newcomer
    8
    5
    Oct 17, 2015
    United States
    So the latest nightlies are broken for me on WiiU also. I get the same error message.

    The last nightly that I found to work was 2018-Feb-10 but unfortunately I erased my copy.

    The latest stable 1.7.0 works the first time, but then after saving a configuration file, when it loads up, I get memory error 160-2203. If I delete the configuration file, it will load again but then it will error if there is a config file.

    It looks like there were a bunch of cleanups submitted on Feb-11,12,etc that probably broke something for the WiiU but I'm not sure how to debug other than looking at the stacktrace above and walking through the code.
     
  13. Metro City

    Metro City Member

    Newcomer
    28
    2
    Oct 20, 2015
    Italy
    I tried version 1.6.7, Downloaded the program and installed, this works great but does not find to me lot of roms
     
  14. Gunstorm

    Gunstorm Member

    Newcomer
    14
    7
    Jan 24, 2017
    Brazil
    how can i setup custom thumbnails images to work on xmb? (with folder? how name the .png files?)
     
  15. infidelity

    infidelity GBAtemp Regular

    Member
    190
    48
    Dec 13, 2013
    United States
    crap, I deleted the 2-10-18 nightly build before I read all this broken build stuff. Is there anyone with the 2-10-18 build of just retroarch itself??? I have a game party tomorrow and now RetroArch wont work for me.
     
  16. infidelity

    infidelity GBAtemp Regular

    Member
    190
    48
    Dec 13, 2013
    United States
    Anybody? Anyone have just retroarch from 2-10-18 or earlier? I need it asap.
     
  17. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,773
    5,336
    Jan 17, 2013
    Mexico
    None of the currently available packages work?
    There are some from Feb 12th up to today.
    Try them out, hopefully one of those works.

    I would post mine when I get home but I only have like 8 cores, from the consoles/games I have only.
    So I won't have most of the ones you have been mentioning lately, sadly :( (Like Commodore, Amiga, etc).
     
  18. infidelity

    infidelity GBAtemp Regular

    Member
    190
    48
    Dec 13, 2013
    United States
    I thought it was just "RetroArch" itself that was the issue? Cause I tried booting the 16th build & the 12th build from the WiiU menu, and it instantly crashed. All I need is the retroarch.rpx found in "wiiu/apps/retroarch"
     
  19. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,773
    5,336
    Jan 17, 2013
    Mexico
    I don't use the main RetroArch RPX from quite a while now, but perhaps @cucholix @ploggy @the_randomizer or someone else might be able to help you here.
    A main retroarch.rpx file from the Feb 10th nightlies is required, dudes, hopefully you have it since I don't use the main retroarch app for a while now.
     
  20. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    23,862
    11,598
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Oh..I haven't used any version since 1.7.0 vanilla, sorry.