Questions about R4 Dual Core and Pokémon XY

Discussion in 'R4 DS' started by Byacco~, Oct 15, 2013.

  1. Byacco~
    OP

    Byacco~ Newbie

    Newcomer
    2
    0
    Mar 17, 2012
    Mexico
    Hi y'all, good day~

    I've some questions about the R4 Dual Core flashcard and PokémonXY games.


    I always played Pokémon in DeSmuME and now I bought a 3ds XL and the Pokémon Y game.

    Obviously I also want to play DS games in the 3DS and only found a R4 DC flash card, this is:

    Warning: Spoilers inside!

    I know few things about the flashcards but I understand the basics...

    I have read that Pokémon XY needs a firmware update to work, right? but I don't know if R4 DC supports it. I found it in their website:

    [​IMG]

    My questions are:

    1) What version of firmware is required to play PokémonXY?

    2) Is the current version (from internet) of R4 DC needed to play Pokémon Y?

    3) And what about with the current version of the 3DS firmware (6.3.0-12U)? Will it work with my R4 DC?

    Btw, my 3ds is not connected to internet yet. Similarly, I have not inserted the Pokémon Y card too...

    Please, can anyone help with this?


    Thanks for reading :)
     
  2. Arras

    Arras GBAtemp Guru

    Member
    5,858
    2,673
    Sep 14, 2010
    Netherlands
    Pokemon needs 6.1.0. You can update to that if your R4 is updated to the latest firmware FIRST, as according to the site it works on 6.2.0. Make sure you have the internet on your 3DS disabled when installing the XY update.
     
  3. Byacco~
    OP

    Byacco~ Newbie

    Newcomer
    2
    0
    Mar 17, 2012
    Mexico

    6.1.0? Ok~

    Update the R4 first? Sure, thanks :3

    Ehmm, I don't really understand the last part of your comment. Why should I keep internet disabled while I play Pokémon Y? o.ó

    One last question: the R4 is upgradeable if it releases a new 3DSXL firmware update?


    Thank you very much for the help :_D
     
  4. Arras

    Arras GBAtemp Guru

    Member
    5,858
    2,673
    Sep 14, 2010
    Netherlands
    No, you don't need to keep the internet disabled while playing Y, you need to keep the internet disabled while installing the update from Y as otherwise it might install the latest version anyway. The site only states your card works on 6.2.0 while the latest is 6.3.0. So after the Y update, don't install any more updates.