M92T36 or BQ24193

Discussion in 'Switch - Console, Accessories & Hardware' started by nerirififi, Jan 4, 2019.

  1. ollicnat

    ollicnat Member

    Newcomer
    2
    Mar 11, 2015
    Costa Rica
    Hi how does look the charger port on switch? Did you use other charger to search if yours is ok?
     
    sniperventura likes this.
  2. sniperventura

    sniperventura Member

    Newcomer
    1
    Nov 15, 2015
    Mexico
    already try to recharge it with the dock, only usb, with the charger of my cell phone, but nothing, do not load with any, leave it for many hours with all. I'm worried about opening my other switch, because it has a guarantee and I would lose it.
     
  3. ollicnat

    ollicnat Member

    Newcomer
    2
    Mar 11, 2015
    Costa Rica
    In that way is better to use your garantee.
     
    zxr750j likes this.
  4. consolex

    consolex GBAtemp Regular

    Member
    3
    Feb 22, 2016
    France
    It's ok for you ?
    I have a charging problem.
    The VBUS is not doing its job.
    I think it comes from a rocker on S2_DRV-G1 / S2_DRV-G2 or S1_DRV-G1 / S1_DRV-G2 or S2_DRV_SRC / S2_DRV_SRC

    The charging only works in 1 direction

    @mattytrog :)
    [​IMG]

    http://prntscr.com/n8lofo
     
    Last edited by consolex, Apr 7, 2019
  5. vastrolorde

    vastrolorde Advanced Member

    Newcomer
    5
    Mar 22, 2015
    United States
    any idea what component on the motherboard is on fault?
     
  6. Canna

    Canna Bad Ass Poisonous Mushroom

    Member
    7
    GBAtemp Patron
    Canna is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jul 14, 2018
    United Kingdom
    there talking about the IC CHIP M9T236
     
  7. Blao

    Blao Newbie

    Newcomer
    1
    May 30, 2019
    France
    Hello i get 2101-0001 error when i try to put m92t17 instead of m92t36, these just look phisycally same, i lost 3h
     
  8. slicer2k

    slicer2k Member

    Newcomer
    2
    Aug 9, 2017
    Brazil
    Guys i know it's impossible to identify the problem like this, but maybe someone can give me a tip?

    I have connect my NSW to a fucked up usb pc port and now my switch isn't working, battery seems to be charging because it gets warm using the ac adaptor. Normally, which IC/fuse/whatever is the most common to get burned? because i'm going to order them all from china and they are like 3 dolars, i prefer to buy it all at once.

    at the topic i've seen you guys mentioning BQ24193 P13USB and M92T36 anything else??

    thanks.
     
    Last edited by slicer2k, Jun 27, 2019
  9. solac

    solac Member

    Newcomer
    1
    Jun 21, 2009
    hi,

    i am currently having problems with a nintendo switch. it came with a broken charge port. after replacing the charge port. the unit does not boot up (turn on). i have tried to check for pin 5 of m92t36 with charger plugged in it read 4.5volt, pin 6 i don't get any voltage also seems to be shorted to GND, capacitor near pin 6 seem to be shorted. also checked battery voltage with charger unplugged battery voltage around 3v and with charger plugged in around 3.5v. i did notice that the bq24193 seems to be heating up is this normal ? pin 1 of bq24193 with charger plug in is around 14.97v also gets warm with in less than a minute of just pluging the charger. i hope someone can help me fix this switch.
     
    Last edited by solac, Sep 16, 2019
  10. Pintglass

    Pintglass GBAtemp Regular

    Member
    3
    Jan 28, 2019
    United Kingdom
    bq24193 does get hot when its charging, check what voltage you get on pin 6 of M92T36 and check that pin for a short to ground. Or check the cap thats connected to that pin.
     
  11. solac

    solac Member

    Newcomer
    1
    Jun 21, 2009
    i just checked the capacitor near pin 6 its shorted to ground on both sides, pin 6 is shorted to ground, what could be causing this ?
     
  12. Pintglass

    Pintglass GBAtemp Regular

    Member
    3
    Jan 28, 2019
    United Kingdom
    Most probably PI3usb on the other side of the board will be faulty.
     
  13. solac

    solac Member

    Newcomer
    1
    Jun 21, 2009
    is there anyway to test this ? or just need to go ahead and replace that. also is pin 6 of m92t36 3volt rail?
     
  14. Pintglass

    Pintglass GBAtemp Regular

    Member
    3
    Jan 28, 2019
    United Kingdom
    Yes pin 6 is on the 3v3 rail.
    Test the filters under the pI3usb for continuity, the large cap above pi3usb is on the same rail this will show short aswell,
    Try turning it on and feel if somethings getting hot.
     
  15. solac

    solac Member

    Newcomer
    1
    Jun 21, 2009
    the large cap near pI3usb is shorted to ground seems like this mostlikely is the culprit. il try to replace and see if it solves the issue
     
    Last edited by solac, Sep 16, 2019
  16. solac

    solac Member

    Newcomer
    1
    Jun 21, 2009
    — Posts automatically merged - Please don't double post! —

    you are right this is the faulty part, after removing this part i tested for short and it was gone. So i replaced with a new one and unit booted right up.

    thank you very much
     
    zxr750j likes this.
  17. Pintglass

    Pintglass GBAtemp Regular

    Member
    3
    Jan 28, 2019
    United Kingdom
    No problem, I’d check all the common mode chokes for continuity before you reassemble or you may have a problem in dock mode.
     
  18. solac

    solac Member

    Newcomer
    1
    Jun 21, 2009
    I haven't tested the dock mode. what are "common mode chokes" can you please send photos.

    Was just really happy to see the unit finally turn on. after struggling to replace the charge port twice thinking it wasn't soldered properly. then figured maybe something else was wrong. till i found this thread.

    thanks
     
  19. Pintglass

    Pintglass GBAtemp Regular

    Member
    3
    Jan 28, 2019
    United Kingdom
    These are the common mode chokes test for continuity on both channels of each one

    . Switch_side2chokes.
     
  20. solac

    solac Member

    Newcomer
    1
    Jun 21, 2009
    hmmm how do i test that ? do i need to test all those points ? continuity against ground ?
     
    Last edited by solac, Sep 17, 2019
Quick Reply
Draft saved Draft deleted
Loading...