Laggy play on PS1 mod chip

Discussion in 'Sony PlayStation 1 & 2' started by blaisedinsd, May 16, 2017.

  1. blaisedinsd
    OP

    blaisedinsd GBAtemp Maniac

    Member
    1,023
    118
    Dec 6, 2012
    United States
    I soldered a mod chip in my PS1 a couple years back and have mostly played Ape Escape on it and it plays fine.

    Last night I tried burning Final Fantasy 7 disc 3 to use my old 20 year level 99 save. My actual game got stolen from me in a car theft back then so I downloaded this from a Rom site.

    I used the program Burn on a mac to burn the .bin and .cue file

    Initial burn didn't play at all. Tried again on the slowest burn speed and the game booted but plays like ass with tons of stuttering and temporary freezing.

    I recall my original Playstation eventually having issues back in the day playing FF7 but I thought that was just stuttering during FMV sequences. (this mod chip one is a newer model) Is FF7 just harder to read from disc than Ape Escape? I thought all burned games would play perfectly when I installed the mod chip....