Homebrew Just got CFW Atmosphere, I can only play some of my OFW games others are not listed. What do I do?

Valkri599

Active Member
OP
Newcomer
Joined
Aug 30, 2021
Messages
32
Trophies
0
Age
34
XP
156
Country
Japan
I just tried doing the whole CFW thing on my switch and its working more or less but I'm really confused about one point.

Most of my games are digital titles downloaded and purchased from the eshop and I'd like to continue to play these/buy others in the future. But after following the guides, and setting up a partition with emunand for CFW boots and a separate stock boot I'm wondering why only a handful of games are available to play. Others say "needs update" or "needs to be downloaded"

So why is this exactly?

I figured since the emunand is a copy its catching the access so to speak from the titles that were last installed before the emunand's creation? But this seems weird since I downloaded on OFW, completed and worked fine. When I go to CFW to play with cheats, the games are not accessible.

THEN I saw that the emunand is looking in its own folder for the route to the games. I changed this to the base Nintendo folder and its still not finding all the games. It found a few of them but its not finding others. This is what the file commands look like:

[emummc]
enabled=1
sector=0xb438000
path=emuMMC/RAW1
id=0x0000
nintendo_path=Nintendo


I know its a partition drive now so the games are going to a different place (the Nintendo folder I assume) but its still not finding them even changing the file as above. Is Am I off base and doing something completely wrong?

Sorry for the long post. I've been at this literally all day and can't find a solid answer to this so I want to be as detailed as possible. I literally just want CFW to apply cheats to stuff like Octopath and other RPGs, not for other mods/other things at the moment so its really frustrating since most guides just have cheats as a side feature.
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
18,139
Trophies
1
Age
28
Location
New York City
XP
12,073
Country
United States
Are you sure that all of your digital titles installed were installed to your SD card? Some of them might have been installed to internal memory which would explain why even after altering the path of the Nintendo folder, emuMMC is still not reading all of the games.
 

Valkri599

Active Member
OP
Newcomer
Joined
Aug 30, 2021
Messages
32
Trophies
0
Age
34
XP
156
Country
Japan
Yup, I tried deleting some and redownloading fresh making sure they are not going to internal and still cannot get them to display in the emuMMC for some reason. After messing with lots of things last night I can get them to display/launch in CFW sys mode, but not emu still. I'm not sure why exactly since most guides don't go into specifics. Wondering if its a pathing issue, or something wrong was done on my end.

I tried updating the various CFW apps via online connections and it seemed to fix things? Everything seems launchable in emuMMC now which -shrug- I still don't understand exactly what happened. Perhaps something wasn't in the right place or what not since I assumed I got the latest versions from github.
 

Kallim

Well-Known Member
Member
Joined
Jan 12, 2021
Messages
190
Trophies
0
Age
46
XP
381
Country
United Kingdom
The Emunand stores the games in a different place. So even though the ticket is installed the game won't run.

On the sysnand they are in the nintendo folder but you need to copy them to the emummc/Raw1 folder (might be raw2 or 3 etc if you have more than one emunand on the SD card). Do you have more than one???

Have you tried to migrate and seperate the emunand??
 

Valkri599

Active Member
OP
Newcomer
Joined
Aug 30, 2021
Messages
32
Trophies
0
Age
34
XP
156
Country
Japan
I tried changing the emummc direction from the Raw1 folder to the Nintendo one, and it did not work at first seemingly. Like I responded the other day, it works now and I'm not exactly sure why. I think updating with the actual switch apps corrected some of the path mistakes that I might have made when moving files manually. Seems like nothing changed when I look at file placement and configs, but something had to have been changed for it to be smooth sailing now.

Also I could use the default atmosphere "Launch" icon after updating, something I could only launch into with the "others/extras" icon before.

But yeah, I get the general concept of there being two places where the games go/are accessed from. We'll see if things stay in order when I get back into more switch games since I'm just playing the stuff I've always had before modding at the moment.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: 10 year old hardware now still emulates switch pretty decently