I updated the latest r4 firmware,still doesn't work on my dsi

Discussion in 'NDS - Flashcarts and Accessories' started by raid168, Mar 21, 2012.

  1. raid168
    OP

    raid168 Advanced Member

    Newcomer
    89
    0
    Sep 24, 2007
    Canada
    my dsi was upgraded to version is 1.4.3 U by accident

    my R4i card doesn't work any more,showing "Error" message.

    I downloaded the lastest r4i fireware v1.54b from r4i-sdhc,


    still same error, not able to make it work,

    please help!!!


    [​IMG]


    [​IMG]
     
  2. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,103
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    You need to actually run the update, which means you need to run the flash cart...

    So that means you need to do the update on another DS system. You cannot update it from your DSi.
     
  3. Tom Bombadildo

    Tom Bombadildo Honk!

    pip Contributor
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    10,144
    10,003
    Jul 11, 2009
    United States
    I forgot
    You have to run the firmware patch on an older DS/Lite/DSi still working with the card.
     
  4. raid168
    OP

    raid168 Advanced Member

    Newcomer
    89
    0
    Sep 24, 2007
    Canada
    the following is what I did
    1. I formatted the sd card
    2. copy the latest firmware files to the root of sd card.
    3. run in dsi, error
     
  5. Tom Bombadildo

    Tom Bombadildo Honk!

    pip Contributor
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    10,144
    10,003
    Jul 11, 2009
    United States
    I forgot
    No no, you have to run the file on the DS to update the card, you can't just put it on the card and have it work. Find another DS.
     
  6. raid168
    OP

    raid168 Advanced Member

    Newcomer
    89
    0
    Sep 24, 2007
    Canada
    I don't have other older ds or dsi.

    should I buy another card instead of this r4?

    DStwo works with dsi 1.4.3.u?
     
  7. Tom Bombadildo

    Tom Bombadildo Honk!

    pip Contributor
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    10,144
    10,003
    Jul 11, 2009
    United States
    I forgot
    Borrow one.

    R4's are...ok cards. DSTwos are the best in terms of features, as it has SNES and GBA emulators for it. It will work with 1.4.3. However, if you just want a flashcard for playing DS games I would suggest the Acekard 2i as it's cheaper, very reliable and gets updated just as frequently as the DSTwo does. It's about $15 cheaper than the DSTwo as well, depending on where you buy it. No GBA/SNES emulation though.
     
  8. raid168
    OP

    raid168 Advanced Member

    Newcomer
    89
    0
    Sep 24, 2007
    Canada
    sigh, guess I need to buy a new card, thanks
     
  9. Qtis

    Qtis Grey Knight Inquisitor

    Member
    3,791
    1,292
    Feb 28, 2010
    The Forge
    You could also try a Gamestop or similar used console shop. Pop the R4 in and run the update..
     
  10. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,931
    Sep 8, 2009
    One's inner self
    heres how you go about updating the card

    [​IMG]