DSTWO update for Firmware 1.4.1/ 1.4.2 released

Discussion in 'Supercard' started by tk_saturn, Sep 9, 2010.

  1. murkurie

    murkurie GBAtemp Fan

    Member
    1
    Feb 16, 2010
    United States
    California, Redlands
    cool, it worked, thanks
     
  2. Schizoanalysis

    Schizoanalysis From somewhere inside the rabbit hole...

    Member
    5
    Jun 23, 2009
    ...
    I have a question.

    Does this file make changes to the cartridge? (patch it)

    Or it is only a firmware change?
     
  3. Mbmax

    Mbmax Homebrew addicted

    Member
    3
    Nov 7, 2006
    Good to see they fixed their mistake quickly. [​IMG]

    Now to wait for acekard team fix.
     
  4. Ebichan

    Ebichan Newbie

    Newcomer
    1
    Sep 12, 2009
    Cote d'Ivoire
    Thanks supercard team!!


    P.D do you see,Juan Carlos?? it works!!!! hahahhahahhahaha [​IMG]
    kisses
     
  5. ismaelWii

    ismaelWii GBAtemp Regular

    Member
    1
    Aug 25, 2009
    Spain
    It's wonderful! I just put the file on the microSD, then the DSTWO on the DSi and it worked instantly!

    PD: It is impossible to run DSTWO on 1.4.1 without the microSD xD
     
  6. Langin

    Langin HI! ^O^

    Member
    9
    Jul 29, 2008
    Netherlands
    The Hague
    Hmp, this time they have won....


    BUT: Nice and fast!
     
  7. MeritsAlone

    MeritsAlone GBAtemp Fan

    Member
    1
    Sep 4, 2010
    Spaaaaace!
    this just proves that the Acekard team need to get back up because im gonna get a supercard if Acekard dont start making some progress, and its kinda sad, AceKard is a awesome name =(
     
  8. Greatforce

    Greatforce GBAtemp Regular

    Member
    2
    May 22, 2010
    Netherlands
    didnt expected to be this fast
     
  9. LUGiA

    LUGiA GBAtemp Fan

    Member
    2
    May 14, 2008
    what's this about 1.4.2 DSi just got 1.4.1 didn't it.
     
  10. Minox

    Minox Thanks for the fish

    Former Staff
    14
    Aug 27, 2007
    Japan
    1.4.2 is for Chinese DSis while 1.4.1 is for the other regions if I understand things correctly. Why the different version numbers? - I have no idea.
     
  11. jurassicplayer

    jurassicplayer Completionist Themer

    Member
    7
    GBAtemp Patron
    jurassicplayer is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 7, 2009
    United States
    Pantsuland
    Actually, if I remember correctly, weren't the version numbers slightly different some time ago? I feel like there was this one point in time that a similar thing happened...or maybe that was for the wii...(or maybe I'm just going nuts now xD)...
     
  12. 9th_Sage

    9th_Sage GBAtemp Maniac

    Member
    1
    Apr 30, 2008
    United States
    Ah, I see....this isn't an actual update to the card's built-in firmware. Kind of interesting, I'd like to know more about what the dat file actually IS then. From the forum:
    Those worried about a possibility of bricking shouldn't be, anyway, since it's not writing anything to the flashcart. Just thought I'd mention that on the thread since I know a few people were worried because the last time an honest actual firmware upgrade was released, some people had issues with it.
     
  13. Greatforce

    Greatforce GBAtemp Regular

    Member
    2
    May 22, 2010
    Netherlands

    1.4.1 Blocked the most common Flashcards. Later the day, Version 1.4.2 was released in japany. blocked the rest of the flashcards
     
  14. Fishaman P

    Fishaman P Speedrunner

    Member
    7
    Jan 2, 2010
    United States
    Wisconsin
    DSi can use WPA for native apps. This includes updating, the shop, and the web browser.
     
  15. dilav

    dilav GBAtemp Maniac

    Member
    3
    Nov 22, 2006
    United States
    How did it work? How was it fixed? What did N do to block it?
     
  16. achelos

    achelos Member

    Newcomer
    2
    Apr 12, 2007
    Netherlands
    Confirmed working for NDSi XL 1.4.1E =] (EOS 1.06)
     
  17. 9th_Sage

    9th_Sage GBAtemp Maniac

    Member
    1
    Apr 30, 2008
    United States
    It's just a file on the SD card you have to replace, that's the entire fix. What was changed, I have no idea really.
     
  18. Rydian

    Rydian Resident Furvert™

    Member
    18
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    So that the companies investing in Nintendo and making games for them don't sit back and think "Nintendo doesn't care about piracy, so I'll take my games to another company!"
     
  19. Mbmax

    Mbmax Homebrew addicted

    Member
    3
    Nov 7, 2006
    There isn't 2 updates in one day but one update for all countries.
    China iQue DSi was already in 1.4.1C months ago. It's logically the 1.4.2C that they get.

    Now why the iQue DSi is in advance, i have no clue.
     
  20. 9th_Sage

    9th_Sage GBAtemp Maniac

    Member
    1
    Apr 30, 2008
    United States
    That's part of it. Also...of COURSE they want to try to stop piracy. Once someone is in the system though it gets much harder to keep them out, so it's pretty much an uphill battle for them.
     
Loading...