Discussion in 'Supercard' started by cutterjohn, Dec 17, 2007.

Dec 17, 2007

DSLinux & SCDS1 SDHC by cutterjohn at 2:06 AM (727 Views / 0 Likes) 0 replies

  1. cutterjohn

    Member cutterjohn GBAtemp Advanced Fan

    Nov 27, 2007
    United States
    Hello people,

    I've got problems with DSLinux & SCDS1 SDHC OS3.0, EZ-Flash V 3in1. No changes in the "OS" setip defaults in any of the .ini files. 2G Kingston Japan uSD, speed setting 25. [EDIT] uSD is formatted FAT32 default settings, IIRC 2k clusters, all of the below worked fine for my Evolution excepting the WiFi flakiness of DSOrganize 3.1 or 3.1129. Same happened with the GnM supplied 128MB uSD with it's defau;lt format(never checked), also unsurprisingly neither Arcomage nor DSLinux managed to start with the GnM[/EDIT]

    I tried these situations:
    1. OS3 & SCDS1 SDHC w/SC DLDI driver(broken)
    2. Running DSlinuxm.nds would start to CLI fine.
    3. Running wnc would sometime start up WiFi using any method
    4. Trying to run either retawq or links would appear to hang (let it run for several minutes)

    1. same hw/OS
    2. Cluny's 12/7/07 DLDI driver replacing dldi.bin in scshell directory
    3. same result
    4. same result

    1. same hw/OS
    2. manually patching dslinuxm.nds with Cluny's driver, disabling patching on the app in the "OS"
    3. same result
    4. same result

    So, does anyone know if Cluny's fix is maybe not 100%, as it appears(haven't seen many posts) that scummvm and lmp-ng now work, but it doesn't seem to be helping dslinux...

    All the ROMs that I've tried worked fine and even picked up the Evolution save files w/o problems. Rudolph's 3in1 seems to be working normally and it's not patched at all(i.e. default no driver and auto-patching). DS Browser works IF I run Rudolph's app and let it setup the 3in1 RAM as a expansion pack, rumble works(quieter than I expected although on lowest setting).

    Arcomage.nds hangs with the loading, please wait dialog. (non-DLDI)

    DSOrganize worked with either DLDI driver.

    ...and well, that's all I had time to try...

    Any suggestions? I'm really missing the better dslinux browsers ATM, as the second best(DSOrganize) seems to fglake out on WiFi after a few page loads on ANY of my flash carts...

    I did something slightly stupid and enticed my Evo to work for a minute or so, and the new version of DSLinux loaded fine, setup WiFi, loaded links and then visited /., and it worked peachily. I'm kind of beginning to think that SC need to ditch moonshell as their primary shell, and write their own, after all even Datel managed to write their own shell which worked just about as well as SCs' current setup... [EDIT2] minus being able to run ROMs and even more incompatible with homebrew...[/EDIT2]

Share This Page