Card problems on a specific 3DS XL

Discussion in 'R4 DS' started by Blizzy, Mar 15, 2017.

  1. Blizzy
    OP

    Blizzy Newbie

    Newcomer
    1
    0
    Mar 15, 2017
    Poland
    EDIT: God, I can't rename the topic, could someone change it from 3DS XL to DSi XL? Sorry :(


    Hi all,

    I am having a peculiar problem. The hinges on my old DS broke and I had to buy a new console, so I bought a second hand DSi XL (1.4.5E). I also bought an R4i SDHC like the one pictured below, because my old Acekard 2i didn't work and I didn't want to bother with trying to make it work:

    [​IMG]
    Unfortunately upon entering the card in my DSi XL I got the "An Error Occurred..." system message. A bit puzzled, I went back to my old DS and inserted the card to check what is written on the Update screen. The card worked fine, I could see that the firmware is fresh, and it reads that 1.4.5 is supported. Strange, as it should work on my DSi XL with no problems.

    I then asked my friend for his DSi XL, also a 1.4.5E, which he uses with a card like this:
    [​IMG]

    I inserted his card into my console, but I got the same error message. That's strange, I have seen his card working with 1.4.5E. I then took the R4 that I bought, and it works fine on his console, so that can't be a problem with the card I bought. I tested my console with an original game card and I can play the game just fine, so the card slot is OK.

    What can be the causes? I can see the icon of the card when I insert it into the slot, so it can't be some connectivity issue that I can solve with a piece of paper, right? I checked two different cards in my console that I've seen work on another system with the same firmware. What gives? Am I looking at buying yet another console? How can this be possible?
     
    Last edited by Blizzy, Mar 15, 2017
  2. Millaaash

    Millaaash Newbie

    Newcomer
    3
    1
    Aug 1, 2017
    Finland
    I was reading about this card so maybe this? do original ds games work?