Black screen with DS and GBA mode in emuNand 9.5 for N3DS + rxtools 3 latest nightly build

Discussion in '3DS - Flashcards & Custom Firmwares' started by loolee, Jan 11, 2016.

  1. loolee
    OP

    loolee Member

    Newcomer
    20
    2
    Jan 11, 2016
    Antigua and Barbuda
    Hi all,

    I successfully downgraded my N3DS to 9.2 using this tutorial and then configured CFW, emuNand, RxTools and CTRBootManager using this tutorial.
    To make it quick, i use menuhax to boot CTRBootManager which then automatically load emuNand via rxtools 3 (if i do not touch any buttons), and my NANDs are unlinked.
    Ah yes, i forgot that i also had to inject FBI in emuNand in health and safety app as i messed something up while configuring emuNand at first time.
    I then updated emuNand to 9.5 with sysUpdater and proper cia files.

    So i have now sysNand 9.2/emuNand9.5 and auto boot on emuNand.

    I can install/play games properly (both retail and CIAs), play online, access e-shop, everything is working properly except for 2 problems which i am unable to solve and find clear information about.

    GBA virtual console and DS mode are both going to black screen when i try to use them in emuNand.
    - When i put a retail DS cartridge and try to play it in emuNand, i get black screen and have to reboot my console.
    - When i try to load an installed GBA game (installed using cia) in emuNand, i get black screen and have to reboot my console.
    - When i boot vanilla or CFW sysNand, DS cartridge load properly
    - When i boot vanilla sysNand, GBA game ask me to redownload it from eshop
    - When i boot CFW sysNand, GBA game load properly.


    Here is what i already tried to solve this:
    - Install different GBA games in both NANDs
    - Deleted AGB original file from both NANDs using FBI. Then install AGB patch, i patched myself following this tutorial both in emuNand and sysNand
    - Alternate CFW, but i was unsuccessful to make them load (Cake/Reinand/Old version of Rxtools)

    I am unable to find a way to solve this, all i can find is related to RxTools 2.6 which is not compatible with N3DS and all related discussion i find does not solve this.

    I would need at least a fix for the DS mode, as for GBA i still have gPsP, but i want to exclusively use my emuNand (no mess with sysNand and all my data in emuNand NNID, easier for backup), so booting in sysNand only for DS games is just missing the point :)

    So did i miss something or is this not possible on N3DS for now?
     
  2. loolee
    OP

    loolee Member

    Newcomer
    20
    2
    Jan 11, 2016
    Antigua and Barbuda
    I solved this by using 10.3 emuNand and latest reiNand.

    - Ds retail cartridge run
    - GBA VC cias are running, but have to be installed on both sys and emu Nand.

    Only (little) downside is console reboot when i close any of those games.
     
  3. xKaii

    xKaii GBAtemp Regular

    Member
    160
    22
    Jan 9, 2016
    That was useful to me. Thanks for posting it. :)