Attemping to Compile and run Sneek for vwii

Discussion in 'Wii U - Hacking & Backup Loaders' started by unaxtzero, Oct 8, 2014.

  1. unaxtzero
    OP

    unaxtzero Newbie

    Newcomer
    9
    3
    Oct 8, 2014
    United States
    I am a long time lurker and I often simply search out information in hopes others have experienced similar situations and follow the help that has been given to them.

    However in this case, I haven't found any information. And with the 5.2.0 patch that was just released, the situation might be a bit harder to figure out.

    I have a great deal of experience with the process of modding the wii and now the vwii and have no problem with following guides, but because the Wii U is simply not that popular... It really is hard to find information. I wish the Wii U were more popular, maybe once the cafe side mod is released then more people will flock to the system. Who knows...

    Anyway, here is my problem.

    I have modified my vwii, homebrew channel along with the homebrew forwarder to make 4:3 to 16:9.

    Before the latest 5.2 patch, I followed the standard guide on modding the vwii:
    http://gbatemp.net/threads/simple-guide-to-install-cios-on-vwii-backup-nand-and-keys.339890/

    I chose to use: d2x-v10 beta52

    One thing I must note is that I did in fact perform the IOS80 patch as outlined in this thread:
    http://gbatemp.net/threads/patched-ios80-installer-for-vwii-allows-sd-menu-custom-channels.344882/

    I have actually been extensively working on the WiiFlow Master Pack along with the coverart working and finally got done with setting it all up.

    After completing all that I decided to try to get some wiiware and VC games and that is currently where I have issues.

    I realized that if I wanted to work with wiiware and VC games, the EmuNand route was the best way to go about this. However I installed IOS80 patch already...

    I am able to run WiiFlow with a EmuNand(capturing the nand into a emunand folder on the SD card).

    The problem comes from the fact that within WiiFlow and running WiiWare and VC games with the Emunand, they will only load from the SD Card and not the USB.

    I am not sure why they load fine from the SD Card in WiiFlow from the EmuNand, and not when i place the Emunand folder on the usb and set the paths accordingly.

    This would be fine but they load extremely slow and I assume this is because of the way that I am loading them.

    Ultimately I decided maybe I should try the SNEEK route and maybe I can finally utilize the USB drive with WiiWare and VC, and maybe they will load faster since I am interfacing through SNEEK.

    I followed this guide here:
    http://www.hacksden.com/showthread.php/8119-Compiling-a-vWii-compatible-version-of-SNEEK

    Again I want to point out my stupid decision to install the IOS80 patch, at least not without multiple methods to back up the original. I do believe I have my original nand.bin before modding but that would be the nand.bin from before 5.2...

    This might be why I am currently having the issue with running SNEEK after completing the instructions.


    Ok Here is the problem I am facing:

    I have compiled SNEEK according to the instructions and am getting:
    "Waiting for arm to reset ppc"

    I even went so far as to compile nswitch myself as providing by others who were experiencing issues with that problem.

    However still, I get that message.

    I have to assume that the problem might be a combination of the fact that I am using a patched IOS80 and the fact that I am on system 5.2 which is the latest WII U system update.

    I am not sure.
    When I compile SNEEK, I get kernel_sd.bin , kernel_sd_di.bin , kernel_usb.bin and kernel_usb_di.bin files.

    I tried to load Sneek from the Homebrew menu with each of these files. I tried first kernel_sd.bin and renamed it kernel.bin as per instructions to the sd root:\SNEEK\kernel.bin and got the waiting for arm to reset ppc message.

    I tried each of the other files when the first one failed and each give the same message.

    So I don't know what else to do.

    I tried this with d2x-v10-beta53-alt-vWii as well instead of beta52 but still results in the same messages.

    I received no errors during compilation of SNEEK and installed devkitpro as per instructions. I have to assume my problem extends from my IOS80 or maybe because I am on the latest system 5.2.

    No idea, I would have solved this myself but I haven't a clue with PPC programming so I wouldn't know where to start with trying to debug the issue myself. Not only that, but I feel stupid for not backing up my IOS80 with FSTOOLBOX to a wad which would at least give me that sense of relief.

    I read on a thread that you can get IOS80 from another console and install it to your own as it is not unique to each console, but I am not sure that is true and even so... I might need one from a console that is on 5.2, maybe? I am not sure :(
     
  2. gunner007

    gunner007 GBAtemp Advanced Maniac

    Member
    1,506
    368
    Dec 31, 2013
    United States
    Shouldn't need SNEEK at all.

    I have my EMUNand on my USB disk. Pointed WiiFlow to it, and installed my WADS using ShowMiiWad and work fine.

    Use your original NAND.BIN as your emunand then. As you need a copy of IOS80 during compilation.
     
  3. marcioap1

    marcioap1 Advanced Member

    Newcomer
    84
    13
    Sep 15, 2012
    Brazil

    I don't think a patched IOS80 is preventing you from using emunand. As you stated you can use it with the SD Card. Maybe something is wrong with your USB HDD? Also when using emunand wiiflow looks for VC/Wiiware files in the emunand folders, not within the IOS80, I suppose.

    One interesting thing is that you have a patched vWii system menu and had no problems to update your WiiU to 5.2, so people who are claiming that can't update their system probably have another vWii IOS patched.
     
  4. unaxtzero
    OP

    unaxtzero Newbie

    Newcomer
    9
    3
    Oct 8, 2014
    United States
    This is what I originally tried but this is what happens when I try to run wiiware or vc games from my USB disk in a emunand folder as opposed to the sd card:

    1. Select Wii Emunand.
    2. Choose Wiiware or VC game.
    3. Select Play.
    4. Screen goes black for about 15 seconds and I see the USB drive being read from as it's light is blinking...
    5. Wiiflow load screen comes back up as if it can not load the game and reloads back to the start Wiiflow screen.

    I have no issues with the USB Drive as I can load Wii games fine from it when choosing Wii within Wiiflow. I just seem to have issues with trying to use an emunand that is on the USB Drive...

    If I move the emunand folder to the SD Card instead of the USB disk, I make sure to only have a emunand folder on either the SD Card or the USB disk and set it up in WiiFlow accordingly, making sure to reload the cache of course:

    1. Select Wii Emunand
    2. Choose Wiiware or VC game.
    3. Select Play.
    4. Screen goes black for about 3 to 4 minutes, game loads.

    There are some VC games and some Wiiware games that do not load at all though, and I assume that this is due to incompatibilities that are already known about but that is another issue altogether that I will have to deal with...

    I assumed that since I did the IOS80 patch, this would be why the games would not load from the USB Emunand but would from the SD Card Emunand.

    However I completely realize how weird that is because the IOS80 patch simply allows fake-signed wads to be able to be installed to the Wii menu and SD Card. It shouldn't have anything to do with my problem, but understand I am just grasping at straws because I haven't a clue what the issue is.


    So because the games loaded so damn slowly and I wanted to utilize my usb disk since it is 1 TB versus a small 16 gb sd card, I decided to just go ahead and compile SNEEK and try to get that to work.

    However, that may not solve anything anyway. And because of the complexity involved with compiling SNEEK and getting it running on the vWii... It scares most people away, so there isn't many people other than Joostin and those in the thread about it. Not only that, but even if I follow the directions, it may not even work with 5.2 to begin with anyway so I might be just wasting my time.

    Yeah I actually have no clue if I am correct about the patched IOS80, which I stated above that I was just thinking maybe that is what is causing issues.

    Additionally, you might be correct about the usb hard drive but I haven't had any other issues with WiiFlow utilizing it. Only when I want it to run an EmuNand from it and not the SD Card do I encounter problems.

    The USB Disk is:
    1TB Toshiba Canvio Basics 3.0 Portable Hard Drive
    Part Number: HDTB210XK3BA

    http://www.toshiba.com/us/accessories/Storage/Canvio-Basics-Portable-Hard-Drive/1TB/HDTB210XK3BA

    What I am going to do now is

    This is one of the things where I tend to keep quiet and probably many others like me who just browse the forums but never speak up, should probably speak up.

    The have never experienced update problems with the Wii U after patching IOS80. I had IOS80 patched before 5.1 and 5.2 and haven't had problems updating through each.

    Thus, I have to assume that it might not be the IOS80 patch that would be causing the update issues.

    The error messages people are getting with being unable to update are often Nintendo Error messages.

    Nintendo has a train record of crappy error messages that are often generic and unhelpful. Most often it seems as if they have an error flow chart where thousands of unique situations that cause an error all have errors pointing to huge error messages that only vaguely reference them.

    I assume that Nintendo wants to keep its consoles friendly and obviously do not want to resort to kernel panic message dumps... But it is possible to create a complex error system that is both specific and friendly to even kids. Hell, Nintendo of all people should know that kids tend to be more experienced with technology. At least that is how it was when I was growing up.

    But I am going off on a tangent, my bad.
     
  5. unaxtzero
    OP

    unaxtzero Newbie

    Newcomer
    9
    3
    Oct 8, 2014
    United States
    What I decided to do in the interim until I figure out the SNEEK situation is I am moving to a 32GB SD Card now that is class 10 rated at 30 MB/s.

    I am going to see if at least Wiiware and VC loads faster from the Emunand on this SD Card from within Wiiflow since it is a "faster" sd card.

    I realize that, no matter what, its going to load slowly when launched from WiiFlow. But a 3 to 5 minute wait is kind of annoying.

    One thing to note: everything loads fast and fine when installed to my nand and then moved to my SD Card, then loaded from the vWii System menu.

    But I'd rather not manually install and move every title, I am not even sure it will fit as I believe without using SNEEK+DI, there is a limit to the amount of channels that you can install to the vWii/Wii menus... 42 I think is the limit.

    This is where you end up having to use WiiFlow or SNEEK to get past that, which brings me all the way back to the problem again.

    So you can see my problem.
     
  6. unaxtzero
    OP

    unaxtzero Newbie

    Newcomer
    9
    3
    Oct 8, 2014
    United States
    I really hate to double or triple post but I am just updating my problem for anyone in the future who experiences similar issues as I outlined.

    After moving my sd card content to a faster SD Card (class 10, rated 30 MB/s) I then also went into Wiiflow and set up WiiFlow to force load cIOS 249 as default.

    With the faster sd card and forcing WiiFlow to utilize 249 instead of Auto (which I assume causes Wiiflow to scan for compatible cIOS which may contribute to load time), wiiware and VC load faster from the EmuNand on the sd card.

    Oh well, at least the games load now. I do want to get sneek working but I think that is a different problem entirely and I should probably go post on Joostin's forum if I want help with the Sneek problems. Sneek still gives the "Waiting for arm to reset ppc" message.

    Maybe it is the hard drive I am using, I may try a different hard drive with sneek and if it magically works then I will post to this thread with what works.

    I would like to restore my IOS80 back to normal, have a nand.bin and extracted the IOS from this nand.bin that I believe is my virgin vwii.

    But both the patched IOS80 and this original IOS80 appear the same size and v7200. So I am not sure if I have the original or not.
    I would probably have to open up each and do comparisons.

    For anyone reading this in the future, don't be lazy. Back up your nand and put it in a safe place. Then back up your IOS's and not just the nand dump, see this thread for information about backing up individual IOS's to safe wads that are without fakesigns:

    http://gbatemp.net/threads/a-suggestion-for-all-softmodded-vwiis.369198/
    http://www.hacksden.com/showthread.php/8291-A-suggestion-for-all-softmodded-vWii-s

    It is better to be safe than sorry. Don't be lazy!