Anyone else having the black and white scrolling screen problem

Discussion in 'Wii - Hacking' started by robman62, Mar 25, 2009.

  1. robman62
    OP

    Member robman62 GBAtemp Regular

    Joined:
    Nov 23, 2008
    Messages:
    275
    Country:
    United States
    I am using multigame isos, whenever the 0.2 launcher detects the game the screen starts scrolling, and if I manage to start a game....it is in blck and white. is there a fix? [​IMG]




    *EDIT* SOLUTION FOUND here

    http://gbatemp.net/index.php?showtopic=143587
     
  2. ether2802

    Former Staff ether2802 we have the techno...!!

    Joined:
    Oct 14, 2007
    Messages:
    4,350
    Location:
    Pto. Vallarta
    Country:
    Mexico
    Yes, use games from your region, or buy a better TV that can handle both video signals..!! [​IMG]
     
  3. robman62
    OP

    Member robman62 GBAtemp Regular

    Joined:
    Nov 23, 2008
    Messages:
    275
    Country:
    United States
    Every game is from my region (NTSC-U) and I have an hdtv that runs everything perfectly. Xi runs the games fine, so I dont know what you are talking about nor does your post help me at all.
     
  4. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    The scrolling screen and black and white display is a common example of an out of region game trying to display on a TV which isn't compatible with that alternative standard. I'd double check all your games are indeed NTSC and not PAL.
     
  5. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    I looked at the source of the new loader and WiiGator changed some video mode stuff. To me it looks correctly, it looks at the region of the disc(4th caracter of the discID), and load the matching video mode. Before that it loads the menu with the video mode stored in your Wii and if it can't detect the region of the game, it doesn't change the video mode after the region detection. The old version always used the video mode stored in your Wii, that's why the same disc now causes trouble.

    I see at least 2 possible reasons for this problem:
    1. the disc itself has a PAL discID
    2. the disc doesn't have a discID, but the loader detects it somehow as PAL, because at the place where the loader expects the discID, there's the wrong character(but's there's only a 1:50 chance that's identified as PAL then)
     
  6. robman62
    OP

    Member robman62 GBAtemp Regular

    Joined:
    Nov 23, 2008
    Messages:
    275
    Country:
    United States
    it may be #2 because my disks are all ntsc, but could the multigame iso creater somehow have altered the disk's Id erasing it?
     
  7. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    ???
    The complete disc has 1 discID. And that the important one, all games on the disc can be NTSC, but the discID of the whole disc is PAL. I think GCOS asks for the region of the disc, the command line version requires you to specify it. So i'm far from being an expert for gamecube stuff, but there has to be a tool which you can use to check what the discID of your disc is.
     
  8. robman62
    OP

    Member robman62 GBAtemp Regular

    Joined:
    Nov 23, 2008
    Messages:
    275
    Country:
    United States
    I used the Multigame iso creator, on all ntsc games, and in the top right corner it says region, I am always sure to make sure I pick USA, many people seem to be having this problem.....but there is no fix. Is there a way to alter the 0.2 dol file so it reads the region from the wii again?
     
  9. robman62
    OP

    Member robman62 GBAtemp Regular

    Joined:
    Nov 23, 2008
    Messages:
    275
    Country:
    United States
    I know there are more people with this problem have any of you found a fix?
     
  10. zeroxls

    Newcomer zeroxls Newbie

    Joined:
    Mar 15, 2009
    Messages:
    4
    Country:
    United States
  11. EriktheRed

    Newcomer EriktheRed Member

    Joined:
    Feb 12, 2009
    Messages:
    32
    Country:
    United States
    I had the same issue using the DOL from HBC, but if I use the rebooter (via wii backup loader using IOS 249) and load from the disc channel it works fine for me.
     
  12. zeroxls

    Newcomer zeroxls Newbie

    Joined:
    Mar 15, 2009
    Messages:
    4
    Country:
    United States
    so load the wii backup launcher and it should work...
     
  13. robman62
    OP

    Member robman62 GBAtemp Regular

    Joined:
    Nov 23, 2008
    Messages:
    275
    Country:
    United States
    use the wii launcher to play a GC backup? please explain with more detail
     
  14. hyp3rlink

    Newcomer hyp3rlink Member

    Joined:
    Feb 21, 2009
    Messages:
    28
    Country:
    United States
    I had the similar "screen falling" problem with the PAL version of Rogue Trooper on my NTSC Wii.

    I used wiipower's toy-r6 and choose the video mode PAL 576i -> NTSC 480 and the game worked fine.

    And the B/W problem occurred when I used PAL Disaster:DoC, but that just went away when I installed SoftMii.

    So yeah, for me SoftMii seems to be an better option then the gamma launcher.
     
  15. anbu41

    Newcomer anbu41 Member

    Joined:
    Jul 31, 2008
    Messages:
    13
    Country:
    United States
    Well, when you install the patched mIOS, choose the option to have it compatible with the Wii launcher.

    Worked fine for me.
     
  16. zeroxls

    Newcomer zeroxls Newbie

    Joined:
    Mar 15, 2009
    Messages:
    4
    Country:
    United States
    well there no more black and white scrolling lines but it is still in black and white...not sure what to do i tried installed over and doing what to be done..still no solution?
     
  17. robman62
    OP

    Member robman62 GBAtemp Regular

    Joined:
    Nov 23, 2008
    Messages:
    275
    Country:
    United States
    same here, Im gonna try and burn a single GC NTSC game on a disk and see how it goes....I hope im not making a coaster.
     

Share This Page