write protect akaio

Discussion in 'Acekard' started by xman01, Jan 30, 2009.

Jan 30, 2009

write protect akaio by xman01 at 4:21 PM (1,382 Views / 0 Likes) 6 replies

  1. xman01
    OP

    Newcomer xman01 Newbie

    Joined:
    Jan 23, 2009
    Messages:
    8
    Country:
    United Kingdom
    Hi, i recently downloaded moonshell from acekard site, followed the instructions and installed it on my microsd along with akaio and some games.
    Everything went well.
    the following day i thought it would be a good idea to make a backup of the microsd card. I plugged it into the usb adapter and started the direct copy of the contents to the hdd of my laptop.
    First thing that happened is it would say "discovered 2 files" and would stick there forever, I finally narrowed it down to moonshell files.
    I skipped the moonshell nds and folder files, all copied fine so i thought.
    I disconnected the microsd stopping it first the correct way with windows application. inserted it into the acekard.
    This is where the problem started.
    Upon boot up it went to the guru meditation error screen. tried again same thing. Took it out and placed the microsd back in the usb adapter and placed it back in the laptop.
    Decided to check each folders contents, here`s where the fun starts. The _aio folder is completley empty, the rest are fine. I thought nothing of it and decided to copy it from the backup back to the microsd. Low and behold the backup _aio was also empty. I then went to the downloaded version i got from this site and went to install that straight back on the microsd card. Now when i tried that all i get is a message from windows saying the card is write protected?.
    Here are some steps i have tried.

    0-no switch for lock on microsd card or usb adapter
    1-panasonic sd format tool says write protected, unable to format
    2-windows built in format tool same as above.
    3-added reg keys to turn off write protect for the usb microsd card, same result still write protected.
    4-tried all options under default right click properties(defrag,fix errors and so on)
    5-used different adapters including microsd to sd adapter with the switch to unlock, also taped the switch as some people say to do, still says write protected.
    6-used another computer with xp. same result(was using vista x32 bit at first)

    I came to the conclusion the microsd card has gotten hard coded to always write protected on.

    My questions are why only _aio folder affected. The other folders copied fine. only aio folder was wiped.
    My microsd card was 8gb class 6 and transfered at 15mb sec so was ok in that department. why did it suddenly fail during a backup. i was not writing to the card, only reading it`s contents. Why did Moonshell stop the copy?.

    Any advice other than to purchase a new card....
     
  2. Normmatt

    Member Normmatt Former AKAIO Programmer

    Joined:
    Dec 14, 2004
    Messages:
    2,135
    Country:
    New Zealand
    Try formating it from linux, windows is very annoying this way. I have no idea why only the AKAIO folder is corrupted, but i doubt its the only one, the boot sector must have corrupted somehow, this often happens on fake microsd's iirc.
     
  3. doyama

    Member doyama GBAtemp Maniac

    Joined:
    Nov 30, 2006
    Messages:
    1,288
    Country:
    United States
    Seems a tad odd since the microsd format doesn't have any write protection capabilities. Only the full size adapters have that.

    I'm wondering if your reader is somehow defective perhaps. Have you tried using other sd readers?

    One other way you might be able to read it, is to plug the sd card into a camera and transfer via the camera's usb connection.
     
  4. xman01
    OP

    Newcomer xman01 Newbie

    Joined:
    Jan 23, 2009
    Messages:
    8
    Country:
    United Kingdom
    If the boot sector is corrupted, can it be fixed?.
    Yes i have tried other sd readers, same thing.
    Tried a mobile phone and camera to format it , but no go i`m afraid.
    I can read from it fine, but cannot write at all, have no linux os installed on any of my comps.

    Why i`m here would pulling microsd adapters out whilst being used damage the boot sector?. I did not do this but some people on the net claim that it can also happen to microsd cards.
     
  5. cory1492

    Member cory1492 GBAtemp Maniac

    Joined:
    Jun 23, 2005
    Messages:
    1,489
    Location:
    Home, WhereElse?
    Country:
    Canada
    You don't have linux?
    http://damnsmalllinux.org/
    You need to do a low level format, linux is the best way to do this and saying you don't have it installed with all the single CD/DVD bootable live distros out there is no excuse/reason/cop-out - there are tools for windows that try to do the same thing (google "hdd low level format tool" without quotes, just make sure if you use such a thing you are damn sure which drive you are pointing it at.) The tool I have used in windows to do such formats will tell you if any sectors are writeable, and even when it says they aren't it's best to give linux a go anyway - I've recovered one card with not writeable sectors under windows low level format tools that way.

    What actually happens in some cards (usually clones or manufacturer discards that someone has kindly pulled from the rubbish bin and sold to people at cut rates) is the internal memory controller (converting SDIO/serial to memory via buffers and memory accessors) fails to work properly and thus 'locks' (actually breaks is more accurate) write access to physical blocks of memory rendering the card scrap, which when most apps find multiple sectors unwriteable will assume the disk is locked - nothing really to do with the 'boot block' in this case which really only needs to be intact if you are going to 'boot' from the disk (the master partition record and the following ones on the other hand, is a different matter.)
     
  6. LordLandon

    Newcomer LordLandon Member

    Joined:
    Aug 29, 2003
    Messages:
    13
    Country:
    United States
    Your problem seems very similar to mine (see the topic I just made) after using my acekard, the __ak2 or __aio folder, whichever I'm using either becomes empty or inaccesible/corrupted, while the other ones are perfectly fine...
     
  7. kobykaan

    Member kobykaan GBAtemp Addict

    Joined:
    Aug 27, 2007
    Messages:
    2,994
    Country:
    United Kingdom
    you could also try formatting it in a PHONE or other device thats not a computer maby use an adapter to fit a psp or camera [​IMG]
     

Share This Page