Will there ever be a CIA installer/cfw for Ninjhax or IronHax up to 9.9

Discussion in '3DS - Flashcards & Custom Firmwares' started by BurningDesire, Aug 3, 2015.

  1. BurningDesire
    OP

    BurningDesire GBAtemp Psycho!

    Member
    4,964
    5,822
    Jan 27, 2015
    United States
    Behind a screen reading news
    HI. I know that up to 9.2 you can run PastaCFW on Ninjhax but what are the hopes of having a cia installer or custom firmware launcher on Ninjhax 2.0 / IronHax supporting 9.3-9.9? What does it take to make a Cia installer anyways?
     
  2. Arcanuskun

    Arcanuskun GBAtemp Regular

    Member
    208
    81
    May 7, 2014
    two words man. kernel exploit

    without it, devs cannot implement a CIA installer for 9.3+ firmwares.
     
    Jwiz33 likes this.
  3. Intronaut

    Intronaut An star maker

    Member
    726
    433
    Nov 18, 2014
    Cote d'Ivoire
    maybe we could install legit ones, but we still need access to AM service, and currently nobody know what services can be accessed with ninjhax 2.0
     
  4. capito27

    capito27 GBAtemp Advanced Fan

    Member
    873
    1,006
    Jan 19, 2015
    Swaziland
    Not exactly, there is One kind of CIA that you can install without kernel exploit, under very specific conditions (can't go into details), but for general CIA install you are right
     
  5. Zidapi

    Zidapi GBAtemp Psycho!

    Member
    3,038
    1,821
    Dec 1, 2002
    It's not impossible, but it's highly improbable. It could be years before we see another kernel exploit.

    It'd require a monumental fuckup on Nintendo's part.
     
  6. koim

    koim GBAtemp Regular

    Member
    172
    192
    Apr 16, 2015
    France
    two things.
    there's no such thing as an unbreakable system.
    there's no way to know when kernel access will be cracked on 9.3+ (if it ever happens).
     
  7. ezesk8

    ezesk8 Newbie

    Newcomer
    1
    0
    Jan 24, 2015
    Argentina
    Do you mean legit CIA?
     
  8. Psi-hate

    Psi-hate GBATemp's Official Psi-Hater

    Member
    1,665
    1,057
    Dec 14, 2014
    United States
    Houston
    Rohax was patched after 9.2 which gave us the am services. Meaning Ninjhax2.0 doesn't support am services anymore (unless a new exploit is found for that) but what is very mysterious is that Smea added aminit() into the hbmenu a few weeks ago, which by knowledge shouldn't be possible without a new exploit.
     
  9. WateredFire19

    WateredFire19 Banned

    Banned
    643
    215
    Aug 23, 2014
    United States
    Legit CIA's may come very soon. That also means downgrading to 9.2-. Also, Smealum says when Nintendo patches Ninjhax 2.0 with a higher firmware, he will make it open source (just like NH 1.x). That could help VERY much.
     
  10. capito27

    capito27 GBAtemp Advanced Fan

    Member
    873
    1,006
    Jan 19, 2015
    Swaziland
    No, those are still in general CIA category
     
  11. Psi-hate

    Psi-hate GBATemp's Official Psi-Hater

    Member
    1,665
    1,057
    Dec 14, 2014
    United States
    Houston
    Smealum said that Ninjhax 2.0 has a quite a few more added things than Ninjhax. Possibly a new exploit that we don't know about or some sort of modification?
     
  12. Intronaut

    Intronaut An star maker

    Member
    726
    433
    Nov 18, 2014
    Cote d'Ivoire
    Interesting
     
  13. WateredFire19

    WateredFire19 Banned

    Banned
    643
    215
    Aug 23, 2014
    United States
    Could be. I'm almost 100 percent sure that something can be using that source code. Especially with it being 9.3-9.9 compatible and all.
     
  14. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,268
    5,302
    Mar 17, 2010
    Norway
    Alola
    Who knows?
    But it seems to me that now that running homebrew on the newest FW is possible, it makes looking for a kernel exploit much easier. So at least now there's a chance it will happen eventually, unless everyone loses interest in the 3DS before then. It could take years or it might never happen.
    Gateway has been pretty quiet lately, maybe they've found something. After all, it wasn't long after Ninjhax was released before Gateway Ultra showed up out of nowhere. That's just speculation though.
    I think as long as there are skilled hackers working on it, eventually an exploit will be found. It's not impossible to make a 100% secure system but it's very very difficult. Originally the 3DS was thought to be extremely secure and that's been proven not to be the case, so while they may have patched up some holes I wouldn't be surprised if they've missed some. There are already several known kernel exploits, there are probably more where that came from.
    For all we know, skilled hackers like yellows8 may have already found kernel exploits on newer FW, they certainly wouldn't tell us if that was the case.
     
    Last edited by The Real Jdbye, Aug 3, 2015
    NoNAND likes this.
  15. BurningDesire
    OP

    BurningDesire GBAtemp Psycho!

    Member
    4,964
    5,822
    Jan 27, 2015
    United States
    Behind a screen reading news
    Ah. I'm just wondering because I'm very pissed I upgraded my 3ds. I didn't think Gateway 9.2 would happen. So I'm stuck with Ninjhax and no CIA install fuck my life.
     
  16. Pecrow

    Pecrow GBAtemp Maniac

    Member
    1,137
    417
    Jun 23, 2015
    United States
    Ouch,