What firmware is in new DSi units?

Discussion in 'NDS - Console and Game Discussions' started by Rafinesque, Nov 29, 2010.

  1. Rafinesque
    OP

    Rafinesque GBAtemp Regular

    Member
    128
    0
    Jun 21, 2010
    United States
    I want to buy a DSi that's compatible with the flash carts that are available. What firmware is in the new units on store shelves?
     
  2. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,103
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    1.4 mostly, maybe 1.4.1 if you're unlucky... but both have been bypassed by every single cart worth it's money anyways.

    Do you already have a cart, or are you looking?
     
  3. ShadowSoldier

    ShadowSoldier GBAtemp Guru

    Member
    9,383
    3,300
    Oct 8, 2009
    Canada
    Most likely 1.4. Unless you somehow got a one in a million 1.4.1.
     
  4. Evo.lve

    Evo.lve All that you could be.

    Member
    1,786
    21
    Oct 11, 2010
    Away from you.
    It's most likely 1.4

    A used one may come as 1.3 (like mine)

    But yeah, as Rydian said, every single cart worth the money has a 1.4.1 bypass already anyway.

    Just don't update your DS.

    EDIT: Btw, ShadowSoldier, congrats on 1000 posts.
     
  5. Rafinesque
    OP

    Rafinesque GBAtemp Regular

    Member
    128
    0
    Jun 21, 2010
    United States
    What kind of store do you think would have the oldest stock (USA)?
     
  6. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,103
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    You're not going to find a new one with less than 1.4. 1.4 was pushed out around the beginning of the year.

    When you buy your cart, buy it from a place that offers a flashing/update service (like shoptemp, this site's official partner store) and get that service when you order the cart, then they'll update it to bypass 1.4.1 so it's ready to use when you get it.

    The Acekard 2i and DSTwo are two main recommendations.
     
  7. Rafinesque
    OP

    Rafinesque GBAtemp Regular

    Member
    128
    0
    Jun 21, 2010
    United States
    I know all about the flash carts (I've been doing this longer than some of you have been alive :-) )

    I just want to make sure I get a compatible DSi. I had a DSi with 1.0 firmware, and sold it on Ebay, without realizing there are some hardware advantages, even for DS games (I already had two DS Lite's).
     
  8. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,103
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Like I said, it's only up to 1.4.1, and any card worth it's salt works on 1.4.1 (after being updated).
     
  9. Rafinesque
    OP

    Rafinesque GBAtemp Regular

    Member
    128
    0
    Jun 21, 2010
    United States
    Thanks. I'll go out and buy one. I'm hoping the new CycloDS DSi cart lives up to their reputation....