VBA sound is terrible

Discussion in 'Wii - Hacking' started by artisan, Jul 9, 2008.

  1. artisan
    OP

    artisan GBAtemp Regular

    Member
    101
    0
    Jul 30, 2007
    United States
    is anyone else having this problem? i looked around the forums and other sites and havent found anyone mentioning this so it could be just me. the sound is screwed, obviously not sounding like its SUPPOSED to be. can anyone help?
     
  2. PKGINGO

    PKGINGO GBAtemp Regular

    Member
    135
    0
    Jul 27, 2007
    United States
    Oddly the sound fixes itself after playing for a long time... seems to reset back to the odd state after doing an operation with SRAM.
     
  3. harrybuttox

    harrybuttox GBAtemp Regular

    Member
    277
    0
    Apr 29, 2008
    United States
    thats normal...it even says so in the read-me
     
  4. Sick Wario

    Sick Wario Club Nintendo

    Member
    1,229
    63
    Jul 24, 2006
    NNID: godrugal
    sound problem is in and out, but the damn inverted/screwed colours (component) bug is killing me
     
  5. PKGINGO

    PKGINGO GBAtemp Regular

    Member
    135
    0
    Jul 27, 2007
    United States
    Tell the people that make devkitppc to fix their compiler (I have 4 GB of ram, and gcc craps out after using 2.7 gb, on both XP 32 and vista 64). Either release 64bit compilers, or fix the bug that makes gba.o eat the computer.... Then I might be able to help.
     
  6. kickflip720

    kickflip720 Newbie

    Newcomer
    2
    0
    May 30, 2008
    I PM'd emu_kidid about the compilation problems at TehSkeen.com. He was very helpful.

    It appears that GBA.cpp will not compile with devkitpro r15 with -O2 optimisation switched on. Turn it off (-O0) and it will compile but will be extremely slow. To get the full speed compilation you have to compile GBA.cpp with devkitpro r13 with -O2 and then use this GBA.o file when compiling and linking in r15 (again with -O2 optimisation). A hassle but it works.

    I hope this is of use PKGINGO.
     
  7. PKGINGO

    PKGINGO GBAtemp Regular

    Member
    135
    0
    Jul 27, 2007
    United States
    Yeah, I have spoken to emu_kidid about this before, he also uses a nonstandard library path. It's just such a messy tool chain right now, and there are some weird memory leaks. Plus I still have a lot to learn about the wii anyway. I'll see what I can do when I get some time if no one else steps up. I only want this to work primarily for MOTHER 3, so chances are I might use an O5 optimization to help when it almost dies from what I hear.