USB Loader GX - No Devolution option, Can't Load GC Games

Discussion in 'Wii - Backup Loaders' started by Jedishaft, Aug 8, 2014.

  1. Jedishaft
    OP

    Jedishaft Newbie

    Newcomer
    3
    0
    Aug 7, 2014
    United States
    Sort of new to all of this but most things have worked well without many hiccups or having been able to find the answers online. Can't really figure this one out though and I've looked everywhere.

    I have a partitioned HDD, first partition fat 32, second ntfs. First(Fat32) is for GameCube Games using Devolution(V r200) having been ripped with CleanRip (v2.0). The Second(NTFS) for Wii games also having been ripped using CleanRip. USB's are set up to work and games can be played by both partitions, just not in the same program...

    Here's where it get's strange though. Every tutorial I've read talks about USB Loader GX having devolution support, and I have the newest version (3.0) but there is nothing in the settings to choose it (despite many tutorials stating that it should be there as an option), it plays the wii games magnificently (except for skyward sword but I've read that I needed to watch the motion + video first by playing the game first to get it to work, will test soon) but it won't find or play the GameCube Games. Can't seem to get it to use Dios Mios either, I've tried loading several versions of the WAD for Dios Mios but none seem to change anything nor can I find out a way to check if it did change anything.
    (yes gamecube games are enabled in USB Loader GX and if put into the same directory/file structure as the wii games they show up sort of... but without a loading screen/icon, like they are just a blank space that can be clicked, but won't load anything, all it does is go blank, restart usb loader gx and freeze in the process of reloading it).

    Meanwhile WiiFlow plays the Gamecube games wonderfully, but freezes everytime it tries to play a wii game.

    my preference would be to get USB loader gx to run the gamecube games since I like it's layout, simplicity and how well it works with the wii games, but if there's a fix for the wiiflow (and a way to have it show things in more of a grid layout) then that would be just as good. I just want both the wii and gamecube games to play in the same program.


    not really sure how to proceed or what to do, any help would be appreciated
    thanks in advance
    -Mike



    below are system stats if they will help, I'm not sure if they will or not



    USB Loader GX Settings (in the order as they appear, only video output options are skipped as noted)

    Loader Settings
    (some screen/resolution settings, likely irrelevant so skipped)
    Ocarina - Off
    Boot/Standard - IOS249
    Quick Boot - Off
    Error 002 fix - Anti
    Block IOS Reload - Auto
    Return to - USB Loader GX (don't think it works, but that's another thing)
    Nand Saves Emulation - Off
    Nand Chan. Emulation - Full
    Hooktype - None
    Wiird Debugger - Off
    Debugger Paused Start - Off
    Channel Launcher - Main DOL
    GC Force Interlace - Off
    DML NMM Mode - Off
    DML LED Activity - Off
    DML PAD Hook - Off
    DML No Disc - On
    DML Debug - Off

    Hard Drive Settings
    Game/Install Partition (Fat 32) - (I don't think it matters which I pick, it doesn't change anything)
    Multiple Partitions - On
    USB Port - Both Ports
    Install Directories - Gamename [..] - I've tried all options here too, no change
    Game Split Size - Split each 4gb
    Install Partitions - All Partitions
    GC Install Compressed - On
    GC install 32k Aligned - On
    Sync Fat 32 FS info (have not tried yet)

    Custom Paths (all default except the main GameCube Path)
    Main GameCube Path - USB2:/Games/
    SD GameCube Path - sd:/Games/

    Wii is v4.3u
    Letterbomb hack
    Homebrew Channel - V 0.3.9e (top of homebrew channel says 1.1.2 IOS58 v24.32)
    USB Loader GX - V 3.0r1180
    Ios249 (re:21005)
    d2: v5 base37
    cIOS - I think so, but can't figure out how to verify
    Dios Mios - attempted but doesn't seem like it
    Model - RVL-001(USA)
     
  2. SuperrSonic

    SuperrSonic GBAtemp Advanced Fan

    Member
    662
    220
    Dec 9, 2011
    No, 3.0 is not the latest build with devolution support. See the USB Loader GX thread and look for Cyan's signature, it has the link to the latest build.
    Also you should just stick with FAT32 for Wii games, having them on NTFS makes no difference, unless you need it for a good reason don't use it.

    Your other issues I don't know; once you have the DM wad installed it should work provided you have a compatible hdd and a loader up to date, using ulgx 3.0 may cause issues if the wad is one of the newer versions.
     
  3. Jedishaft
    OP

    Jedishaft Newbie

    Newcomer
    3
    0
    Aug 7, 2014
    United States
    cool that actually helped a bit, updated to a newer version now the options are there, enabled them and put the games in the right directory structure, now they show up in the game library but it's asking for a devolution loader.bin, but that doesn't exist, my devolution only has a boot.dol in it's folder, tried renaming that to loader.bin and it only made it freeze on a black screen.

    Also got dios mios installed, thank you, actually helped a lot.

    PS the NTFS was just because some of the Wii games were larger than 4g also it's supposed to be a touch faster so I figured if it could work it would be worth doing. But your right, probably not actually necissary because you can split or scrub the iso's, just sort of a nice to have.

    thanks again
    -Mike
     
  4. Jedishaft
    OP

    Jedishaft Newbie

    Newcomer
    3
    0
    Aug 7, 2014
    United States
    Nevermind the last comment, I found the Loader.bin in the devolution source code files, put it into the usb loader gx folder and now it works great.
    Thanks again for your help man, you are awesome
    -Mike