Updating Wii

Discussion in 'Wii - Hacking' started by BMasterP, Jan 24, 2009.

Jan 24, 2009

Updating Wii by BMasterP at 10:03 AM (782 Views / 0 Likes) 3 replies

  1. BMasterP
    OP

    Member BMasterP GBAtemp Regular

    Joined:
    Nov 29, 2006
    Messages:
    147
    Location:
    DOESBURG
    Country:
    Netherlands
    I read all over the forum, not to update the wii using a game that asks for it.

    What if the game needs te be updated in order to work(i read SSBM needs te have the system version updated). Will a program like wiibrickblocker or w.i.u work patching the iso? or is there another option? I know i can install starfall but from what i have read it just keeps te wii from installing the update, will the game still work then?

    i realy tryed to search this but no concrete awnsers(english isnt my native language so maybe i'm typing the wrong keywords)


    Just read this post http://wiki.gbatemp.net/wiki/index.php/Hac...AQ#System_Menus (saw it down a post couldn't find it using search.

    from reading this part

    IOS16

    Originated on the leaked Wii disc from Nintendo, often referred to as the kissing pink fish disk. Used by the scene to restore the truncha bug to updated systems as 16 is only used by this disk and had not been patched. IOS16-64-v257-prod.wad
    [edit] IOS38

    Needed by some newer games. Can be installed manually to avoid updating IOS38-64-v3609.wad
    [edit] IOS53

    Needed by some newer games. Can be installed manually to avoid updating IOS53-64-v4113.wad
    [edit] IOS55

    Needed by some newer games. Can be installed manually to avoid updating IOS55-64-v4633.wad


    i assum that just installing a newer IOS(in this case IOS55 is the latest) this will "update" my wii manualy to play the latest games?
     
  2. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Every game has a IOS it wants to use. The latest ones want IOS38, IOS53 and IOS55, older ones want 9,21,33,36 or 37(maybe more). You only need to install the IOS the game wants in order to be able to play it from the disc channel. But if you didn't turn off disc updates somehow, it will still prompt you to update, even if it would be fully playable.

    SoftChip tells you which IOS the game wants, you find this information in the logfile, or the IOS Version patcher tells it to you. Getting the IOS wad is easy too: Just run wufe and extract all IOS wads from the disc, or open the .iso with Trucha Signer or WiiScrubber and copy the wad to your sd card.
     
  3. BMasterP
    OP

    Member BMasterP GBAtemp Regular

    Joined:
    Nov 29, 2006
    Messages:
    147
    Location:
    DOESBURG
    Country:
    Netherlands
    I get the point, only question left is that you mention "You only need to install the IOS the game wants in order to be able to play it from the disc channel." i assume this goes for the loaders as well?
     
  4. WiiPower

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Well i don't know which IOS is used by Gecko OS, it's the IOS the game wants or IOS36. But Gamma always uses IOS249, and SoftChip is configurable. For these both it's absolutlely unimportant if the IOS the game wants is installed or not. Please don't delete your IOS now, as this will result in a brick!
     

Share This Page