Unable to run NinjHax 4.2.0

Discussion in '3DS - Homebrew Development and Emulators' started by stapled, Jun 1, 2016.

  1. stapled
    OP

    stapled Member

    Newcomer
    21
    2
    Sep 20, 2007
    Canada
    I am running 4.2.0 on a O3DS that was downgraded with gateway. I was following the guide for fixing black screens when booting Luma3DS and now I can no longer boot NinjHax, it just crashes.

    I installed the NATIVE104.cia on my 4.2.0 sysNand. Any idea how to fix this?
     
  2. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,336
    5,343
    Mar 17, 2010
    Norway
    Alola
    You might be screwed, pretty sure the exploits that Ninjhax 1.1 uses are patched in 10.4 FIRM, and Ninjhax 2.x won't work below 9.0.
    You're lucky you didn't brick tbh.
     
    vb_encryption_vb likes this.
  3. Pikasack

    Pikasack What is a title

    Member
    635
    203
    Apr 27, 2015
    Canada
    Since you updated the FIRM, you could try using the 10.4 exploit for Ninjhax 2.0 and perform a downgrade to 4.2.0 again or install the file again if it's legit.
     
  4. Deck of Noobs

    Deck of Noobs Politically Incorrect

    Member
    774
    1,126
    Apr 9, 2016
    United States
    3ds.guide
    ( ͡° ͜ʖ ͡ °)
     
    nero99, Xenon Hacks, Minnow and 4 others like this.
  5. stapled
    OP

    stapled Member

    Newcomer
    21
    2
    Sep 20, 2007
    Canada
    NinjHax 2.0 installs but crashes when start it. NinjHax 1 either crashes when I scan the QR code or launches the browser and freezes depending on what one I scan.

    Do you think updating the system with a game cartridge would help?
     
  6. Quantumcat

    Quantumcat Dead and alive

    Member
    11,594
    6,234
    Nov 23, 2014
    Australia
    Canberra, Australia
    Yes I think it will - I thought Ninjhax 2.x required greater than or equal to 9.0? And it doesn't require the browser.
     
  7. dpad_5678

    dpad_5678 GBAtemp's Memelord

    Member
    1,702
    1,259
    Nov 19, 2015
    United States
    Ninjhax 1.x needs the browser. Hax 2.x uses the home menu.
     
    Last edited by dpad_5678, Jun 2, 2016 - Reason: I fucked up
  8. Quantumcat

    Quantumcat Dead and alive

    Member
    11,594
    6,234
    Nov 23, 2014
    Australia
    Canberra, Australia
    Are you sure? I used it on a console updated to 9.2 from 2.1 with a cartridge. So I think it only had a -3 browser. And I saw many people advising others to update to 9.2 and use Ninjhax 2.0, when they were trying to install rxTools and they didn't have a browser or a DS flashcart.
     
  9. dpad_5678

    dpad_5678 GBAtemp's Memelord

    Member
    1,702
    1,259
    Nov 19, 2015
    United States
    Yeah sorry I got it mixed up.
     
    Quantumcat likes this.
  10. stapled
    OP

    stapled Member

    Newcomer
    21
    2
    Sep 20, 2007
    Canada
    Well the only game that I can use to update is Majoras Mask. Will that overwrite the NATIVE104.cia I installed?
     
  11. dpad_5678

    dpad_5678 GBAtemp's Memelord

    Member
    1,702
    1,259
    Nov 19, 2015
    United States
    No, since it contains an older firmware (7.2.0 or 9.2.0).
     
  12. driverdis

    driverdis I am Justice

    Member
    2,440
    935
    Sep 21, 2011
    United States
    1.048596β
    you will need to use MSEThax to boot a CFW, which I then recommend booting SysUpdater and updating to 9.2 manually. your FIRM will be replaced as part of the downgrade and 10.4 FIRM still allows for downgrading so that should not be an issue.

    if you update past 4.x via cart, you may be stuck updating to 11.0 then doing the hardmod FIRM downgrade method.

    I recommend using PastaCFW via MSEThax
     
    Last edited by driverdis, Jun 2, 2016
  13. stapled
    OP

    stapled Member

    Newcomer
    21
    2
    Sep 20, 2007
    Canada
    I can't set up MSEThax. Using a DS flashcart gives me "An error has occurred. Press and hold the Power button to turn the system off."
     
  14. driverdis

    driverdis I am Justice

    Member
    2,440
    935
    Sep 21, 2011
    United States
    1.048596β
    then you are stuck updating to 11.0 then having someone/or yourself hardmod the console to downgrade the FIRM. from there, you can downgrade to 9.2 via following the OTP guide.
     
  15. zoogie

    zoogie simple pimp tool

    Member
    6,518
    8,393
    Nov 30, 2014
    United States
    One alternative may be to wait until a 10.4-10.7 game comes out*, then you can update then re-downgrade. Your browser will be stubbed though, unfortunately. Shouldn't be an issue with cubic ninja handy.

    *should be soon, EUR recently got a 10.5 game, US is still only <=10.3 for now.
     
  16. driverdis

    driverdis I am Justice

    Member
    2,440
    935
    Sep 21, 2011
    United States
    1.048596β
    I thought cubic ninja (ninjhax) required a working web browser, any carts with 9.9 or up will have a subbed browser, which is worse than even an old browser which older game cart updates left alone.
     
  17. zoogie

    zoogie simple pimp tool

    Member
    6,518
    8,393
    Nov 30, 2014
    United States
    No, ninjhax 2.x doesn't care about the browser. It doesn't touch it.
    Ninjhax 1.x did.
     
    Quantumcat likes this.
  18. stapled
    OP

    stapled Member

    Newcomer
    21
    2
    Sep 20, 2007
    Canada
    So 10.3 wouldn't help even though it's the same QR code for CN?
     
  19. zoogie

    zoogie simple pimp tool

    Member
    6,518
    8,393
    Nov 30, 2014
    United States
    The QR is not the same (assuming you're taking about 10.3 vs 10.4). That's not important though.
    The issue is you currently have native firm for 10.4 and if you updated with a 10.3 cart, you'd have a mismatched native firm/ctrnand combo which puts you at risk for a brick.

    Tell you what, I have a nand mod so I can test your situation. I'll try a couple of things and let you know. (just to confirm, you have a U region system, correct?)
     
    Last edited by zoogie, Jun 2, 2016