Tutorial:How to fix The Legend Of Zelda Skyward Sword

Discussion in 'Wii - Tutorials' started by Nobunaga, Nov 12, 2011.

  1. Nobunaga
    OP

    Member Nobunaga Empty

    Joined:
    Apr 19, 2010
    Messages:
    2,052
    Country:
    Greece
    [​IMG]

    I created this topic because a lot of people had some problems with the game.
    So here is how i fixed zelda.

    1.From the place you downloaded the game had a package of WAD (IOS 2XX) files which i won't provide
    2.Download Wad manager 1.7 Link: [ft]http://filetrip.net/f11391-WAD-Manager-1-7.html[/ft]
    3.Transfer the was file to a USB or a SD card so you can install them.
    4.Go to Homebrew Channel and start Wad manager 1.7
    5.Select IOS 249 and install all the wad files (2XX)
    6.Download the latest USB Loader GX (It's in WAD so i can't provide)
    7.Go to settings and Enable autoreload IOS (Not Auto)
    8.Play the game!

    To play the game it requires a WM+
    The newest controllers have this one.

    Hope this will help you! :D
     
  2. Langin

    Member Langin GBAtemp's kpop addict

    Joined:
    Jul 29, 2008
    Messages:
    4,637
    Location:
    The Hague
    Country:
    Netherlands
    WM+ is WiiMotion+

    To be sure. ^^
     
  3. MewtwoEx

    Newcomer MewtwoEx Member

    Joined:
    Sep 12, 2009
    Messages:
    19
    Country:
    Mexico
    7.Go to settings and Enable autoreload IOS (Not Auto)

    Question here, that will be ON to Block IOS Reload yes?

    if so.. it still doesnt work, I get prompt back to the Wii Menu
     
  4. Nobunaga
    OP

    Member Nobunaga Empty

    Joined:
    Apr 19, 2010
    Messages:
    2,052
    Country:
    Greece
    Hmm what FW is your wii on?
    Maybe that's a problem too :/
     
  5. Heran Bago

    Member Heran Bago Where do puyo come from?

    Joined:
    Nov 6, 2005
    Messages:
    2,846
    Location:
    Foggy California
    Country:
    United States
    Try running the game with alt dol (player.dol) once and then go back to how you tried previously.
     
  6. unopepito06

    Newcomer unopepito06 Advanced Member

    Joined:
    Sep 12, 2009
    Messages:
    51
    Location:
    Washington
    Country:
    United States
    Thanks man, you're a lifesaver. Worked perfectly!

    For others, the game was booting me back to the Wii menu. I just installed all the IOS wads, booted it with Neogamma with alt dol, and it ran fine. Tested booting it with Loader GX after that and that worked fine too, and I didn't even change the autoreload.
     
  7. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,402
    Location:
    Engine room, learning
    Country:
    France
    You don't even need the new cIOS (which are leaked from alpha version, and not released officially yet).

    Like for every games using the Motion+:
    Just watch the player.dol video to explain the Wii motion+ if you never watched it before, and that's all.
    All future WiiMotion+ games will work without the need to watch the video again.
     
    Slimmmmmm likes this.
  8. NayibPastrana

    Newcomer NayibPastrana Newbie

    Joined:
    Nov 16, 2011
    Messages:
    1
    Okay, quick question...

    What exactly does the fix do? I found it, and am currently downloading it, but I'm not sure what it does. Is it really necessary?
     
  9. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,402
    Location:
    Engine room, learning
    Country:
    France
    like I told just above, no it's not needed at all.

    The "fix" is just the latest version of the cIOS, in a pack of "5 wad files" which will install 5 different revisions of d2x v7 alpha5 (for developers only). You will have a cIOS installed in slot 247/248/249/250/251 ! You really don't need that!


    You have two scenarios to play the game :
    1. You already watched the Wii motion+ video:
      You don't need the "fix" pack at all. just play Zelda like any other games.
    2. You never watched the Wii Motion+ video:
      • solution 1 (dirty, but quick): Go to your loader setting, select Alternative dol method, and pick the "player.dol". Launch the game, it will show you the Wii motion+ video and reboot the system. Go back to your game setting in the loader, and disable alternative dol. Launch the game and Enjoy :D
      • Solution 2 (clean): Install D2x v6 if you don't have it yet. install in slot 249 the base 56. Go to your USBloader setting (or game setting) and enable the option "Block IOS reload". Launch the game, it will show you the video only the first time you launch it. and instead of rebooting the system it will launch the game. Enjoy :D
        (PS: you can disable "block IOS reload" once you watched the video M+, it won't try to load it again ever)


    The "fix" is only provided so the users install the latest D2x in order to enable "block IOS reload" option.
    But it's not required at all, you can play the game without this option, you ONLY NEED to watch the video Motion+ once (maybe you already did with Wii Sport Resort? then it's fine, you won't ever have to watch it again).

    Zelda has no protection at all, it's just a "common" Wii motion+ game : you need to watch the video.


    The "tutorial" in the first post of this topic is wrong.
    It told the user to do unnecessary steps (without checking their current config first), and says that USBloaderGX is only available as WAD file so he can't give it (which is wrong, a dol exists, and the wad is legal).
    The tutorial rely on pirated content that the user has to find, instead of providing legal installers. It's not very helpful for a tutorial if it cover only 1 released torrent file which included the said "fixed wad" and not being a global tutorial (for example for people buying the original but not wanting to update their wii and play only on USB loaders).

    Elza, If you can, please update the tutorial to be legal and cover all possible user's situation.
     
    1 person likes this.
  10. y0wni

    Newcomer y0wni Member

    Joined:
    Jul 18, 2009
    Messages:
    12
    Location:
    dusty keyboard
    Country:
    Netherlands
    I asume this topic is about a certain bug which won't let you past the introduction video?
    I used 4.2e with the recommended modmii repack, which included ios56 249 222 251 I believe and it started just fine with usbloader gx.

    However I got the blackscreen 2 times now while playing, is the alternative dol loading recommended for me or should I just install d2x v6 which I believe I already have.

    Also what if I update to 4.3e?, will I just be able to redo hackmii and be able to run games on a stable 4.3e?
     
  11. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,402
    Location:
    Engine room, learning
    Country:
    France
    Alternative dol = The video instead of the game.
    It has nothing to do with the black screens, and won't help you play the game ... it will only show you the video...again.


    You can update to 4.3E and can re-hack the Wii.
    Just know that Wii system menu version has NOTHING to do with playing a game (I'm on 3.2E and all games are working).
    There's no "stable" system menu for games.

    Games runs with IOS not system menu.
    What you need (if you need something stable) is a Stable cIOS + Stable USBloader.


    Latest USBloader GX (beta) has problem with black screen, use v2.3 if you are using a beta and have black screen when launching a game.


    If you have black screen while playing Zelda (loading another map), then it's another problem that a lot of users have with all USBloaders and different settings, and we don't know the cause yet.
    It could be a bad dump.
    It could be caused by any patches (Ocarina? Block IOS reload? something else? use all default settings.)
     
  12. y0wni

    Newcomer y0wni Member

    Joined:
    Jul 18, 2009
    Messages:
    12
    Location:
    dusty keyboard
    Country:
    Netherlands
    Even with Block IOS off or on it still creates a blackscreen, perhaps i need some sort of new cIOS


    Fixed, it was the early release ISO.
     
  13. AndrevanRijn

    Newcomer AndrevanRijn Newbie

    Joined:
    Apr 24, 2012
    Messages:
    3
    Country:
    United States
    No problems here...
    Bought it in original 25th anniversary edition...
    Great soundtrack btw...
     
  14. Hielkenator

    Member Hielkenator GBAtemp Psycho!

    Joined:
    Feb 7, 2010
    Messages:
    4,176
    Country:
    Netherlands
    No, not needed at all.
     

Share This Page